Lucene search
+L

26 matches found

Kitploit
Kitploit
•added 2026/10/08 5:32 p.m.•23 views

wolfCOSE

wolfCOSE wolfCOSE는 핵심 CBOR 및 COSE 표준을 구현한 경량 고속 C 라이브러리로, 암호화를 위해 wolfSSL을 기반으로 합니다. 지원 표준 및 RFC 핵심 사양: RFC 8949 - Concise Binary Object Representation CBOR RFC 9052 - CBOR Object Signing and Encryption COSE RFC 9053 - COSE algorithms RFC 9864 - Fully-Specified Algorithms for JOSE and COSE RFC...

6.3AI score
SaveExploits0References1
OSV
OSV
•added 2026/09/06 6:17 p.m.•10 views

AZL-99798 CVE-2026-82208 affecting package mysql 8.0.46-1

With the wolfSSL backend, when CA caching is enabled and an CURLOPTSSLCTXFUNCTION callback replaces the trust store, libcurl can silently reinstall the cached store after the callback returns. A certificate trusted by the cached store but rejected by the callback-selected store is then incorrectl...

7.5CVSS7.2AI score0.00407EPSS
SaveExploits1References1
OSV
OSV
•added 2026/09/06 6:17 p.m.•13 views

AZL-99849 CVE-2026-82208 affecting package rust 1.90.0-10

With the wolfSSL backend, when CA caching is enabled and an CURLOPTSSLCTXFUNCTION callback replaces the trust store, libcurl can silently reinstall the cached store after the callback returns. A certificate trusted by the cached store but rejected by the callback-selected store is then incorrectl...

7.5CVSS7.2AI score0.00407EPSS
SaveExploits1References1
OSV
OSV
•added 2026/09/06 6:17 p.m.•12 views

AZL-99840 CVE-2026-82208 affecting package rust 1.75.0-30

With the wolfSSL backend, when CA caching is enabled and an CURLOPTSSLCTXFUNCTION callback replaces the trust store, libcurl can silently reinstall the cached store after the callback returns. A certificate trusted by the cached store but rejected by the callback-selected store is then incorrectl...

7.5CVSS7.2AI score0.00407EPSS
SaveExploits1References1
OSV
OSV
•added 2026/09/06 6:17 p.m.•12 views

AZL-99756 CVE-2026-82208 affecting package curl 8.11.1-11

With the wolfSSL backend, when CA caching is enabled and an CURLOPTSSLCTXFUNCTION callback replaces the trust store, libcurl can silently reinstall the cached store after the callback returns. A certificate trusted by the cached store but rejected by the callback-selected store is then incorrectl...

7.5CVSS7.2AI score0.00407EPSS
SaveExploits1References1
Cvelist
Cvelist
•added 2026/09/06 5:49 p.m.•68 views

CVE-2026-82208 wolfSSL CA-cache hit overrides callback

With the wolfSSL backend, when CA caching is enabled and an CURLOPTSSLCTXFUNCTION callback replaces the trust store, libcurl can silently reinstall the cached store after the callback returns. A certificate trusted by the cached store but rejected by the callback-selected store is then incorrectl...

0.00407EPSS
SaveExploits1References3
EUVD
EUVD
•added 2026/09/06 5:49 p.m.•17 views

EUVD-2026-72152

With the wolfSSL backend, when CA caching is enabled and an CURLOPTSSLCTXFUNCTION callback replaces the trust store, libcurl can silently reinstall the cached store after the callback returns. A certificate trusted by the cached store but rejected by the callback-selected store is then incorrectl...

7.2AI score0.00407EPSS
SaveExploits1References3
OSV
OSV
•added 2026/09/02 8:00 a.m.•13 views

CURL-CVE-2026-82208 wolfSSL CA-cache hit overrides callback

With the wolfSSL backend, when CA caching is enabled and an CURLOPTSSLCTXFUNCTION callback replaces the trust store, libcurl can silently reinstall the cached store after the callback returns. A certificate trusted by the cached store but rejected by the callback-selected store is then incorrectl...

7.5CVSS7.2AI score0.00407EPSS
SaveExploits1
Positive Technologies
Positive Technologies
•added 2026/09/02 12:00 a.m.•23 views

PT-2026-84658

Name of the Vulnerable Software and Affected Versions libcurl affected versions not specified Description When using the wolfSSL backend with CA caching enabled, a flaw exists where the CURLOPT SSL CTX FUNCTION callback can be overridden. If this callback replaces the trust store, libcurl may...

7.5CVSS7.1AI score0.00407EPSS
SaveExploits1References28
Hacker One
Hacker One
•added 2026/08/27 8:28 a.m.•22 views

curl: CVE-2026-82208: wolfSSL CA-cache hit overrides callback

Summary With the wolfSSL backend, when CA caching is enabled and an CURLOPTSSLCTXFUNCTION callback replaces the trust store, curl can silently reinstall the cached store after the callback returns. A certificate trusted by the cached store but rejected by the callback-selected store is then...

7.5CVSS7AI score0.00407EPSS
SaveExploits1
RedhatCVE
RedhatCVE
•added 2026/07/29 12:53 p.m.•16 views

CVE-2026-54919

cpp-httplib is a C++11 single-file header-only cross platform HTTP/HTTPS library. In affected Mbed TLS backend versions from 0.31.0 through 0.46.1 and wolfSSL backend versions from 0.33.0 through 0.46.1, when cpp-httplib is built with CPPHTTPLIBMBEDTLSSUPPORT or CPPHTTPLIBWOLFSSLSUPPORT and a...

7.4CVSS7.3AI score0.00264EPSS
SaveExploits0References2
SUSE CVE
SUSE CVE
•added 2026/07/15 5:03 a.m.•18 views

SUSE CVE-2026-54919

cpp-httplib is a C++11 single-file header-only cross platform HTTP/HTTPS library. In affected Mbed TLS backend versions from 0.31.0 through 0.46.1 and wolfSSL backend versions from 0.33.0 through 0.46.1, when cpp-httplib is built with CPPHTTPLIBMBEDTLSSUPPORT or CPPHTTPLIBWOLFSSLSUPPORT and a...

7.4CVSS7.7AI score0.00264EPSS
SaveExploits0References3
NVD
NVD
•added 2026/07/10 5:16 p.m.•20 views

CVE-2026-54919

cpp-httplib is a C++11 single-file header-only cross platform HTTP/HTTPS library. In affected Mbed TLS backend versions from 0.31.0 through 0.46.1 and wolfSSL backend versions from 0.33.0 through 0.46.1, when cpp-httplib is built with CPPHTTPLIBMBEDTLSSUPPORT or CPPHTTPLIBWOLFSSLSUPPORT and a...

7.4CVSS0.00264EPSS
SaveExploits0References3
CVE
CVE
•added 2026/07/10 4:06 p.m.•59 views

CVE-2026-54919

cpp-httplib on Mbed TLS and wolfSSL backends was vulnerable to a TLS certificate chain verification bypass for IP-literal hosts (affecting v0.31.0–0.46.1) when server verification was enabled; SSLClient/Client could skip chain validation and Mbed TLS WebSocketClient could skip verification. The i...

7.4CVSS7.3AI score0.00264EPSS
SaveExploits0References3Affected Software1
Cvelist
Cvelist
•added 2026/07/10 4:06 p.m.•56 views

CVE-2026-54919 cpp-httplib: TLS certificate chain verification bypassed for IP-literal hosts on Mbed TLS and wolfSSL backends

cpp-httplib is a C++11 single-file header-only cross platform HTTP/HTTPS library. In affected Mbed TLS backend versions from 0.31.0 through 0.46.1 and wolfSSL backend versions from 0.33.0 through 0.46.1, when cpp-httplib is built with CPPHTTPLIBMBEDTLSSUPPORT or CPPHTTPLIBWOLFSSLSUPPORT and a...

7.4CVSS0.00264EPSS
SaveExploits0References3
EUVD
EUVD
•added 2026/07/10 4:06 p.m.•29 views

EUVD-2026-42942

cpp-httplib is a C++11 single-file header-only cross platform HTTP/HTTPS library. In affected Mbed TLS backend versions from 0.31.0 through 0.46.1 and wolfSSL backend versions from 0.33.0 through 0.46.1, when cpp-httplib is built with CPPHTTPLIBMBEDTLSSUPPORT or CPPHTTPLIBWOLFSSLSUPPORT and a...

7.4CVSS6.9AI score0.00264EPSS
SaveExploits0References3
attackerkb
attackerkb
•added 2026/07/10 4:06 p.m.•17 views

CVE-2026-54919

cpp-httplib is a C++11 single-file header-only cross platform HTTP/HTTPS library. In affected Mbed TLS backend versions from 0.31.0 through 0.46.1 and wolfSSL backend versions from 0.33.0 through 0.46.1, when cpp-httplib is built with CPPHTTPLIBMBEDTLSSUPPORT or CPPHTTPLIBWOLFSSLSUPPORT and a...

7.4CVSS5.9AI score0.00264EPSS
SaveExploits0References4Affected Software1
Tenable Nessus
Tenable Nessus
•added 2026/07/03 12:00 a.m.•29 views

Fedora 44 : cpp-httplib (2026-1b15ac058b)

The remote Fedora 44 host has a package installed that is affected by multiple vulnerabilities as referenced in the FEDORA-2026-1b15ac058b advisory. Update to 0.48.0 rhbz2481109 Security fixes - Complete the IP-host certificate identity fix from v0.47.0 for the Mbed TLS and wolfSSL backends. An...

9.9CVSS7.6AI score0.00486EPSS
SaveExploits4References6
Hacker One
Hacker One
•added 2026/06/26 8:40 a.m.•55 views

curl: mbedTLS / wolfSSL / rustls backends silently skip hostname verification when CURLOPT_SSL_VERIFYPEER=0

Summary When an application sets CURLOPTSSLVERIFYPEER=0 while keeping CURLOPTSSLVERIFYHOST=2 the default, the mbedTLS, wolfSSL, and rustls TLS backends silently skip the hostname-vs-certificate check. The OpenSSL, GnuTLS, and Schannel backends correctly preserve hostname checking under the same...

6.1AI score
SaveExploits0
Hacker One
Hacker One
•added 2026/05/13 11:33 p.m.•74 views

curl: TLS verifyhost bypass in rustls, mbedTLS, and wolfSSL when verifypeer=0

The now-well-known CURLOPTSSLVERIFYHOST-bypass-when-CURLOPTSSLVERIFYPEER=0 defect exists in three of curl's TLS backends: rustls EXPERIMENTAL, mbedTLS, and wolfSSL DNS hostnames only. The documented contract at docs/libcurl/opts/CURLOPTSSLVERIFYPEER.md:57-59: The check that the host name in the...

5.8CVSS6.3AI score0.04389EPSS
SaveExploits0
Rows per page
Query Builder