Lucene search
+L

6953 matches found

RedHat Linux
RedHat Linux
•added 2025/03/17 1:34 a.m.•21 views

xorg: xwayland: Use of uninitialized pointer in compRedirectWindow()

An access to an uninitialized pointer flaw was found in X.Org and Xwayland. The function compCheckRedirect may fail if it cannot allocate the backing pixmap. In that case, compRedirectWindow will return a BadAlloc error without validating the window tree marked just before, which leaves the...

7.8CVSS5.7AI score0.00405EPSS
SaveExploits0References4
RedHat Linux
RedHat Linux
•added 2025/03/17 1:32 a.m.•14 views

xorg: xwayland: Heap overflow in XkbWriteKeySyms()

A heap overflow flaw was found in X.Org and Xwayland. The computation of the length in XkbSizeKeySyms differs from what is written in XkbWriteKeySyms, which may lead to a heap-based buffer overflow...

7.8CVSS6.2AI score0.00438EPSS
SaveExploits0References4
RedHat Linux
RedHat Linux
•added 2025/03/17 1:32 a.m.•17 views

xorg: xwayland: Use of uninitialized pointer in compRedirectWindow()

An access to an uninitialized pointer flaw was found in X.Org and Xwayland. The function compCheckRedirect may fail if it cannot allocate the backing pixmap. In that case, compRedirectWindow will return a BadAlloc error without validating the window tree marked just before, which leaves the...

7.8CVSS5.7AI score0.00405EPSS
SaveExploits0References4
RedHat Linux
RedHat Linux
•added 2025/03/17 1:32 a.m.•14 views

xorg: xwayland: Buffer overflow in XkbChangeTypesOfKey()

A buffer overflow flaw was found in X.Org and Xwayland. If XkbChangeTypesOfKey is called with a 0 group, it will resize the key symbols table to 0 but leave the key actions unchanged. If the same function is later called with a non-zero value of groups, this will cause a buffer overflow because t...

7.8CVSS6AI score0.00444EPSS
SaveExploits0References4
RedHat Linux
RedHat Linux
•added 2025/03/17 1:16 a.m.•27 views

Xorg: xwayland: Buffer overflow in XkbVModMaskText()

A buffer overflow flaw was found in X.Org and Xwayland. The code in XkbVModMaskText allocates a fixed-sized buffer on the stack and copies the names of the virtual modifiers to that buffer. The code fails to check the bounds of the buffer and would copy the data regardless of the size...

7.8CVSS6AI score0.00438EPSS
SaveExploits0References4
RedHat Linux
RedHat Linux
•added 2025/03/17 1:16 a.m.•35 views

xorg: xwayland: Out-of-bounds write in CreatePointerBarrierClient()

An out-of-bounds write flaw was found in X.Org and Xwayland. The function GetBarrierDevice searches for the pointer device based on its device ID and returns the matching value, or supposedly NULL, if no match was found. However, the code will return the last element of the list if no matching...

7.8CVSS5.8AI score0.00405EPSS
SaveExploits0References4
RedHat Linux
RedHat Linux
•added 2025/03/17 1:16 a.m.•18 views

xorg: xwayland: Use-after-free in SyncInitTrigger()

A use-after-free flaw was found in X.Org and Xwayland. When changing an alarm, the values of the change mask are evaluated one after the other, changing the trigger values as requested, and eventually, SyncInitTrigger is called. If one of the changes triggers an error, the function will return...

7.8CVSS5.7AI score0.00393EPSS
SaveExploits0References4
Zero Day Initiative
Zero Day Initiative
•added 2025/03/13 12:00 a.m.•18 views

X.Org Server compRedirectWindow Type Confusion Local Privilege Escalation Vulnerability

This vulnerability allows local attackers to escalate privileges on affected installations of X.Org Server. An attacker must first obtain the ability to execute low-privileged code on the target system in order to exploit this vulnerability. The specific flaw exists within the handling of window...

7.8CVSS7.2AI score0.00405EPSS
SaveExploits0References1
Microsoft CVE
Microsoft CVE
•added 2025/03/10 7:00 a.m.•10 views

Xorg: xwayland: use-after-free in syncinittrigger()

...

7.8CVSS7.8AI score0.00393EPSS
SaveExploits0
Microsoft CVE
Microsoft CVE
•added 2025/03/10 7:00 a.m.•9 views

X.org: xwayland: use-after-free of the root cursor

...

7.8CVSS7.8AI score0.00393EPSS
SaveExploits0
Microsoft CVE
Microsoft CVE
•added 2025/03/10 7:00 a.m.•14 views

Xorg: xwayland: use-after-free in playreleasedevents()

...

7.8CVSS7.8AI score0.00393EPSS
SaveExploits0
Microsoft CVE
Microsoft CVE
•added 2025/03/10 7:00 a.m.•16 views

Xorg: xwayland: buffer overflow in xkbchangetypesofkey()

...

7.8CVSS7.8AI score0.00444EPSS
SaveExploits0
Tenable Nessus
Tenable Nessus
•added 2025/03/06 12:00 a.m.•12 views

Linux Distros Unpatched Vulnerability : CVE-2025-21710

The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - In the Linux kernel, the following vulnerability has been resolved: tcp: correct handling of extreme memory squeeze Testing with iperf3 using the pasta protocol...

8.2CVSS5.7AI score0.00274EPSS
SaveExploits0References3
Tenable Nessus
Tenable Nessus
•added 2025/03/05 12:00 a.m.•20 views

Linux Distros Unpatched Vulnerability : CVE-2023-49295

The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - quic-go is an implementation of the QUIC protocol RFC 9000, RFC 9001, RFC 9002 in Go. An attacker can cause its peer to run out of memory sending a large number...

6.5CVSS6.4AI score0.01204EPSS
SaveExploits0References3
OSV
OSV
•added 2025/03/04 8:15 a.m.•12 views

CVE-2024-58043

Permission bypass vulnerability in the window module Impact: Successful exploitation of this vulnerability may affect service confidentiality...

5.5CVSS5.8AI score0.0012EPSS
SaveExploits0References1
Vulnrichment
Vulnrichment
•added 2025/03/04 7:10 a.m.•12 views

CVE-2024-58043

Permission bypass vulnerability in the window module Impact: Successful exploitation of this vulnerability may affect service confidentiality...

7.3CVSS7.2AI score0.0012EPSS
SaveExploits0References1
Positive Technologies
Positive Technologies
•added 2025/03/04 12:00 a.m.•4 views

PT-2025-9634

Name of the Vulnerable Software and Affected Versions The product name cannot be determined. Description A permission bypass issue exists in the window module, which may impact service confidentiality upon successful exploitation. Recommendations At the moment, there is no information about a new...

7.3CVSS0.0012EPSS
SaveExploits0References6
Rapid7 Vulnerability Database (full)
Rapid7 Vulnerability Database (full)
•added 2025/03/04 12:00 a.m.•5 views

CVE-2024-58043: Undefined Security Weakness

Permission bypass vulnerability in the window module Impact: Successful exploitation of this vulnerability may affect service confidentiality...

7.3CVSS5.9AI score0.0012EPSS
SaveExploits0References1
SUSE CVE
SUSE CVE
•added 2025/02/28 2:23 a.m.•17 views

SUSE CVE-2024-57999

In the Linux kernel, the following vulnerability has been resolved: powerpc/pseries/iommu: IOMMU incorrectly marks MMIO range in DDW Power Hypervisor can possibily allocate MMIO window intersecting with Dynamic DMA Window DDW range, which is over 32-bit addressing. These MMIO pages needs to be...

5.5CVSS6.5AI score0.00231EPSS
SaveExploits0References19
SUSE CVE
SUSE CVE
•added 2025/02/28 2:22 a.m.•16 views

SUSE CVE-2025-21710

In the Linux kernel, the following vulnerability has been resolved: tcp: correct handling of extreme memory squeeze Testing with iperf3 using the "pasta" protocol splicer has revealed a problem in the way tcp handles window advertising in extreme memory squeeze situations. Under memory pressure, ...

5.5CVSS6AI score0.00274EPSS
SaveExploits0References21
Rows per page
Query Builder