1567 matches found
delete-branches (1.2.15), delete-workflow-runs (1.2.33) +12 more potentially affected by CVE-2026-102938 via virtualenv (20.35.4)
virtualenv PYPI version 20.35.4 is affected by a known vulnerability. The following packages have a transitive dependency on virtualenv and may be impacted: - delete-branches 1.2.15 - delete-workflow-runs 1.2.33 - elroy =0.0.62, =0.0.1b1, =0.6.0, =2.2.1, =6.0.0, =1.2.3, =0.6.2, =0.7.0 Source cves...
pad-final-project (>=0.1.3, <=0.1.7), ppmanager (>=0.1.2, <=0.4.0) potentially affected by CVE-2026-102938 via virtualenv (20.28.0)
virtualenv PYPI version 20.28.0 is affected by a known vulnerability. The following packages have a transitive dependency on virtualenv and may be impacted: - pad-final-project =0.1.3, =0.1.2, =0.4.0 Source cves: CVE-2026-102938 Source advisory: OSV:PYSEC-2026-4012...
pokpok-sdk (>=0.1.3, <=0.1.6) potentially affected by CVE-2026-102938 via virtualenv (20.29.1)
virtualenv PYPI version 20.29.1 is affected by a known vulnerability. The following packages have a transitive dependency on virtualenv and may be impacted: - pokpok-sdk =0.1.3, =0.1.6 Source cves: CVE-2026-102938 Source advisory: OSV:PYSEC-2026-4012...
appcensus-dynamic-repos (>=2.0.113, <=2.1.117), microscopemetrics (0.2.4) +11 more potentially affected by CVE-2026-102938 via virtualenv (20.32.0)
virtualenv PYPI version 20.32.0 is affected by a known vulnerability. The following packages have a transitive dependency on virtualenv and may be impacted: - appcensus-dynamic-repos =2.0.113, =0.6.0, =1.0.0, =0.1.1, =0.5.4, =1.0.1, =1.0.119 Source cves: CVE-2026-102938 Source advisory:...
waldiez-runner (0.5.9) potentially affected by CVE-2026-102938 via virtualenv (20.33.0)
virtualenv PYPI version 20.33.0 is affected by a known vulnerability. The following packages have a transitive dependency on virtualenv and may be impacted: - waldiez-runner 0.5.9 Source cves: CVE-2026-102938 Source advisory: OSV:PYSEC-2026-4012...
PYSEC-2026-4012 virtualenv writes prompt values into pyvenv.cfg without sanitizing line boundaries, allowing configuration injection
pyvenv.cfg is a line-based format with no escape syntax. PyEnvCfg.write wrote values verbatim, while PyEnvCfg.readvalues parses the file with str.splitlines. A value containing a line boundary therefore became additional configuration lines, and because reading is last-wins, the injected keys...
virtualenv writes prompt values into pyvenv.cfg without sanitizing line boundaries, allowing configuration injection
pyvenv.cfg is a line-based format with no escape syntax. PyEnvCfg.writewrote values verbatim, while PyEnvCfg.readvalues parses the file withstr.splitlines. A value containing a line boundary therefore becameadditional configuration lines, and because reading is last-wins, the injectedkeys replace...
PT-2026-102926
Name of the Vulnerable Software and Affected Versions virtualenv versions prior to 21.7.11 Description The PyEnvCfg.write function writes prompt values verbatim to the line-oriented pyvenv.cfg format, while PyEnvCfg. read values parses the file using str.splitlines and accepts the last value for...
PT-2026-105773
pyvenv.cfg is a line-based format with no escape syntax. PyEnvCfg.write wrote values verbatim, while PyEnvCfg. read values parses the file with str.splitlines. A value containing a line boundary therefore became additional configuration lines, and because reading is last-wins, the injected keys...
CVE-2026-13346 affecting package python-virtualenv for versions less than 20.36.1-6
CVE-2026-13346 affecting package python-virtualenv for versions less than 20.36.1-6. A patched version of the package is available...
GHSA-QWM4-QH6W-59XR vulnerabilities
Vulnerabilities for packages: datadog-agent, py3.14-virtualenv, kubeflow-katib...
CVE-2026-13346 vulnerabilities
Vulnerabilities for packages: datadog-agent, py3.14-virtualenv, kubeflow-katib...
CLSA-2026-1782176246 TuxCare security update for virtualenv (1 CVE)
TuxCare rebuilt virtualenv to address 1 CVE. Fixed in 20.39.1.post1+tuxcare...
PT-2026-75145
TuxCare rebuilt virtualenv to address 1 CVE. Fixed in 20.39.1.post1+tuxcare...
virtualenv Synchronization DoS
The vulnerability of the tool for creating isolated virtual environments in Python virtualenv is related to synchronization errors when using a shared resource. Exploiting this vulnerability can allow an attacker to cause a service failure...
cateye (>=0.3.4, <=0.3.8), edx-completion (>=0.0.1, <=0.1.1) +4 more potentially affected by CVE-2026-22702 via virtualenv (15.1.0)
virtualenv PYPI version 15.1.0 is affected by a known vulnerability. The following packages have a transitive dependency on virtualenv and may be impacted: - cateye =0.3.4, =0.0.1, =0.5.7, =1.0.0rc1, =1.2.0, =1.7.1 Source cves: CVE-2026-22702 Source advisory: OSV:PYSEC-2026-2009...
backlogapi (>=0.1.3, <=0.1.5), dcoscli (>=0.4.10, <=0.6.1) +1 more potentially affected by CVE-2026-22702 via virtualenv (15.2.0)
virtualenv PYPI version 15.2.0 is affected by a known vulnerability. The following packages have a transitive dependency on virtualenv and may be impacted: - backlogapi =0.1.3, =0.4.10, =0.6.7, =0.7.1 Source cves: CVE-2026-22702 Source advisory: OSV:PYSEC-2026-2009...
cabrita (>=2.2.2b1, <=2.2.2b2), kaze-python (>=0.7.8, <=0.8.9) +2 more potentially affected by CVE-2026-22702 via virtualenv (16.0.0)
virtualenv PYPI version 16.0.0 is affected by a known vulnerability. The following packages have a transitive dependency on virtualenv and may be impacted: - cabrita =2.2.2b1, =0.7.8, =0.7.2, =1.7.2, =1.11.0 Source cves: CVE-2026-22702 Source advisory: OSV:PYSEC-2026-2009...
pystarter (>=1.0.0, <=1.1.2), terraenv (>=0.6.0.dev0, <=0.6.2) potentially affected by CVE-2026-22702 via virtualenv (16.1.0)
virtualenv PYPI version 16.1.0 is affected by a known vulnerability. The following packages have a transitive dependency on virtualenv and may be impacted: - pystarter =1.0.0, =0.6.0.dev0, =0.6.2 Source cves: CVE-2026-22702 Source advisory: OSV:PYSEC-2026-2009...
fzpycreate (>=0.0.12, <=2.0.0), neo-python (0.8.4) potentially affected by CVE-2026-22702 via virtualenv (16.2.0)
virtualenv PYPI version 16.2.0 is affected by a known vulnerability. The following packages have a transitive dependency on virtualenv and may be impacted: - fzpycreate =0.0.12, =2.0.0 - neo-python 0.8.4 Source cves: CVE-2026-22702 Source advisory: OSV:PYSEC-2026-2009...