10554 matches found
CVE-2022-0729
CVE-2022-0729 affects vim/vim; described as an out-of-range pointer offset in the GitHub repo prior to 8.2.4440. The vulnerability relates to memory access errors that can lead to a crash or potentially arbitrary code execution, as noted across multiple sources referencing Vim’s memory handling. ...
CVE-2022-0729 Use of Out-of-range Pointer Offset in vim/vim
Use of Out-of-range Pointer Offset in GitHub repository vim/vim prior to 8.2.4440...
CVE-2022-0729
Use of Out-of-range Pointer Offset in GitHub repository vim/vim prior to 8.2.4440...
CVE-2022-0729: Use of Out-of-range Pointer Offset
Use of Out-of-range Pointer Offset in GitHub repository vim/vim prior to 8.2.4440...
PT-2022-2266
Name of the Vulnerable Software and Affected Versions vim versions prior to 8.2.4440 Description The issue is caused by the use of an out-of-range pointer offset in the vim text editor. This can be exploited by a remote attacker to execute arbitrary code. The estimated number of potentially...
Vim buffer error vulnerability
A buffer overflow vulnerability exists in Vim, a UNIX-based editor, which stems from a product src/regexpbt.c file that does not effectively check for memory bounds. An attacker could cause a buffer overflow via this vulnerability...
CVE-2022-0729
Use of Out-of-range Pointer Offset in GitHub repository vim/vim prior to 8.2.4440...
Fedora: Security Advisory for vim (FEDORA-2022-8622ebdebb)
The remote host is missing an update for the Copyright C 2022 Greenbone Networks GmbH Some text descriptions might be excerpted from a referenced sources, and are Copyright C by the respective right holders. SPDX-License-Identifier: GPL-2.0-or-later This program is free software; you can...
CVE-2022-0729
Use of Out-of-range Pointer Offset in GitHub repository vim/vim prior to 8.2.4440...
CVE-2022-0714
A heap-buffer-overflow flaw was found in vim's winlbrchartabsize function of charset.c file. The issue occurs due to an incorrect 'vartabstop' value. This flaw allows an attacker to trick a user into opening a specially crafted file, triggering a heap-overflow, and can cause an application to...
AZL-8764 CVE-2022-0714 affecting package vim for versions less than 8.2.4743-1
Heap-based Buffer Overflow in GitHub repository vim/vim prior to 8.2.4436...
ALPINE-CVE-2022-0714
Heap-based Buffer Overflow in GitHub repository vim/vim prior to 8.2.4436...
DEBIAN-CVE-2022-0714
Heap-based Buffer Overflow in GitHub repository vim/vim prior to 8.2.4436...
CVE-2022-0714
Heap-based Buffer Overflow in GitHub repository vim/vim prior to 8.2.4436...
CVE-2022-0714
Heap-based Buffer Overflow in GitHub repository vim/vim prior to 8.2.4436...
CVE-2022-0714
Heap-based Buffer Overflow in GitHub repository vim/vim prior to 8.2.4436...
UBUNTU-CVE-2022-0714
Heap-based Buffer Overflow in GitHub repository vim/vim prior to 8.2.4436...
[SECURITY] Fedora 35 Update: vim-8.2.4428-1.fc35
VIM VIsual editor iMproved is an updated and improved version of the vi editor. Vi was the first real screen-based editor for UNIX, and is still very popular. VIM improves on vi by adding new features: multiple windows, multi-level undo, block highlighting and more...
CVE-2022-0696
A NULL pointer dereference flaw was found in vim's finducmd function of usercmd.c file. This flaw allows an attacker to trick a user into opening a crafted file, triggering a NULL pointer dereference. This issue leads to an application crash, causing a denial of service. Mitigation Untrusted vim...
An unspecified vulnerability exists in vim (CNVD-2022-13206)
Vim is a UNIX-based editor. vim versions prior to 8.2.4418 contain a security vulnerability that stems from the use of out-of-range pointer offsets in vim. No details of the vulnerability are currently available...