10629 matches found
ALPINE-CVE-2023-0049
Out-of-bounds Read in GitHub repository vim/vim prior to 9.0.1143...
UBUNTU-CVE-2023-0049
Out-of-bounds Read in GitHub repository vim/vim prior to 9.0.1143...
PT-2023-1015
Name of the Vulnerable Software and Affected Versions vim versions prior to 9.0.1143 Description The issue is related to an out-of-bounds read in the build stl str hl function of the Vim text editor, which can be exploited to execute arbitrary code. This is due to a buffer overflow in memory...
Vim buffer error vulnerability
Vim is a cross-platform text editor. A security vulnerability exists in Vim that originates from an out-of-bounds memory write in the function dostringsub, which can be exploited by an attacker to trigger a denial of service and potentially run code...
CVE-2023-0049 Out-of-bounds Read in vim/vim
Out-of-bounds Read in GitHub repository vim/vim prior to 9.0.1143...
CVE-2023-0049
Out-of-bounds Read in GitHub repository vim/vim prior to 9.0.1143...
CVE-2023-0054 Out-of-bounds Write in vim/vim
Out-of-bounds Write in GitHub repository vim/vim prior to 9.0.1145...
CVE-2023-0051 Heap-based Buffer Overflow in vim/vim
Heap-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.1144...
CVE-2023-0054 Out-of-bounds Write in vim/vim
Out-of-bounds Write in GitHub repository vim/vim prior to 9.0.1145...
CVE-2023-0051 Heap-based Buffer Overflow in vim/vim
Heap-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.1144...
CVE-2023-0054
Out-of-bounds Write in GitHub repository vim/vim prior to 9.0.1145...
CVE-2023-0049
Out-of-bounds Read in GitHub repository vim/vim prior to 9.0.1143...
Vim security vulnerabilities
Vim is a cross-platform text editor. A security vulnerability exists in versions of Vim prior to 9.0.1144, which stems from a heap memory overflow in the function msgputsprintf, and can be exploited by an attacker to trigger a denial of service and potentially run code...
CVE-2023-0051: Heap-based Buffer Overflow
Heap-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.1144...
PT-2023-1017
Name of the Vulnerable Software and Affected Versions Vim versions prior to 9.0.1145 Description The issue is related to an out-of-bounds write in the Vim text editor, specifically in the do string sub function eval.c, which is caused by a boundary error when processing untrusted input data. This...
CVE-2023-0054: Out-of-bounds Write
Out-of-bounds Write in GitHub repository vim/vim prior to 9.0.1145...
CVE-2023-0049 Out-of-bounds Read in vim/vim
Out-of-bounds Read in GitHub repository vim/vim prior to 9.0.1143...
CVE-2023-0049: Out-of-bounds Read
Out-of-bounds Read in GitHub repository vim/vim prior to 9.0.1143...
CVE-2023-0051
Heap-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.1144...
CVE-2023-0049
CVE-2023-0049 affects Vim, with an out-of-bounds read in vim/vim prior to 9.0.1143. Connected advisories confirm the issue in Vim builds and indicate vulnerable versions, and that remediation is to upgrade to Vim 9.0.1191 or newer. The impact is described as high in CVSS data, reflecting potentia...