10558 matches found
PT-2023-5105
Name of the Vulnerable Software and Affected Versions vim versions prior to 9.0.1846 Description The issue is caused by an integer overflow in the f fullcommand function of the vim text editor. This can allow an attacker to execute arbitrary code. The estimated number of potentially affected...
PT-2023-5106
Name of the Vulnerable Software and Affected Versions vim versions prior to 9.0.1847 Description The issue is related to an out-of-bounds write in the vim text editor, which can allow an attacker to execute arbitrary code. This is a result of a buffer overflow in memory. Recommendations For...
PT-2023-5104
Name of the Vulnerable Software and Affected Versions vim versions prior to 9.0.1833 Description The issue is related to an untrusted search path in the vim text editor. Exploitation of this issue may allow an attacker to execute arbitrary code. Recommendations For versions prior to 9.0.1833,...
CVE-2023-4735: Out-of-bounds Write
Out-of-bounds Write in GitHub repository vim/vim prior to 9.0.1847...
PT-2023-5107
Name of the Vulnerable Software and Affected Versions vim versions prior to 9.0.1848 Description The issue is a heap-based buffer overflow in the vim text editor, specifically in the vim regsub both function, caused by a dynamic memory buffer overflow. This can allow an attacker to execute...
Vim Code Problem Vulnerability
Vim is a cross-platform text editor. A code issue vulnerability exists in versions prior to Vim 9.0.1833 that stems from an untrusted search path...
SUSE SLED15 / SLES15 / openSUSE 15 Security Update : vim (SUSE-SU-2023:3497-1)
The remote SUSE Linux SLED15 / SLEDSAP15 / SLES15 / SLESSAP15 / openSUSE 15 host has packages installed that are affected by multiple vulnerabilities as referenced in the SUSE-SU-2023:3497-1 advisory. Updated to version 9.0 with patch level 1572. - CVE-2023-2426: Fixed Out-of-range Pointer Offset...
CBL Mariner 2.0 Security Update: vim (CVE-2023-3896)
The version of vim installed on the remote CBL Mariner 2.0 host is prior to tested version. It is, therefore, affected by a vulnerability as referenced in the CVE-2023-3896 advisory. - Divide By Zero in vim/vim from 9.0.1367-1 to 9.0.1367-3 CVE-2023-3896 Note that Nessus has not tested for this...
SUSE-SU-2023:3497-1 Security update for vim
This update for vim fixes the following issues: Updated to version 9.0 with patch level 1572. - CVE-2023-2426: Fixed Out-of-range Pointer Offset use bsc1210996. - CVE-2023-2609: Fixed NULL Pointer Dereference bsc1211256. - CVE-2023-2610: Fixed nteger Overflow or Wraparound bsc1211257...
CVE-2023-3896 affecting package vim for versions less than 9.0.1562-2
CVE-2023-3896 affecting package vim for versions less than 9.0.1562-2. A patched version of the package is available...
SUSE SLES12 Security Update : vim (SUSE-SU-2023:3463-1)
The remote SUSE Linux SLES12 / SLESSAP12 host has packages installed that are affected by multiple vulnerabilities as referenced in the SUSE-SU-2023:3463-1 advisory. Updated to version 9.0 with patch level 1572. - CVE-2023-2426: Fixed Out-of-range Pointer Offset use bsc1210996. - CVE-2023-2609:...
SUSE: Security Advisory (SUSE-SU-2023:3463-1)
The remote host is missing an update for the SPDX-FileCopyrightText: 2023 Greenbone AG Some text descriptions might be excerpted from a referenced sources, and are Copyright C by the respective right holders. SPDX-License-Identifier: GPL-2.0-only ifdescription...
SUSE-SU-2023:3463-1 Security update for vim
This update for vim fixes the following issues: Updated to version 9.0 with patch level 1572. - CVE-2023-2426: Fixed Out-of-range Pointer Offset use bsc1210996. - CVE-2023-2609: Fixed NULL Pointer Dereference bsc1211256. - CVE-2023-2610: Fixed nteger Overflow or Wraparound bsc1211257. -...
Denial Of Service (DoS)
vim is vulnerable to Denial of Service DoS attacks. This vulnerability allows a local attacker to cause a denial of service DoS by tricking a user into opening a specially crafted file due to a null pointer dereference in the exbufferall function...
USN-6302-1: Vim vulnerabilities
It was discovered that Vim incorrectly handled memory when opening certain files. If an attacker could trick a user into opening a specially crafted file, it could cause Vim to crash, or possibly execute arbitrary code. This issue only affected Ubuntu 22.04 LTS. CVE-2022-2522, CVE-2022-2580,...
USN-6302-1 vim vulnerabilities
It was discovered that Vim incorrectly handled memory when opening certain files. If an attacker could trick a user into opening a specially crafted file, it could cause Vim to crash, or possibly execute arbitrary code. This issue only affected Ubuntu 22.04 LTS. CVE-2022-2522, CVE-2022-2580,...
Vim register.c Heap Buffer Overflow DoS
The vulnerability of the yankcopyline function in the register.c component of the Vim text editor is related to incorrect calculation of buffer size. Exploiting this vulnerability may allow an attacker to access confidential data, compromise its integrity, and even cause service interruptions...
Vim utfc_ptr2len Heap Buffer Overflow DoS
The vulnerability of the utfcptr2len function in the mbyte.c text editor Vim is related to pointer assignment errors. Exploiting this vulnerability could allow an attacker to access confidential data, compromise its integrity, and even cause service interruptions...
Vim utf_ptr2char Heap Buffer Overflow DoS
The vulnerability of the utfptr2char function in the mbyte.c text editor Vim is related to the execution of an operation outside the buffer’s boundaries in memory. Exploiting this vulnerability could allow an attacker to access confidential data, compromise its integrity, and even cause service...
Ubuntu 18.04 ESM / 20.04 LTS / 22.04 LTS : Vim vulnerabilities (USN-6302-1)
The remote Ubuntu 18.04 ESM / 20.04 LTS / 22.04 LTS host has packages installed that are affected by multiple vulnerabilities as referenced in the USN-6302-1 advisory. It was discovered that Vim incorrectly handled memory when opening certain files. If an attacker could trick a user into opening ...