10558 matches found
Vim Division Overflow
The vulnerability of the Vim text editor is related to a division by zero error. Exploiting this vulnerability can allow an attacker to execute arbitrary code...
Vim ins-compl_get_exp Code Execution
The vulnerability of the ins-complgetexp function in the Vim text editor is related to the use of memory after it is freed. Exploiting this vulnerability could allow an attacker to perform arbitrary commands...
Vim Insecure Search Path
The vulnerability of the Vim text editor is related to the use of an unreliable search path. Exploiting this vulnerability allows a hacker to execute arbitrary code...
Vim buflist_altfpos Code Execution
The vulnerability of the buflistaltfpos function in the Vim text editor relates to the use of memory after it is freed. Exploiting this vulnerability could allow an attacker to execute arbitrary code...
Vim bt_quickfix Code Execution
The vulnerability of the Vim text editor is related to the use of memory after it is freed. Exploiting this vulnerability can allow an attacker to execute arbitrary code...
Vim Heap Buffer Overflow DoS
The vulnerability of the Vim text editor is related to writing beyond the buffer boundaries in memory. Exploiting this vulnerability can allow an attacker to execute arbitrary code...
Vim Input Validation Error Vulnerability
Vim is a cross-platform text editor. An input validation error vulnerability exists in versions prior to Vim 9.0.1846 that stems from the presence of an integer overflow or wrap-around issue. A remote attacker can exploit this vulnerability by sending a malicious HTTP or HTTPS request to execute...
Fedora: Security Advisory for vim (FEDORA-2023-6436d808d4)
The remote host is missing an update for the SPDX-FileCopyrightText: 2023 Greenbone AG Some text descriptions might be excerpted from a referenced sources, and are Copyright C by the respective right holders. SPDX-License-Identifier: GPL-2.0-only ifdescription...
Vim regs sub both() function
The vulnerability of the vim regsubboth function in the Vim text editor is related to buffer overflow in dynamic memory. Exploiting this vulnerability could allow an attacker to compromise the confidentiality, integrity, and accessibility of the protected information...
Vim buffer overflow vulnerability (CNVD-2023-70067)
Vim is a cross-platform text editor. A buffer overflow vulnerability exists in versions prior to vim 9.0.1847, which stems from an out-of-bounds write problem. An unauthenticated attacker can exploit this vulnerability to execute arbitrary code...
Slackware: Security Advisory (SSA:2023-254-01)
The remote host is missing an update for the SPDX-FileCopyrightText: 2023 Greenbone AG Some text descriptions might be excerpted from a referenced sources, and are Copyright C by the respective right holders. SPDX-License-Identifier: GPL-2.0-only ifdescription...
Important Photon OS Security Update - PHSA-2023-3.0-0647
Updates of 'vim' packages of Photon OS have been released...
[slackware-security] vim
New vim packages are available for Slackware 15.0 and -current to fix security issues. Here are the details from the Slackware 15.0 ChangeLog: patches/packages/vim-9.0.1897-i586-1slack15.0.txz: Upgraded. Fixed three use-after-free security issues. Thanks to marav for the heads-up. For more...
Huawei EulerOS: Security Advisory for vim (EulerOS-SA-2023-2777)
The remote host is missing an update for the Huawei EulerOS SPDX-FileCopyrightText: 2023 Greenbone AG Some text descriptions might be excerpted from a referenced sources, and are Copyright C by the respective right holders. SPDX-License-Identifier: GPL-2.0-only ifdescription...
Huawei EulerOS: Security Advisory for vim (EulerOS-SA-2023-2746)
The remote host is missing an update for the Huawei EulerOS SPDX-FileCopyrightText: 2023 Greenbone AG Some text descriptions might be excerpted from a referenced sources, and are Copyright C by the respective right holders. SPDX-License-Identifier: GPL-2.0-only ifdescription...
Vim buffer overflow vulnerability (CNVD-2023-72249)
Vim is a cross-platform text editor. A buffer overflow vulnerability exists in Vim versions prior to 9.0.1873, which stems from a boundary error in the regexp.c:2482 function when handling untrusted input. A remote attacker could exploit this vulnerability to execute arbitrary code on the system ...
Slackware Linux 15.0 / current vim Multiple Vulnerabilities (SSA:2023-254-01)
The version of vim installed on the remote host is prior to 9.0.1897. It is, therefore, affected by multiple vulnerabilities as referenced in the SSA:2023-254-01 advisory. - Use After Free in GitHub repository vim/vim prior to 9.0.1840. CVE-2023-4733 - Use After Free in GitHub repository vim/vim...
[SECURITY] Fedora 37 Update: vim-9.0.1872-1.fc37
VIM VIsual editor iMproved is an updated and improved version of the vi editor. Vi was the first real screen-based editor for UNIX, and is still very popular. VIM improves on vi by adding new features: multiple windows, multi-level undo, block highlighting and more...
Fedora 37 : vim (2023-6436d808d4)
The remote Fedora 37 host has a package installed that is affected by multiple vulnerabilities as referenced in the FEDORA-2023-6436d808d4 advisory. - patchlevel 1872 ---- The newest upstream commit Security fixes for CVE-2023-4733, CVE-2023-4752, CVE-2023-4750 Tenable has extracted the preceding...