10554 matches found
SUSE CVE-2023-5535
Use After Free in GitHub repository vim/vim prior to v9.0.2010...
Vim trunc_string() DoS
The vulnerability of the truncstring function in the Vim text editor is related to buffer overflow attacks. Exploiting this vulnerability could allow a remote attacker to cause a service failure...
USN-6154-1: Vim vulnerabilities | Cloud Foundry
Severity Medium Vendor Canonical Ubuntu Versions Affected Canonical Ubuntu 16.04 Canonical Ubuntu 18.04 Canonical Ubuntu 22.04 Description It was discovered that Vim was using uninitialized memory when fuzzy matching, which could lead to invalid memory access. An attacker could possibly use this...
Fedora 37 : vim (2023-c0da722865)
The remote Fedora 37 host has a package installed that is affected by multiple vulnerabilities as referenced in the FEDORA-2023-c0da722865 advisory. patchlevel 1984 ---- The newest upstream commit Tenable has extracted the preceding description block directly from the Fedora security advisory. No...
DEBIAN-CVE-2023-5535
Use After Free in GitHub repository vim/vim prior to v9.0.2010...
ALPINE-CVE-2023-5535
Use After Free in GitHub repository vim/vim prior to v9.0.2010...
AZL-31499 CVE-2023-5535 affecting package vim for versions less than 9.0.2010-1
Use After Free in GitHub repository vim/vim prior to v9.0.2010...
CVE-2023-5535
Use After Free in GitHub repository vim/vim prior to v9.0.2010...
UBUNTU-CVE-2023-5535
Use After Free in GitHub repository vim/vim prior to v9.0.2010...
CVE-2023-5535 Use After Free in vim/vim
Use After Free in GitHub repository vim/vim prior to v9.0.2010...
CVE-2023-5535
Use After Free in GitHub repository vim/vim prior to v9.0.2010...
CVE-2023-5535 Use After Free in vim/vim
Use After Free in GitHub repository vim/vim prior to v9.0.2010...
CVE-2023-5535
Use After Free in GitHub repository vim/vim prior to v9.0.2010...
CVE-2023-5535
Use After Free in GitHub repository vim/vim prior to v9.0.2010...
CVE-2023-5535 Use After Free in vim/vim
Use After Free in GitHub repository vim/vim prior to v9.0.2010...
CVE-2023-5535
Vim CVE-2023-5535: Use After Free in vim/vim prior to v9.0.2010. Affected: Vim before 9.0.2010; remediation is to upgrade to 9.0.2010 or newer. Exploitation details are not provided in the available documents.
Vim buffer overflow vulnerability (CNVD-2024-40470)
Vim is a cross-platform text editor. A buffer overflow vulnerability exists in Vim versions prior to 9.0.1969, which stems from a boundary error in the function truncstring in src/message.c when handling untrusted input. A remote attacker could exploit this vulnerability to execute arbitrary code...
PT-2023-8852
Name of the Vulnerable Software and Affected Versions vim versions prior to 9.0.2010 Description The issue is related to a Use After Free vulnerability in the buf contents changed function of the vim text editor, which is associated with the use of memory after it has been freed. Exploitation of...
Vim resource management error vulnerability
Vim is a highly configurable text editor designed to efficiently create and change any type of text . As an improved version of vi many new features have been added: multi-level undo, syntax highlighting, command line history, online help, spell checking, filename completion, block manipulation, ...