10554 matches found
Fedora 37 : vim (2023-0f6a9433cf)
The remote Fedora 37 host has a package installed that is affected by a vulnerability as referenced in the FEDORA-2023-0f6a9433cf advisory. Security fix for CVE-2023-0049 Tenable has extracted the preceding description block directly from the Fedora security advisory. Note that Nessus has not...
Huawei EulerOS: Security Advisory for vim (EulerOS-SA-2024-1540)
The remote host is missing an update for the Huawei EulerOS SPDX-FileCopyrightText: 2024 Greenbone AG Some text descriptions might be excerpted from a referenced sources, and are Copyright C by the respective right holders. SPDX-License-Identifier: GPL-2.0-only ifdescription...
Huawei EulerOS: Security Advisory for vim (EulerOS-SA-2024-1559)
The remote host is missing an update for the Huawei EulerOS SPDX-FileCopyrightText: 2024 Greenbone AG Some text descriptions might be excerpted from a referenced sources, and are Copyright C by the respective right holders. SPDX-License-Identifier: GPL-2.0-only ifdescription...
EulerOS Virtualization 2.10.1 : vim (EulerOS-SA-2024-1559)
According to the versions of the vim packages installed, the EulerOS Virtualization installation on the remote host is affected by the following vulnerabilities : - Vim is a UNIX editor that, prior to version 9.0.2121, has a heap-use-after-free vulnerability. When executing a :s command for the...
EulerOS Virtualization 2.10.0 : vim (EulerOS-SA-2024-1540)
According to the versions of the vim packages installed, the EulerOS Virtualization installation on the remote host is affected by the following vulnerabilities : - Vim is a UNIX editor that, prior to version 9.0.2121, has a heap-use-after-free vulnerability. When executing a :s command for the...
openSUSE Security Advisory (SUSE-SU-2024:1287-1)
The remote host is missing an update for the SPDX-FileCopyrightText: 2024 Greenbone AG Some text descriptions might be excerpted from a referenced sources, and are Copyright C by the respective right holders. SPDX-License-Identifier: GPL-2.0-only ifdescription...
SUSE SLED15 / SLES15 / openSUSE 15 Security Update : vim (SUSE-SU-2024:1287-1)
The remote SUSE Linux SLED15 / SLEDSAP15 / SLES15 / SLESSAP15 / openSUSE 15 host has packages installed that are affected by multiple vulnerabilities as referenced in the SUSE-SU-2024:1287-1 advisory. Updated to version 9.1.0111, fixes the following security problems - CVE-2023-48231:...
SUSE-SU-2024:1287-1 Security update for vim
This update for vim fixes the following issues: Updated to version 9.1.0111, fixes the following security problems - CVE-2023-48231: Use-After-Free in winclose bsc1217316. - CVE-2023-48232: Floating point Exception in adjustplinesforskipcol bsc1217320. - CVE-2023-48233: overflow with count for :s...
CVE-2023-4750
A flaw was found in Vim, where it is vulnerable to a use-after-free in the btquickfix function. This flaw allows a specially crafted file to crash software, use unexpected values, or possibly execute code when opened in Vim...
CVE-2023-4733
A flaw was found in Vim, where it is vulnerable to a use-after-free in the buflistaltfpos function. This flaw allows a specially crafted file to crash software, use unexpected values, or possibly execute code when opened in Vim...
Vim Code Execution
The vulnerability of the Didsetlangmap function in the Vim text editor is related to the use of sprintf to write to the error buffer, which is passed to functions that handle option renames. Exploiting this vulnerability allows an attacker to execute arbitrary code...
ROS-20240410-15
A vulnerability in the vim text editor is related to the call to sprintf to write to an error buffer, which is passed to the option callback functions. Exploitation of the vulnerability could allow an attacker to cause a denial of service...
USN-6557-1: Vim vulnerabilities | Cloud Foundry
Severity Unknown Vendor Canonical Ubuntu Versions Affected Canonical Ubuntu 16.04 Canonical Ubuntu 18.04 Canonical Ubuntu 22.04 Description It was discovered that Vim could be made to dereference invalid memory. An attacker could possibly use this issue to cause a denial of service. This issue on...
Vim exmode DoS
The vulnerability of the exmode mode in the Vim text editor is related to the assignment of NULL pointers. Exploiting this vulnerability can allow an attacker to cause a service failure...
Vim win_close() Data Compromise
The vulnerability of the winclose function in the Vim text editor relates to Vim’s attempt to access a window structure that has already been freed. Exploiting this vulnerability could allow an attacker to compromise the confidentiality, integrity, and accessibility of data...
Vim Heap Buffer Overflow DoS
The vulnerability of the nvzgetcount function in the Vim text editor is related to the use of large values for the z command. Exploiting this vulnerability could allow a remote attacker to cause a service failure...
Vim get_number() DoS
The vulnerability of the getnumber function in the Vim text editor relates to the use of the z= command. Users can overflow the counter with values exceeding MAXINT. Exploiting this vulnerability could allow a remote attacker to cause a service failure...
Vim shift_line DoS
The vulnerability of the shiftline function in the Vim text editor is related to the use of extremely large values during row shifting. Exploiting this vulnerability could allow a remote attacker to cause a service failure...
Vim Integer Overflow DoS
The vulnerability of the Vim text editor lies in the fact that the values used for the :s command are stored more than is necessary for a single long variable. Exploiting this vulnerability could allow an attacker to cause a service failure remotely...
Vim Integer Overflow DoS
The vulnerability of the Vim text editor is related to the use of negative line numbers. Exploiting this vulnerability can allow a remote attacker to cause a service failure...