166780 matches found
CVE-2024-21626-old-docker-versions
Container escape vulnerability in old runc components CVE-2024-21626 During my analysis about CVE-2024-21626 I found that other older docker components are vulnerable about fd leakage that is not mentioned in the security advisory GHSA-xr7r-f8xq-vfvv. Read my full article for detailed explanation...
CVE-2023-22527
CVE-2023-22527 CVE-2023-22527 - RCE Remote Code Execution Vulnerability in Out-of-Date Versions of Confluence Data Center and Server Advisory Release Date Tue, Jan 16 2024 01:00 EST Products: Confluence Data Center Confluence Server Affected Versions: 8.0.x 8.1.x 8.2.x 8.3.x 8.4.x 8.5.0-8.5.3...
CVE-2023-34840
CVE-2023-34840 Vulnerability Explanation All versions in angular-ui-notification are vulnerable to XSS due to the library not sanitizing the input provided by the user. In order to safely use this library, sanitizing / encoding the parameters passed to this library is highly recommended, such as...
CVE-2023-1177
CVE-2023-1177 | | MLFlow Path Traversal | Tested on MLflow 2.2.0 | src: https://github.com/iumiro/CVE-2023-1177-MLFlow | .. code-block:: bash !/bin/bash RAND="EXPLOIT-$1+$RANDOM%9999" URL="http://172.17.0.2:6001" FILE='/root/.ssh/idrsa' curl -vX POST...
offsec-osgi-exploits
OSGi Exploits This repository contains exploits for multiple OSGi versions. OSGi v3.7.2 and Below OSGi v3.8-3.20...
http-desync-guardian
Overview HTTP/1.1 went through a long evolution since 1991 to 2014: HTTP/0.9 – 1991 HTTP/1.0 – 1996 HTTP/1.1 RFC 2068 – 1997 RFC 2616 - 1999 RFC 7230 - 2014 This means there is a variety of servers and clients, which might have different views on request boundaries, creating opportunities for...
exploit-CVE-2024-25723
Exploit for CVE-2024-25723 This repository is dedicated to addressing CVE-2024-25723, a critical security vulnerability in ZenML, with an educational Proof of Concept PoC provided to illustrate the issue and encourage prompt mitigation. The PoC demonstrates how an unauthorized user could...
CVE-2023-32315-POC
CVE-2023-32315-POC CVE-2023-32315-Openfire-Bypass-Py Overview This code is a Python version POC for CVE-2023-32315. It performs a series of operations to verify whether the target website is affected by the CVE-2023-32315 vulnerability and attempts to execute certain operations on the affected...
CVE-2024-34470
CVE-2024-34470 PoC and Bulk Scanner Overview This is a proof-of-concept PoC and bulk scanner for CVE-2024-34470: Path Traversal vulnerability HSC Mailinspector affects all versions up to 5.2.18. How to Use POC in Action: Single Target Scan To scan a single target IP: python cve-2024-34470.py -u...
cve-2019-3396
Confluence unauthorised template injection CVE-2019-3396 I Building This bug occurs on the following versions: All versions 1.x.x, 2.x.x, 3.x.x, 4.x.x and 5.x.x All versions 6.0.x, 6.1.x, 6.2.x, 6.3.x, 6.4.x and 6.5.x All versions 6.6.x before 6.6.12 All versions 6.7.x, 6.8.x, 6.9.x, 6.10.x and...
CVE-2024-4040-CrushFTP-File-Read-vulnerability
CVE-2024-4040: CrushFTP File Read Vulnerability Overview On April 19, 2024, a new zero-day vulnerability affecting CrushFTP versions below 10.7.1 and 11.1.0, as well as legacy 9.x versions, was disclosed to a private mailing list by the managed file transfer vendor CrushFTP. Initially, no CVE was...
onedrive_user_enum
onedriveuserenum v2.10 enumerate valid onedrive users For a full rundown of the enumeration technique and OneDrive enum, check out the blog here: https://www.trustedsec.com/blog/onedrive-to-enum-them-all/ If you are looking for the old, non-database vesion of OneDrive Enum, you can find it here:...
CVE-2018-3191
CVE-2018-3191 payload generator Download: https://github.com/voidfyoo/CVE-2018-3191/releases Usage java -jar weblogic-spring-jndi.jar e.g.: java -jar weblogic-spring-jndi.jar rmi://192.168.1.1:1099/Exp Notes weblogic-spring-jndi-12.2.1.3.jar for weblogic: 12.2.1.3 weblogic-spring-jndi-10.3.6.0.ja...
packj
Packj flags malicious/risky open-source packages Packj pronounced package is a tool to help to mitigate software supply chain attacks. It can detect malicious, vulnerable, abandoned, typo-squatting, and other "risky" packages from popular open-source package registries, such as NPM, RubyGems, and...
CVE-2024-21626
PoC of CVE-2024-21626 Read my full article for detailed explanation here. Related article While investigating CVE-2024–21626 , I discovered an overlooked vulnerability in older versions of Docker and runC. To learn more about what I found, read the following article: “Exploring Hidden...
CVE-2020-9484
CVE-2020-9484 Apache Tomcat RCE CVE-2020-9484 Affected versions are: Apache Tomcat 10.x 10.0.0-M5 Apache Tomcat 9.x 9.0.35 Apache Tomcat 8.x 8.5.55 Apache Tomcat 7.x 7.0.104...
CVE-2020-10148
Usage & Disclaimer This script is a batch detection script for the SolarWinds Orion API remote code execution vulnerability CVE-2020-10148. Usage: Python CVE-2020-10148.py urls.txt Each URL in urls.txt is on a separate line, and the vulnerable addresses are output to vul.txt. Affected versions:...
NotQuite0DayFriday
This repository documents real bugs in real software. At the time of disclosure the most recent versions were patched. Seeing mistakes that were made in the past can be a useful tool for seeing trends of bugs which make it past all the quality control processes. Understanding what happened, is th...
CVE-2022-1388
CVE-2022-1388-Exploit Exploit and Check Script for CVE 2022-1388 Usage To Check against single host URL python3 exploit.py -v true -u targeturl To Attack host and test command on this host python3 exploit.py -a true -u targeturl -c command Attack list of hosts or attaching file of host URL's IP...
TFTPlunder
TFTPlunder: an exploit for CVE-2023-29930 This is an exploit script for a blind file read / write vulnerability in the Genesys formerly InIn TFTP provisioning server. Vulnerability info This vulnerability is due to unrestricted configuration options for the TFTP root path and file extensions. In...