2818 matches found
Misinterpretation of Input
Overview Affected versions of this package are vulnerable to Misinterpretation of Input containing a \n. Several validations expect line ending characters to be matched by $, but a malicious user can bypass those validations to cause invalid input to be treated as valid. Remediation Upgrade...
Symfony input validation vulnerability
Symfony is a PHP framework for web and console applications and a set of reusable PHP components from Symfony, Inc. An input validation error vulnerability exists in Symfony. An attacker could use this vulnerability to spoof a "Validator" configured with a regular expression using the "$"...
CVE-2024-50343: Improper Input Validation
symfony/validator is a module for the Symphony PHP framework which provides tools to validate values. It is possible to trick a Validator configured with a regular expression using the $ metacharacters, with an input ending with \n. Symfony as of versions 5.4.43, 6.4.11, and 7.1.4 now uses the D...
WS-2023-0044
User data in TPM attestation vulnerable to MITM. Attestation user data such as the digest of the public key in an aTLS connection was bound to the issuer's TPM, but not to its PCR state. An attacker could intercept a node initialization, initialize the node themselves, and then impersonate an...
GHSA-MJJW-553X-87PQ vulnerabilities
Vulnerabilities for packages: nvidia-container-toolkit...
GHSA-3PHV-83CJ-P8P7 nope-validator Regular Expression Denial of Service vulnerability
Nope is a JavaScript validator. Versions 0.11.3 and prior contain one or more regular expressions that are vulnerable to Regular Expression Denial of Service ReDoS. This vulnerability is fixed in 0.12.1...
nope-validator Regular Expression Denial of Service vulnerability
Nope is a JavaScript validator. Versions 0.11.3 and prior contain one or more regular expressions that are vulnerable to Regular Expression Denial of Service ReDoS. This vulnerability is fixed in 0.12.1...
nope-env (1.0.0) potentially affected by CVE-2020-26309 via nope-validator (0.11.3)
nope-validator NPM version 0.11.3 is affected by a known vulnerability. The following packages have a transitive dependency on nope-validator and may be impacted: - nope-env 1.0.0 Source cves: CVE-2020-26309 Source advisory: GHSA-3PHV-83CJ-P8P7...
nope-env (1.0.0) potentially affected by CVE-2020-26309 via nope-validator (0.11.3)
nope-validator NPM version 0.11.3 is affected by a known vulnerability. The following packages have a transitive dependency on nope-validator and may be impacted: - nope-env 1.0.0 Source cves: CVE-2020-26309 Source advisory: OSV:GHSA-3PHV-83CJ-P8P7...
CVE-2020-26310 GHSL-2020-305: Regular Expression Denial of Service (ReDoS) in Pure JavaScript HTML5 Parser
Validate.js provides a declarative way of validating javascript objects. All versions as of 30 November 2020 contain one or more regular expressions that are vulnerable to Regular Expression Denial of Service ReDoS. As of time of publication, it is unknown if any patches are available...
nope-env (1.0.0) potentially affected by CVE-2020-26309 via nope-validator (0.11.3)
nope-validator NPM version 0.11.3 is affected by a known vulnerability. The following packages have a transitive dependency on nope-validator and may be impacted: - nope-env 1.0.0 Source cves: CVE-2020-26309 Source advisory: MEND:CVE-2020-26309...
Malware in request-ip-validator
Any computer that has this package installed or running should be considered fully compromised. All secrets and keys stored on that computer should be rotated immediately from a different computer. The package should be removed, but as full control of the computer may have been given to an outsid...
CentOS 7 : kpatch-patch (RHSA-2020:5050)
The remote CentOS Linux 7 host has packages installed that are affected by a vulnerability as referenced in the RHSA-2020:5050 advisory. - A flaw was found in the Linux kernel before 5.9-rc4. A failure of the file system metadata validator in XFS can cause an inode with a valid, user-creatable...
CVE-2024-0132 vulnerabilities
Vulnerabilities for packages: nvidia-container-toolkit...
CVE-2024-46984
The reference validator is a tool to perform advanced validation of FHIR resources for TI applications and interoperability standards. The profile location routine in the referencevalidator commons package is vulnerable to XML External Entities attack due to insecure defaults of the used Woodstox...
CVE-2024-46984
CVE-2024-46984 affects gematik app-referencevalidator’s referencevalidator Commons profile location routine, which is vulnerable to XML External Entities (XXE) due to insecure Woodstox WstxInputFactory defaults. A malicious XML resource can induce network requests and Server-Side Request Forgery ...
Security Bulletin: Vulnerability in Hibernate Validator affects IBM watsonx.data
Summary Hibernate Validator allows a remote attacker to bypass security restrictions, such as escaping or stripping, that may be in place when handling user-controlled data in error messages in IBM watsonx.data. Vulnerability Details CVEID:CVE-2021-23463 DESCRIPTION: h2database com.h2database:h2...
apache-commons-validator:UrlValidator2Fuzzer: Security exception in java.base/java.util.regex.Pattern$Loop.match
Detailed Report: https://oss-fuzz.com/testcase?key=4968137508847616 Project: apache-commons-validator Fuzzing Engine: libFuzzer Fuzz Target: UrlValidator2Fuzzer Job Type: libfuzzerasanapache-commons-validator Platform Id: linux Crash Type: Security exception Crash Address: Crash State:...
GO-2024-3112 CometBFT's state syncing validator from malicious node may lead to a chain split github.com/cometbft/cometbft
CometBFT's state syncing validator from malicious node may lead to a chain split github.com/cometbft/cometbft...
Unspecified vulnerability in Linux kernel (CNVD-2024-39479)
Linux kernel is the kernel used by Linux, the open source operating system of the Linux Foundation in the United States. Linux kernel has a security vulnerability that stems from a kernel validator crash in the bpf component. No details of the vulnerability are provided at this time...