1882 matches found
GHSA-6F9P-G466-F8V8 blamer vulnerable to Arbitrary Argument Injection via the blameByFile() API
Versions of the blamer package before 1.0.4 are vulnerable to Arbitrary Argument Injection via the blameByFile API. The library does not sanitize for user input or validate the given file path conforms to a specific schema, nor does it properly pass command-line flags to the git binary using the...
Easy Admin Menu <= 1.3 - Admin+ Stored XSS
Description The plugin does not validate and escape some parameters, which could allow users with the admin role and above to perform Stored Cross-Site Scripting attacks even when the unfilteredhtml capability is disallowed for example in multisite setup...
Schoolmate SQL Injection Vulnerability
Schoolmate is a PHP/MySQL solution for elementary, middle and high schools from mrmunkey22 Individual Developer. A security vulnerability exists in Schoolmate version 1.3, which was discovered to contain an SQL injection vulnerability via the $username variable of SESSION in ValidateLogin.php...
CVE-2023-2906
A vulnerability was found in Wireshark. This security issue occurs due to a failure to validate the length an attacker-crafted CP2179 packet provides. This flaw leaves Wireshark susceptible to a divide-by-zero problem, allowing a denial of service attack. Mitigation Mitigation for this issue is...
FreeImage Validate Method Denial of Service Vulnerability
FreeImage is a cross-platform open source library for supporting popular graphic image formats. A denial of service vulnerability exists in FreeImage, which stems from a stack exhaustion issue in the Validate method of the PluginRAW.cpp file. An attacker could exploit this vulnerability to cause ...
CVE-2023-40801
The sub451784 function does not validate the parameters entered by the user, resulting in a stack overflow vulnerability in Tenda AC23 v16.03.07.45cn...
CVE-2021-40262
A stack exhaustion issue was discovered in FreeImage before 1.18.0 via the Validate function in PluginRAW.cpp...
CVE-2021-40262
A stack exhaustion issue was discovered in FreeImage before 1.18.0 via the Validate function in PluginRAW.cpp...
DEBIAN-CVE-2021-40262
A stack exhaustion issue was discovered in FreeImage before 1.18.0 via the Validate function in PluginRAW.cpp...
CVE-2021-40262
A stack exhaustion issue was discovered in FreeImage before 1.18.0 via the Validate function in PluginRAW.cpp...
Stack overflow
A stack exhaustion issue was discovered in FreeImage before 1.18.0 via the Validate function in PluginRAW.cpp...
CVE-2021-40262
A stack exhaustion issue was discovered in FreeImage before 1.18.0 via the Validate function in PluginRAW.cpp...
CVE-2021-40262
A stack exhaustion issue was discovered in FreeImage before 1.18.0 via the Validate function in PluginRAW.cpp...
CVE-2021-40262
A stack exhaustion issue was discovered in FreeImage before 1.18.0 via the Validate function in PluginRAW.cpp...
CVE-2021-40262
A stack exhaustion issue was discovered in FreeImage before 1.18.0 via the Validate function in PluginRAW.cpp...
CVE-2021-40262: Out-of-bounds Write
A stack exhaustion issue was discovered in FreeImage before 1.18.0 via the Validate function in PluginRAW.cpp...
PT-2023-12355
Name of the Vulnerable Software and Affected Versions FreeImage versions prior to 1.18.0 Description A stack exhaustion issue was discovered via the Validate function in PluginRAW.cpp. Recommendations For versions prior to 1.18.0, update to version 1.18.0 or later to resolve the issue. As a...
FreeImage buffer error vulnerability
FreeImage is a cross-platform open source library for supporting popular graphic image formats. A denial of service vulnerability exists in FreeImage, which stems from a stack exhaustion issue in the Validate method of the PluginRAW.cpp file. An attacker could exploit this vulnerability to cause ...
PT-2023-27228 · Craft · Craft
Name of the Vulnerable Software and Affected Versions: Craft versions prior to 3.8.15 Craft versions prior to 4.4.15 Description: The issue is related to bypassing the validatePath function, which can lead to potential remote code execution. This can result in malicious control of vulnerable...
PT-2023-26793 · Ntsc-Crt · Ntsc-Crt
Name of the Vulnerable Software and Affected Versions: NTSC-CRT version 2.2.1 Description: The issue is related to an integer overflow and out-of-bounds write in the loadBMP function in bmp rw.c. This occurs because the file's width, height, and BPP are not validated. The vendor notes that the ma...