61 matches found
CVE-2026-9198
IBM Langflow OSS 1.0.0 through 1.10.0 allows unauthenticated attackers to chain /api/v1/autologin mints SUPERUSER tokens to any network caller with /api/v1/validate/code executes user code via exec to achieve full RCE on default Langflow deployments...
CVE-2026-9198: Improper Control of Generation of Code
IBM Langflow OSS 1.0.0 through 1.10.0 allows unauthenticated attackers to chain /api/v1/autologin mints SUPERUSER tokens to any network caller with /api/v1/validate/code executes user code via exec to achieve full RCE on default Langflow deployments...
PT-2026-60865
Name of the Vulnerable Software and Affected Versions IBM Langflow OSS versions 1.0.0 through 1.10.0 Description An issue exists in the code validation API endpoint that allows authenticated users to execute arbitrary system commands with the full privileges of the server process. The endpoint...
Langflow AI auto_login RCE
Langflow versions 1.10.0 and below are susceptible to unauthenticated remote code execution. By chaining /api/v1/autologin with /api/v1/validate/code, a remote unauthenticated attacker can send crafted HTTP requests to execute arbitrary code. Module Options msf use...
PT-2026-60833
Name of the Vulnerable Software and Affected Versions IBM Langflow OSS versions 1.0.0 through 1.10.0 Description Unauthenticated attackers can achieve remote code execution RCE on default deployments by chaining two endpoints. First, the '/api/v1/auto login' endpoint allows the minting of SUPERUS...
Langflow AI Code Validation Authenticated RCE
Langflow versions 1.0.0 through 1.10.0 are susceptible to authenticated remote code execution due to improper validation of code in the /api/v1/validate/code endpoint. Arbitrary code is executed under the context of the backend Langflow process. Module Options msf use...
Langflow Unauth RCE
Langflow versions prior to 1.3.0 are susceptible to code injection in the /api/v1/validate/code endpoint. A remote and unauthenticated attacker can send crafted HTTP requests to execute arbitrary code...
PYSEC-2026-380 Langflow Unauth RCE
Langflow versions prior to 1.3.0 are susceptible to code injection in the /api/v1/validate/code endpoint. A remote and unauthenticated attacker can send crafted HTTP requests to execute arbitrary code...
Langflow Unauthenticated RCE (validate endpoint)
Langflow versions up to and including 1.7.3 contain a remote code execution vulnerability in the validate endpoint where unsanitized values in execglobals/code allow an attacker to execute arbitrary Python code. This module abuses the /api/v1/autologin or /api/v1/login and /api/v1/validate/code...
Exploit for CVE-2026-0770
CVE-2026-0770 - Langflow Remote Code Execution Summary La...
Langflow affected by Remote Code Execution via validate_code() exec()
Langflow execglobals Inclusion of Functionality from Untrusted Control Sphere Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of Langflow. Authentication is not required to exploit this vulnerability. The specific...
Exploit for Missing Authentication for Critical Function in Langflow
CVE-2025-3248: Langflow Unauthenticated RCE Vulnerability Scan...
Missing Authorization
Overview Affected versions of this package are vulnerable to Missing Authorization via the api/v1/validate/code endpoint. A low-privileged user can gain administrative privileges by executing the /app/.venv/bin/langflow superuser command. Remediation Upgrade langflow-base to version 0.5.1 or...
📄 Langflow 1.2.x Remote Code Execution
Langflow exposes a vulnerable endpoint /api/v1/validate/code that improperly evaluates arbitrary Python code via the exec function. An unauthenticated remote attacker can execute arbitrary system commands. Versions 1.2.x and below are affected. !/usr/bin/env python3 Exploit Title: Langflow 1.2.x ...
Configuration Change Detected (Low)
The system detected a change in the controller code that was made via the network. An attacker may use code changes to disrupt normal operations, to cause production losses, or to create a security threat. This plugin only works with Tenable.ot. Please visit...
Langflow Code Injection
Langflow versions prior to 1.3.0 are susceptible to code injection in the /api/v1/validate/code endpoint. A remote and unauthenticated attacker can send crafted HTTP requests to execute arbitrary code...
VulnCheck KEV: CVE-2025-3248
Langflow versions prior to 1.3.0 are susceptible to code injection in the /api/v1/validate/code endpoint. A remote and unauthenticated attacker can send crafted HTTP requests to execute arbitrary code...
PYSEC-2025-36
Langflow versions prior to 1.3.0 are susceptible to code injection in the /api/v1/validate/code endpoint. A remote and unauthenticated attacker can send crafted HTTP requests to execute arbitrarycode...
Missing Authentication for Critical Function
Overview langflow is an A Python package with a built-in web application Affected versions of this package are vulnerable to Missing Authentication for Critical Function at the /api/v1/validate/code endpoint, which allows an attacker to execute arbitrary code by sending malicious HTTP requests...
CVE-2025-3248
Langflow versions prior to 1.3.0 are susceptible to code injection in the /api/v1/validate/code endpoint. A remote and unauthenticated attacker can send crafted HTTP requests to execute arbitrary code...