60 matches found
CVE-2018-1336
An improper handing of overflow in the UTF-8 decoder with supplementary characters can lead to an infinite loop in the decoder causing a Denial of Service. Versions Affected: Apache Tomcat 9.0.0.M9 to 9.0.7, 8.5.0 to 8.5.30, 8.0.0.RC1 to 8.0.51, and 7.0.28 to 7.0.86...
Fixed in Apache Tomcat 7.0.88
Important: A bug in the UTF-8 decoder can lead to DoS CVE-2018-1336 An improper handing of overflow in the UTF-8 decoder with supplementary characters can lead to an infinite loop in the decoder causing a Denial of Service. This was fixed in revision 1830376. This issue was reported publicly on 6...
Fixed in Apache Tomcat 8.0.52
Important: A bug in the UTF-8 decoder can lead to DoS CVE-2018-1336 An improper handing of overflow in the UTF-8 decoder with supplementary characters can lead to an infinite loop in the decoder causing a Denial of Service. This was fixed in revision 1830375. This issue was reported publicly on 6...
PT-2018-11780
Name of the Vulnerable Software and Affected Versions Apache Tomcat versions 7.0.28 through 7.0.86 Apache Tomcat versions 8.0.0.RC1 through 8.0.51 Apache Tomcat versions 8.5.0 through 8.5.30 Apache Tomcat versions 9.0.0.M9 through 9.0.7 Description An improper handling of overflow in the UTF-8...
Fixed in Apache Tomcat 8.5.31
Important: A bug in the UTF-8 decoder can lead to DoS CVE-2018-1336 An improper handing of overflow in the UTF-8 decoder with supplementary characters can lead to an infinite loop in the decoder causing a Denial of Service. This was fixed in revision 1830374. This issue was reported publicly on 6...
KLA11597 DoS vulnerability in Apache Tomcat
Unspecified vulnerability was found in Apache Tomcat. Malicious users can exploit this vulnerability via improper handing of overflow in the UTF-8 decoder to cause denial of service. Original advisories Apache Tomcat 9.x Security Vulnerabilities Exploitation Related products Apache-Tomcat CVE lis...
Fixed in Apache Tomcat 9.0.8
Important: A bug in the UTF-8 decoder can lead to DoS CVE-2018-1336 An improper handing of overflow in the UTF-8 decoder with supplementary characters can lead to an infinite loop in the decoder causing a Denial of Service. This was fixed in revision 1830373. This issue was reported publicly on 6...
Node.js 'V8 utf-8 decoder' DoS Vulnerability - Windows
Node.js is prone to a denial of service DoS vulnerability. SPDX-FileCopyrightText: 2015 Greenbone AG Some text descriptions might be excerpted from a referenced sources, and are Copyright C by the respective right holders. SPDX-License-Identifier: GPL-2.0-only CPE = "cpe:/a:nodejs:node.js";...
CVE-2015-5380
The Utf8DecoderBase::WriteUtf16Slow function in unicode-decoder.cc in Google V8, as used in Node.js before 0.12.6, io.js before 1.8.3 and 2.x before 2.3.3, and other products, does not verify that there is memory available for a UTF-16 surrogate pair, which allows remote attackers to cause a deni...
node, iojs, and v8 -- denial of service
node reports: This release of Node.js fixes a bug that triggers an out-of-band write in V8's utf-8 decoder. This bug impacts all Buffer to String conversions. This is an important security update as this bug can be used to cause a denial of service attack...
Airlock WAF 4.2.4 Overlong UTF-8 Sequence Bypass
Exploit for multiple platform in category dos / poc title: Airlock WAF overlong UTF-8 sequence bypass product: Airlock vulnerable version: = 4.2.4 without hotfix HF4213 fixed version: 4.2.5 impact: critical homepage: http://www.ergon.ch/ found: 2012-04-05 by: G. Wagner SEC Consult Vulnerability L...
Apache Tomcat java-runtime-utf-8-decoder-smuggling目录遍历漏洞
No description provided by source...
SuSE9 Security Update : IBM Java5 JRE and SDK (YOU Patch Number 12336)
This update brings IBM Java 5 to Service Release 9. It fixes the following security problems : - A security vulnerability in the Java Runtime Environment JRE may allow an untrusted applet or application to list the contents of the home directory of the user running the applet or application...
SuSE 10 Security Update : IBM Java 1.5.0 (ZYPP Patch Number 5960)
This update brings IBM Java 5 to Service Release 9. It fixes the following security problems : - A security vulnerability in the Java Runtime Environment JRE may allow an untrusted applet or application to list the contents of the home directory of the user running the applet or application...
SuSE 10 Security Update : Qt3 (ZYPP Patch Number 3052)
qt wrongly accepts overly long UTF-8 sequences due to a bug in the UTF-8 decoder. This may lead to security problems unter certain circumstances. The bug for example allows for script tag injection in konqueror. CVE-2007-0242 %NASLMINLEVEL 70300 C Tenable Network Security, Inc. The text descripti...
openSUSE 10 Security Update : libqt4 (libqt4-3056)
qt wrongly accepts overly long UTF-8 sequences due to a bug in the UTF-8 decoder. This may lead to security problems unter certain circumstances. The bug for example allows for script tag injection in konqueror CVE-2007-0242. %NASLMINLEVEL 70300 C Tenable Network Security, Inc. The descriptive te...
CVE-2007-0242
The UTF-8 decoder in codecs/qutfcodec.cpp in Qt 3.3.8 and 4.2.3 does not reject long UTF-8 sequences as required by the standard, which allows remote attackers to conduct cross-site scripting XSS and directory traversal attacks via long sequences that decode to dangerous metacharacters...
CVE-2007-0242
The UTF-8 decoder in codecs/qutfcodec.cpp in Qt 3.3.8 and 4.2.3 does not reject long UTF-8 sequences as required by the standard, which allows remote attackers to conduct cross-site scripting XSS and directory traversal attacks via long sequences that decode to dangerous metacharacters...
CVE-2007-0242
CVE-2007-0242 affects Qt 3.3.8 and 4.2.3 where the UTF-8 decoder in codecs/qutfcodec.cpp does not reject overlong UTF-8 sequences as required by the standard. This allows remote attackers to perform cross-site scripting (XSS) and directory traversal by sending long sequences that decode to danger...
CVE-2007-0242: Undefined Security Weakness
The UTF-8 decoder in codecs/qutfcodec.cpp in Qt 3.3.8 and 4.2.3 does not reject long UTF-8 sequences as required by the standard, which allows remote attackers to conduct cross-site scripting XSS and directory traversal attacks via long sequences that decode to dangerous metacharacters...