41587 matches found
CVE-2026-89601 ext2: Fix lost inode updates for IS_SYNC inodes
In the Linux kernel, the following vulnerability has been resolved: ext2: Fix lost inode updates for ISSYNC inodes ext2setsize and ext2xattrset2 had a construct like: if ISSYNCinode syncinodemetadatainode, 1; else markinodedirtyinode; which leads to lost inode updates for ISSYNC inodes because...
CVE-2026-89601 ext2: Fix lost inode updates for IS_SYNC inodes
In the Linux kernel, the following vulnerability has been resolved: ext2: Fix lost inode updates for ISSYNC inodes ext2setsize and ext2xattrset2 had a construct like: if ISSYNCinode syncinodemetadatainode, 1; else markinodedirtyinode; which leads to lost inode updates for ISSYNC inodes because...
CVE-2026-89601
This vulnerability affects the Linux kernel ext2 filesystem in the ext2_setsize() and ext2_xattr_set2() functions. The root cause is that for IS_SYNC inodes , sync_inode_metadata() is called without first marking the inode dirty; since that function only operates on already-dirty inodes, inode up...
EUVD-2026-76513
In the Linux kernel, the following vulnerability has been resolved: ext2: Fix lost inode updates for ISSYNC inodes ext2setsize and ext2xattrset2 had a construct like: if ISSYNCinode syncinodemetadatainode, 1; else markinodedirtyinode; which leads to lost inode updates for ISSYNC inodes because...
CVE-2026-89601
In the Linux kernel, the following vulnerability has been resolved: ext2: Fix lost inode updates for ISSYNC inodes ext2setsize and ext2xattrset2 had a construct like: if ISSYNCinode syncinodemetadatainode, 1; else markinodedirtyinode; which leads to lost inode updates for ISSYNC inodes because...
CVE-2026-89601: Undefined Security Weakness
In the Linux kernel, the following vulnerability has been resolved: ext2: Fix lost inode updates for ISSYNC inodes ext2setsize and ext2xattrset2 had a construct like: if ISSYNCinode syncinodemetadatainode, 1; else markinodedirtyinode; which leads to lost inode updates for ISSYNC inodes because...
PT-2026-90317
Name of the Vulnerable Software and Affected Versions Linux kernel affected versions not specified Description An issue exists in the ext2 file system where inode updates may be lost for IS SYNC inodes. This occurs within the ext2 setsize and ext2 xattr set2 functions because sync inode metadata...
PT-2026-96360
In the Linux kernel, the following vulnerability has been resolved: fsnotify: Fix stale object mask after concurrent mark updates When a mark gets a new event bit, fanotify and inotify may avoid recalculating the object mask if the cached aggregate already contains that bit. This is racy with a...
PT-2026-96456
In the Linux kernel, the following vulnerability has been resolved: ext2: Fix lost inode updates for IS SYNC inodes ext2 setsize and ext2 xattr set2 had a construct like: if IS SYNCinode sync inode metadatainode, 1; else mark inode dirtyinode; which leads to lost inode updates for IS SYNC inodes...
PT-2026-90311
Name of the Vulnerable Software and Affected Versions Linux kernel version 6.12.95 Description A race condition exists in the fsnotify system affecting fanotify and inotify. When a mark receives a new event bit, the system may skip recalculating the object mask if the cached aggregate already...
Fedora 45 : cockpit (2026-a002299f28)
The remote Fedora 45 host has a package installed that is affected by a vulnerability as referenced in the FEDORA-2026-a002299f28 advisory. Automatic update for cockpit-367-1.fc45. Changelog for cockpit Thu Aug 27 2026 Packit - 367-1 - Translation updates Tenable has extracted the preceding...
Linux Kernel Security Vulnerabilities
Versions of the Linux kernel prior to 7.2.4 contain security vulnerabilities. These vulnerabilities stem from the ext2 file system, which calls syncinodemetadata without first marking the inode as dirty during the processing of ISSYNC inodes. This can lead to the loss of inode updates...
CVE-2026-88884
A flaw was found in Renovate, a dependency update automation tool. This vulnerability allows for the bypass of the minimumReleaseAge security control when processing digest updates. A remote attacker could exploit this by publishing a malicious dependency version, which Renovate would then...
CVE-2026-88884
Renovate is a dependency update automation tool. In versions before 44.3.1 and Mend Renovate CE/EE images before 15.4.0, mend-renovate-ce Helm chart before 15.4.0, mend-renovate-enterprise-edition Helm chart before 10.4.0, digest updates are not subject to the internal "minimumReleaseAge" stabili...
Reliance on Untrusted Inputs in a Security Decision
Overview renovate is a dependency updater. Affected versions of this package are vulnerable to Reliance on Untrusted Inputs in a Security Decision in the minimumReleaseAge process. An attacker can trigger automated pull requests and CI workflow execution for newly published or malicious dependenc...
CVE-2026-88884 Renovate before 44.3.1 Authentication Bypass via Digest Updates
Renovate is a dependency update automation tool. In versions before 44.3.1 and Mend Renovate CE/EE images before 15.4.0, mend-renovate-ce Helm chart before 15.4.0, mend-renovate-enterprise-edition Helm chart before 10.4.0, digest updates are not subject to the internal minimumReleaseAge stability...
EUVD-2026-75434
Renovate is a dependency update automation tool. In versions before 44.3.1 and Mend Renovate CE/EE images before 15.4.0, mend-renovate-ce Helm chart before 15.4.0, mend-renovate-enterprise-edition Helm chart before 10.4.0, digest updates are not subject to the internal minimumReleaseAge stability...
CVE-2026-88884 Renovate before 44.3.1 Authentication Bypass via Digest Updates
Renovate is a dependency update automation tool. In versions before 44.3.1 and Mend Renovate CE/EE images before 15.4.0, mend-renovate-ce Helm chart before 15.4.0, mend-renovate-enterprise-edition Helm chart before 10.4.0, digest updates are not subject to the internal minimumReleaseAge stability...
CVE-2026-88884 Renovate before 44.3.1 Authentication Bypass via Digest Updates
Renovate is a dependency update automation tool. In versions before 44.3.1 and Mend Renovate CE/EE images before 15.4.0, mend-renovate-ce Helm chart before 15.4.0, mend-renovate-enterprise-edition Helm chart before 10.4.0, digest updates are not subject to the internal minimumReleaseAge stability...
CVE-2026-88884
Renovate , a dependency update automation tool, is affected by a stability-age bypass in versions before 44.3.1 (and Mend Renovate CE/EE images before 15.4.0, mend-renovate-ce Helm chart before 15.4.0, mend-renovate-enterprise-edition Helm chart before 10.4.0). The root cause is that digest updat...