58 matches found
fake-switches (>=1.4.3, <=1.5.0), paps-settings (>=0.2.4a0, <=0.2.6a0) +4 more potentially affected by CVE-2026-115776 via twisted (16.6.0)
twisted PYPI version 16.6.0 is affected by a known vulnerability. The following packages have a transitive dependency on twisted and may be impacted: - fake-switches =1.4.3, =0.2.4a0, =0.2.4, =1.1.4, =2.2.4, =2.2.6 Source cves: CVE-2026-115776 Source advisory: OSV:GHSA-53XC-49M8-P798...
fake-switches (>=1.4.3, <=1.5.0), paps-settings (>=0.2.4a0, <=0.2.6a0) +4 more potentially affected by CVE-2026-115778 via twisted (16.6.0)
twisted PYPI version 16.6.0 is affected by a known vulnerability. The following packages have a transitive dependency on twisted and may be impacted: - fake-switches =1.4.3, =0.2.4a0, =0.2.4, =1.1.4, =2.2.4, =2.2.6 Source cves: CVE-2026-115778 Source advisory: OSV:GHSA-CWM5-JH59-MWXR...
fake-switches (>=1.4.3, <=1.5.0), paps-settings (>=0.2.4a0, <=0.2.6a0) +4 more potentially affected by CVE-2026-106454 via twisted (16.6.0)
twisted PYPI version 16.6.0 is affected by a known vulnerability. The following packages have a transitive dependency on twisted and may be impacted: - fake-switches =1.4.3, =0.2.4a0, =0.2.4, =1.1.4, =2.2.4, =2.2.6 Source cves: CVE-2026-106454 Source advisory: OSV:PYSEC-2026-4304...
fake-switches (>=1.4.3, <=1.5.0), paps-settings (>=0.2.4a0, <=0.2.6a0) +4 more potentially affected by CVE-2026-106454 via twisted (16.6.0)
twisted PYPI version 16.6.0 is affected by a known vulnerability. The following packages have a transitive dependency on twisted and may be impacted: - fake-switches =1.4.3, =0.2.4a0, =0.2.4, =1.1.4, =2.2.4, =2.2.6 Source cves: CVE-2026-106454 Source advisory: OSV:GHSA-8PQF-F4M5-798G...
fake-switches (>=1.4.3, <=1.5.0), paps-settings (>=0.2.4a0, <=0.2.6a0) +4 more potentially affected by CVE-2026-42304 via twisted (16.6.0)
twisted PYPI version 16.6.0 is affected by a known vulnerability. The following packages have a transitive dependency on twisted and may be impacted: - fake-switches =1.4.3, =0.2.4a0, =0.2.4, =1.1.4, =2.2.4, =2.2.6 Source cves: CVE-2026-42304 Source advisory: OSV:PYSEC-2026-160...
fake-switches (>=1.4.3, <=1.5.0), paps-settings (>=0.2.4a0, <=0.2.6a0) +4 more potentially affected by CVE-2026-42304 via twisted (16.6.0)
twisted PYPI version 16.6.0 is affected by a known vulnerability. The following packages have a transitive dependency on twisted and may be impacted: - fake-switches =1.4.3, =0.2.4a0, =0.2.4, =1.1.4, =2.2.4, =2.2.6 Source cves: CVE-2026-42304 Source advisory: OSV:GHSA-GRGV-6HW6-V9G4...
Linux Distros Unpatched Vulnerability : CVE-2022-23607
The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - treq is an HTTP library inspired by requests but written on top of Twisted's Agents. Treq's request methods treq.get, treq.post, etc. and treq.client.HTTPClient...
fake-switches (>=1.4.3, <=1.5.0), paps-settings (>=0.2.4a0, <=0.2.6a0) +4 more potentially affected by CVE-2024-41810 via twisted (16.6.0)
twisted PYPI version 16.6.0 is affected by a known vulnerability. The following packages have a transitive dependency on twisted and may be impacted: - fake-switches =1.4.3, =0.2.4a0, =0.2.4, =1.1.4, =2.2.4, =2.2.6 Source cves: CVE-2024-41810 Source advisory: OSV:GHSA-CF56-G6W6-PQQ2...
fake-switches (>=1.4.3, <=1.5.0), paps-settings (>=0.2.4a0, <=0.2.6a0) +4 more potentially affected by CVE-2024-41671 via twisted (16.6.0)
twisted PYPI version 16.6.0 is affected by a known vulnerability. The following packages have a transitive dependency on twisted and may be impacted: - fake-switches =1.4.3, =0.2.4a0, =0.2.4, =1.1.4, =2.2.4, =2.2.6 Source cves: CVE-2024-41671 Source advisory: OSV:GHSA-C8M8-J448-XJX7...
fake-switches (>=1.4.3, <=1.5.0), paps-settings (>=0.2.4a0, <=0.2.6a0) +4 more potentially affected by CVE-2024-41810 via twisted (16.6.0)
twisted PYPI version 16.6.0 is affected by a known vulnerability. The following packages have a transitive dependency on twisted and may be impacted: - fake-switches =1.4.3, =0.2.4a0, =0.2.4, =1.1.4, =2.2.4, =2.2.6 Source cves: CVE-2024-41810 Source advisory: OSV:PYSEC-2024-75...
OPENSUSE-SU-2024:11806-1 python310-treq-22.1.0-1.1 on GA media
These are all security issues fixed in the python310-treq-22.1.0-1.1 package on the GA media of openSUSE Tumbleweed...
fake-switches (>=1.4.3, <=1.5.0), paps-settings (>=0.2.4a0, <=0.2.6a0) +4 more potentially affected by CVE-2023-46137 via twisted (16.6.0)
twisted PYPI version 16.6.0 is affected by a known vulnerability. The following packages have a transitive dependency on twisted and may be impacted: - fake-switches =1.4.3, =0.2.4a0, =0.2.4, =1.1.4, =2.2.4, =2.2.6 Source cves: CVE-2023-46137 Source advisory: OSV:GHSA-XC8X-VP79-P3WM...
fake-switches (>=1.4.3, <=1.5.0), paps-settings (>=0.2.4a0, <=0.2.6a0) +4 more potentially affected by CVE-2023-46137 via twisted (16.6.0)
twisted PYPI version 16.6.0 is affected by a known vulnerability. The following packages have a transitive dependency on twisted and may be impacted: - fake-switches =1.4.3, =0.2.4a0, =0.2.4, =1.1.4, =2.2.4, =2.2.6 Source cves: CVE-2023-46137 Source advisory: OSV:PYSEC-2023-224...
FreeBSD : py-treq -- sensitive information leak vulnerability (181f5e49-b71d-4527-9464-d4624d69acc3)
The version of FreeBSD installed on the remote host is prior to tested version. It is, therefore, affected by a vulnerability as referenced in the 181f5e49-b71d-4527-9464-d4624d69acc3 advisory. - treq is an HTTP library inspired by requests but written on top of Twisted's Agents. Treq's request...
SUSE CVE-2022-23607
treq is an HTTP library inspired by requests but written on top of Twisted's Agents. Treq's request methods treq.get, treq.post, etc. and treq.client.HTTPClient constructor accept cookies as a dictionary. Such cookies are not bound to a single domain, and are therefore sent to every domain...
fake-switches (>=1.4.3, <=1.5.0), paps-settings (>=0.2.4a0, <=0.2.6a0) +4 more potentially affected by unknown CVE via twisted (16.6.0)
twisted PYPI version 16.6.0 is affected by a known vulnerability. The following packages have a transitive dependency on twisted and may be impacted: - fake-switches =1.4.3, =0.2.4a0, =0.2.4, =1.1.4, =2.2.4, =2.2.6 Source cves: unknown CVE Source advisory: OSV:GHSA-8R99-H8J2-RW64...
OPENSUSE-SU-2022:10098-1 Security update for python-treq
This update for python-treq fixes the following issues: - Fixed CVE-2022-23607 boo1195432 binding cookies to the domain...
Security update for python-treq (moderate)
openSUSE Security Update: Security update for python-treq Announcement ID: openSUSE-SU-2022:10098-1 Rating: moderate References: 1195432 Cross-References: CVE-2022-23607 CVSS scores: CVE-2022-23607 NVD : 7.4 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:N Affected Products: openSUSE Backports...
fake-switches (>=1.4.3, <=1.5.0), paps-settings (>=0.2.4a0, <=0.2.6a0) +4 more potentially affected by CVE-2022-24801 via twisted (16.6.0)
twisted PYPI version 16.6.0 is affected by a known vulnerability. The following packages have a transitive dependency on twisted and may be impacted: - fake-switches =1.4.3, =0.2.4a0, =0.2.4, =1.1.4, =2.2.4, =2.2.6 Source cves: CVE-2022-24801 Source advisory: OSV:GHSA-C2JG-HW38-JRQQ...
fake-switches (>=1.4.3, <=1.5.0), paps-settings (>=0.2.4a0, <=0.2.6a0) +4 more potentially affected by CVE-2022-24801 via twisted (16.6.0)
twisted PYPI version 16.6.0 is affected by a known vulnerability. The following packages have a transitive dependency on twisted and may be impacted: - fake-switches =1.4.3, =0.2.4a0, =0.2.4, =1.1.4, =2.2.4, =2.2.6 Source cves: CVE-2022-24801 Source advisory: OSV:PYSEC-2022-195...