112 matches found
impersonate-rs
IRS Impersonate-RS 💡 IRS is a library version of https://github.com/zblurx/impersonate-rs, zblurx Reimplementation of Defte Impersonate in plain Rust. For more informations about it, see this blogpost. The token impersonation approach is a bit different from Defte Impersonate : here you have to...
TokenUniverse
Token Universe Token Universe is an advanced tool for experimenting and researching Windows security mechanisms. It exposes UI for creating, viewing, impersonating, and modifying access tokens, spawning processes, managing Local Security Authority, checking available access and modifying security...
awesome_windows_logical_bugs
awesomewindowslogicalbugs Created this repo for the people who want to learn about windows logical privilege escalation bugs. And also I added some of my findings. You can contact me via @404death to add good article which I missed. work in progress WIP , I'm always update this repo when the new...
RemoteRecon
RemoteRecon Remote Recon and Collection RemoteRecon provides the ability to execute post-exploitation capabilities against a remote host, without having to expose your complete toolkit/agent. Often times as operator's we need to compromise a host, just so we can keylog or screenshot or some other...
RottenPotatoNG
RottenPotatoNG New version of RottenPotato as a C++ DLL and standalone C++ binary - no need for meterpreter or other tools. RottenPotatoDLL This project generates a DLL and EXE file. The DLL contains all the code necessary to perform the RottenPotato attack and get a handle to a privileged token...
Important: Red Hat Security Advisory: goose security update
An update for goose is now available for Red Hat Enterprise Linux 9. For details on how to apply this update, which includes the changes described in this advisory, refer to: https://access.redhat.com/articles/11258 Security Fixes: goose: Arbitrary command execution via malicious Git configuratio...
rmcp: RMCP: Token impersonation via missing OAuth resource field validation
A flaw was found in rmcp, a Rust SDK for the Model Context Protocol. The OAuth implementation in rmcp omits the RFC 9728 resource field from ResourceServerMetadata. This allows a malicious Model Context Protocol MCP server to publish metadata for a different legitimate MCP resource. Consequently,...
RottenPotato
This code is no longer maintained - for a newer implementation see https://github.com/breenmachine/RottenPotatoNG RottenPotato Local Privilege Escalation from Windows Service Accounts to SYSTEM For a technical overview of this exploit see our blog post at...
Masky
Masky Masky is a python library providing an alternative way to remotely dump domain users' credentials thanks to an ADCS. A command line tool has been built on top of this library in order to easily gather PFX, NT hashes and TGT on a larger scope. This tool does not exploit any new vulnerability...
Auto-Elevate
Auto-Elevate This tool demonstrates the power of UAC bypasses and built-in features of Windows. This utility auto-locates winlogon.exe, steals and impersonates it's process TOKEN, and spawns a new SYSTEM-level process with the stolen token. Combined with UAC bypass method 41 ICMLuaUtil UAC bypass...
CVE-2020-11493
CVE-2020-11492 Proof-of-Concept PoC for Docker Desktop for Windows privilege escalation vulnerability. This vulnerability was patched in Docker version 2.3.0.2 on May 11th, 2020. This PoC performs the following: creates a named pipe mimicking docker named pipe \.\pipe\dockerLifecycleServer, call...
TokenPlayer
TokenPlayer Manipulating and Abusing Windows Access Tokens. TokenPlayer is just a small tool i made to learn win32 api programming and understand better the access token model of windows. Features: Stealing and Impersonating primary tokens. Impersonating Protected Processes. Bypassing UAC by usin...
sandbox-attacksurface-analysis-tools
sandbox-attacksurface-analysis-tools Version 2. c Google LLC. 2015 - 2024 Entwickelt von James Forshaw Dies ist eine kleine Suite von PowerShell-Tools zum Testen verschiedener Eigenschaften von Sandboxes unter Windows. Viele der Tools akzeptieren einen -ProcessId-Schalter, mit dem die PID eines...
PrintSpoofer-ReflectiveDLL
PrintSpoofer Details PrintSpoofer is a tool that performs local privilege escalation by exploiting a vulnerability in the Windows Print Spooler service CVE-2019-1040 / CVE-2019-1019. This project implements the PrintSpoofer exploit in Reflective DLL format, making it suitable for use with...
CVE-2020-11492
CVE-2020-11492 Proof-of-Concept PoC for Docker Desktop for Windows privilege escalation vulnerability. This vulnerability was patched in Docker version 2.3.0.2 on May 11th, 2020. This PoC performs the following: creates a named pipe mimicking docker named pipe \.\pipe\dockerLifecycleServer, call...
BackupCreds
BackupCreds | | | | | | | Dump all the Creds! | | | | | | | | | | | | Lefteris lefty Panos | || Abusing SeTrustedCredmanAccessPrivilege to dump user creds The program provides the ability to dump the stored credentials a user might have in the Windows Credential Manager. It is a useful technique ...
TokenStealer
TokenStealer A simple tool I wrote some time ago for stealing and playing with Windows tokens. Parts of code have been taken and adatpted from https://github.com/FSecureLABS/incognito Clearly, you will require Impersonation or AssignPrimary privilege and Debug privilege to access all processes...
UAC-to-SYSTEM-POC
UAC-to-SYSTEM-POC UAC using token impersonation POC !Alt tex...
CVE-2026-55770
OpenBao is an open source identity-based secrets management system. Prior to 2.5.5, OpenBao used EscapeLDAPValue, an RFC 4514 distinguished-name escaping function, where RFC 4515 LDAP search-filter escaping was required in sdk/helper/ldaputil/client.go GetUserDN. With the LDAP authentication...
CVE-2026-48722 Nextflow: Incorrect default permissions in the nextflow auth login command
Nextflow is a DSL for data-driven computational pipelines. From 25.09.2-edge until 25.10.6 and 26.04.3, nextflow auth login writes Seqera Platform OIDC bearer tokens to $NXFHOME:-/.nextflow/seqera-auth.config through AuthCommandImpl.writeConfig in...