72 matches found
CLSA-2026-1779670108 TuxCare security update for langchain-text-splitters (2 CVEs)
TuxCare rebuilt langchain-text-splitters to address 2 CVEs. Fixed in 0.3.11.post1+tuxcare...
PT-2026-74855
TuxCare rebuilt langchain-text-splitters to address 1 CVE. Fixed in 0.3.11.post1+tuxcare...
PYSEC-2026-1520 LangChain Text Splitters is vulnerable to XML External Entity (XXE) attacks due to unsafe XSLT parsing
The HTMLSectionSplitter class in langchain-text-splitters is vulnerable to XML External Entity XXE attacks due to unsafe XSLT parsing. This vulnerability arises because the class allows the use of arbitrary XSLT stylesheets, which are parsed using lxml.etree.parse and lxml.etree.XSLT without any...
a2a-client-handler (0.1.0), aa-rag (>=0.1.0, <=0.4.3) +607 more potentially affected by CVE-2025-6985 via langchain-text-splitters (>=0.0.1, <=0.3.8)
langchain-text-splitters PYPI version =0.0.1, =0.1.0, =0.1.3, =0.1.0b0, =4.8.2, =0.1.0, =0.0.2, =0.1.31, =0.0.1, =0.1.0, =0.1.2 and more Source cves: CVE-2025-6985 Source advisory: OSV:PYSEC-2026-1520...
LangChain Text Splitters is vulnerable to XML External Entity (XXE) attacks due to unsafe XSLT parsing
The HTMLSectionSplitter class in langchain-text-splitters is vulnerable to XML External Entity XXE attacks due to unsafe XSLT parsing. This vulnerability arises because the class allows the use of arbitrary XSLT stylesheets, which are parsed using lxml.etree.parse and lxml.etree.XSLT without any...
Security Bulletin: Maximo AI Service uses multiple third party dependencies which are vulnerable to multiple CVEs.
Summary Maximo AI Service uses pdfminersix-20251107-py3-none-any.whl, requests-2.32.5-py3-none-any.whl, langchaincore-0.3.81-py3-none-any.whl, pythondotenv-1.0.1-py3-none-any.whl, langchaintextsplitters-0.3.11-py3-none-any.whl, qs-6.15.1.tgz, idna-3.10-py3-none-any.whl, idna-3.14-py3-none-any.whl...
ROOT-APP-PYPI-CVE-2026-41481 CVE-2026-41481 in rootio-langchain-text-splitters - Patched by Root
Root has patched CVE-2026-41481 in the rootio-langchain-text-splitters package for Root:PyPI. Multiple fixed versions available...
ROOT-APP-PYPI-CVE-2025-6985 CVE-2025-6985 in rootio-langchain-text-splitters - Patched by Root
Root has patched CVE-2025-6985 in the rootio-langchain-text-splitters package for Root:PyPI. Multiple fixed versions available...
PT-2026-45207
Root has patched GHSA-fv5p-p927-qmxr in the rootio-langchain-text-splitters package for Root:PyPI. Multiple fixed versions available...
CVE-2026-41481 vulnerabilities
Vulnerabilities for packages: open-webui...
CVE-2026-41481 vulnerabilities
Vulnerabilities for packages: open-webui, py3-langchain-text-splitters...
CVE-2026-41481
A flaw was found in LangChain and langchain-text-splitters. This vulnerability, a Server-Side Request Forgery SSRF bypass, allows a remote attacker to redirect a seemingly safe URL to internal network resources. By exploiting unvalidated redirects, an attacker could access sensitive data from...
ano-code (>=0.1.6, <=0.1.11), khoj (>=1.41.1.dev34, <=2.0.0b16.dev0) +1 more potentially affected by CVE-2026-41481 via langchain-text-splitters (0.3.1)
langchain-text-splitters PYPI version 0.3.1 is affected by a known vulnerability. The following packages have a transitive dependency on langchain-text-splitters and may be impacted: - ano-code =0.1.6, =1.41.1.dev34, =1.21.0, =1.21.1 Source cves: CVE-2026-41481 Source advisory: OSV:PYSEC-2026-77...
ai-enterprise-agent (>=0.0.2, <=0.0.9), data-digitization (0.1.0) +20 more potentially affected by CVE-2026-41481 via langchain-text-splitters (0.0.1)
langchain-text-splitters PYPI version 0.0.1 is affected by a known vulnerability. The following packages have a transitive dependency on langchain-text-splitters and may be impacted: - ai-enterprise-agent =0.0.2, =0.1.14, =0.1.0, =0.0.2, =0.1.0, =0.1.0, =0.1.3, =0.0.15, =1.0.6, =0.1.0b0, =0.5.0b1...
autonomous-agent (0.0.1), creao (>=0.2.11, <=0.2.25) +23 more potentially affected by CVE-2026-41481 via langchain-text-splitters (0.2.2)
langchain-text-splitters PYPI version 0.2.2 is affected by a known vulnerability. The following packages have a transitive dependency on langchain-text-splitters and may be impacted: - autonomous-agent 0.0.1 - creao =0.2.11, =0.1.1, =0.1.0, =0.1.3, =0.1.3, =1.0.0, =0.0.90, =0.1.5, =1.2.0, =0.1.1,...
act-workflow (>=4.8.2, <=4.8.399), agent-builder (0.0.1) +21 more potentially affected by CVE-2026-41481 via langchain-text-splitters (0.3.0)
langchain-text-splitters PYPI version 0.3.0 is affected by a known vulnerability. The following packages have a transitive dependency on langchain-text-splitters and may be impacted: - act-workflow =4.8.2, =0.0.1, =1.0.0, =0.1.0, =0.1.0, =0.1.3, =0.0.4, =0.0.3, =0.1.0, =0.1.0, =0.1.12 and more...
abs-langchain-suite (>=0.1.0, <=0.3.1), acp-cli (>=0.0.1, <=0.0.804) +741 more potentially affected by CVE-2026-41481 via langchain-text-splitters (0.3.11)
langchain-text-splitters PYPI version 0.3.11 is affected by a known vulnerability. The following packages have a transitive dependency on langchain-text-splitters and may be impacted: - abs-langchain-suite =0.1.0, =0.0.1, =0.0.1a1, =0.1.0, =1.0.0rc1, =3.2.0, =0.1.0, =0.1.1, =0.1.1, =0.0.1a0,...
agent-nexus-cli (>=0.1.0, <=0.1.31), agentiva (>=0.1.0, <=0.1.5) +24 more potentially affected by CVE-2026-41481 via langchain-text-splitters (>=1.0.0a1, <=1.1.1)
langchain-text-splitters PYPI version =1.0.0a1, =0.1.0, =0.1.0, =3.0.3, =3.1.0, =6.4.21, =0.1.0, =0.1.0, =0.4.0, =0.0.4, =0.8.0, =0.8.15 and more Source cves: CVE-2026-41481 Source advisory: OSV:PYSEC-2026-77...
anoteai (0.11.0), assistant (>=1.0.0b1, <=1.2.1b1) +16 more potentially affected by CVE-2026-41481 via langchain-text-splitters (0.2.1)
langchain-text-splitters PYPI version 0.2.1 is affected by a known vulnerability. The following packages have a transitive dependency on langchain-text-splitters and may be impacted: - anoteai 0.11.0 - assistant =1.0.0b1, =0.1.33, =0.0.5, =1.0.0, =0.1.3, =1.1.0rc1, =0.0.1, =0.1.2, =0.0.1, =0.6.0a...
a2a-client-handler (0.1.0), aa-rag (>=0.4.2, <=0.4.3) +107 more potentially affected by CVE-2026-41481 via langchain-text-splitters (0.3.8)
langchain-text-splitters PYPI version 0.3.8 is affected by a known vulnerability. The following packages have a transitive dependency on langchain-text-splitters and may be impacted: - a2a-client-handler 0.1.0 - aa-rag =0.4.2, =0.1.3, =0.5.18, =0.1.3, =0.0.45, =0.1.1, =0.0.1, =0.0.1, =0.0.9 and...