91 matches found
CVE-2026-105689
Penpot is an open-source design and prototyping platform. Prior to 2.18.0, app.util.ssrf/blocked-address? relies on Java InetAddress predicates that do not classify NAT64, 6to4, or Teredo addresses and applies additional CIDR checks only to IPv4 values. Exploitation requires routing through a NAT...
ip-https-tools
ip-https-tools A collection of tools for the IP over HTTPS IP-HTTPS Tunneling Protocol used by Microsoft DirectAccess to send Teredo related IPv6 packets over an IPv4-based HTTPS session. MS-IPHTTPS protocol pecification DirectAccess Technical Overview DirectAccess Requirements DirectAccess...
cve-2019-1422
cve-2019-1422 A worthless vulnerability, garbage. Retest manually deleting teredo.txt or iphttps.txt under the c:\windows\temp directory...
CVE-2026-85738 TREK: SSRF Guard Bypass via IPv6 Transition Addresses (NAT64/6to4)
TREK is a collaborative travel planner. Prior to 3.4.0, the checkSsrf logic in server/src/utils/ssrfGuard.ts does not recognize NAT64, 6to4, or Teredo IPv6 transition addresses that encode an IPv4 destination. An authenticated user who controls a DNS record can supply a URL whose AAAA result is a...
CVE-2026-85738
The collaborative travel planner TREK (prior to version 3.4.0 ) is vulnerable to a Server-Side Request Forgery (SSRF) due to a flaw in the checkSsrf logic located in server/src/utils/ssrfGuard.ts. The application fails to recognize NAT64, 6to4, or Teredo IPv6 transition addresses that encode an I...
CVE-2026-93597: Server-Side Request Forgery (SSRF)
ArcadeDB versions before 26.9.1 fail to validate IPv6 transition addresses in the SSRF guard used by IMPORT DATABASE and server commands. Authenticated attackers can supply URLs resolving to NAT64, 6to4, or Teredo addresses embedding RFC 1918 or loopback IPv4 payloads to reach internal services a...
CVE-2026-88896
EspoCRM before 10.0.4 is vulnerable to Server-Side Request Forgery (SSRF) via an IPv6 transition address bypass in HostCheck::ipAddressIsNotInternal(). The function strips ::ffff: (IPv4-mapped IPv6) prefixes but fails to recognize IPv6 transition addresses that embed private IPv4 addresses—NAT64 ...
Dozzle: SSRF guard bypass via IPv6 transition addresses (6to4/NAT64/Teredo) in webhook notification dispatcher
Summary The isBlockedIP SSRF guard in Dozzle's webhook notification dispatcher blocks loopback, link-local, multicast, and unspecified addresses but does not recognize IPv6 transition mechanism addresses RFC 3056 6to4, RFC 6052 NAT64, RFC 4380 Teredo that embed arbitrary IPv4 addresses. An...
GHSA-P2W3-6X73-2F6X Dozzle: SSRF guard bypass via IPv6 transition addresses (6to4/NAT64/Teredo) in webhook notification dispatcher
Summary The isBlockedIP SSRF guard in Dozzle's webhook notification dispatcher blocks loopback, link-local, multicast, and unspecified addresses but does not recognize IPv6 transition mechanism addresses RFC 3056 6to4, RFC 6052 NAT64, RFC 4380 Teredo that embed arbitrary IPv4 addresses. An...
CVE-2026-79749
MCPHub is a unified hub for centrally managing and dynamically orchestrating multiple MCP servers/APIs into separate endpoints with flexible routing strategies. Prior to version 1.0.32, MCPHub's SSRF guard in src/utils/ssrf.ts uses a custom isBlockedIpv6 function that only checks for loopback,...
CVE-2026-79749 MCPHub: SSRF Guard Bypass via IPv6 Transition Addresses in URL Validation
MCPHub is a unified hub for centrally managing and dynamically orchestrating multiple MCP servers/APIs into separate endpoints with flexible routing strategies. Prior to version 1.0.32, MCPHub's SSRF guard in src/utils/ssrf.ts uses a custom isBlockedIpv6 function that only checks for loopback,...
CVE-2026-81678: Server-Side Request Forgery (SSRF)
AVideo before 24.0 contains a server-side request forgery vulnerability in the isSSRFSafeURL function that fails to extract embedded IPv4 addresses from NAT64, 6to4, and Teredo IPv6 transition address formats. Unauthenticated attackers can bypass SSRF protections via the LiveLinks proxy endpoint ...
CVE-2026-74905
SiYuan before v3.7.4 contains a server-side request forgery SSRF vulnerability in the isPrivateIP function in kernel/util/net.go, used by SSRFSafeDialer to enforce SSRF protection in SafeMode. The function only checks for loopback, link-local unicast, private, and unspecified addresses and does n...
CVE-2026-73297
Microsoft UFO open-source framework for intelligent automation across devices and platforms. Prior to 3.0.8, isblockedip in ufo/utils/urlsecurity.py did not block NAT64 prefixes 64:ff9b::/96 and 64:ff9b:1::/48, the 6to4 prefix 2002::/16, or the Teredo prefix 2001::/32 and did not re-check embedde...
CVE-2026-73297 Microsoft UFO: IPv6 transition address bypass of SSRF guard in URL validation
Microsoft UFO open-source framework for intelligent automation across devices and platforms. Prior to 3.0.8, isblockedip in ufo/utils/urlsecurity.py did not block NAT64 prefixes 64:ff9b::/96 and 64:ff9b:1::/48, the 6to4 prefix 2002::/16, or the Teredo prefix 2001::/32 and did not re-check embedde...
CVE-2026-73297 Microsoft UFO: IPv6 transition address bypass of SSRF guard in URL validation
Microsoft UFO open-source framework for intelligent automation across devices and platforms. Prior to 3.0.8, isblockedip in ufo/utils/urlsecurity.py did not block NAT64 prefixes 64:ff9b::/96 and 64:ff9b:1::/48, the 6to4 prefix 2002::/16, or the Teredo prefix 2001::/32 and did not re-check embedde...
CVE-2026-73297 Microsoft UFO: IPv6 transition address bypass of SSRF guard in URL validation
Microsoft UFO open-source framework for intelligent automation across devices and platforms. Prior to 3.0.8, isblockedip in ufo/utils/urlsecurity.py did not block NAT64 prefixes 64:ff9b::/96 and 64:ff9b:1::/48, the 6to4 prefix 2002::/16, or the Teredo prefix 2001::/32 and did not re-check embedde...
CVE-2026-73297
The CVE-2026-73297 entry concerns Microsoft UFO, an open-source framework for automation across devices and platforms. Before version 3.0.8, the function _is_blocked_ip in ufo/utils/url_security.py failed to block IPv6 NAT64 prefixes (64:ff9b::/96 and 64:ff9b:1::/48), the 6to4 prefix (2002::/16),...
EUVD-2026-57325
Microsoft UFO open-source framework for intelligent automation across devices and platforms. Prior to 3.0.8, isblockedip in ufo/utils/urlsecurity.py did not block NAT64 prefixes 64:ff9b::/96 and 64:ff9b:1::/48, the 6to4 prefix 2002::/16, or the Teredo prefix 2001::/32 and did not re-check embedde...
CVE-2026-73297: Server-Side Request Forgery (SSRF)
Microsoft UFO open-source framework for intelligent automation across devices and platforms. Prior to 3.0.8, isblockedip in ufo/utils/urlsecurity.py did not block NAT64 prefixes 64:ff9b::/96 and 64:ff9b:1::/48, the 6to4 prefix 2002::/16, or the Teredo prefix 2001::/32 and did not re-check embedde...