217 matches found
CVE-2025-29972
CVE-2025-29927 - Critical Security Vulnerability in Next.js Overview CVE-2025-29927 is a critical security vulnerability affecting Next.js , a popular React framework for building full-stack web applications. This flaw allows attackers to bypass authorization checks implemented in Next.js...
CVE-2025-29927-POC
CVE-2025-29927-POC Introduction This repository contains a Proof of Concept PoC for CVE-2025-29927, a hypothetical vulnerability demonstrating a flaw in middleware handling within a web application. The PoC illustrates how a specially crafted HTTP request can bypass redirection logic to access...
CVE-2025-55182
CVE-2025-55182 / CVE-2025-66478 — Next.js Middleware / RSC Bypass Analysis The author assumes no liability for misuse or damage caused by this research Provided strictly for educational and defensive purposes Description This repository contains a small laboratory and Proof-of-Concept analysis fo...
CVE-2025-2995
CVE-2025-29927 Authorization Bypass reproduction This repository is a reproduction of the CVE-2025-29927 vulnerability in the next package How to reproduce 1. Follow the steps below to clone, and run the Next.js application 2. Test authorization denies access to the /api/hello endpoint $ curl...
CVE-2025-29927
Next.js Vulnerability Demo CVE-2025-29927 This repository contains a demonstration of the Next.js vulnerability CVE-2025-29927, which affects Next.js version 15.2.2 and earlier. The vulnerability allows attackers to bypass middleware authentication checks by setting an x-middleware-subrequest...
CVE-2024-40275_Scanner
CVE-2024-40725 Scanner A Python-based detection tool for CVE-2024-40725 , an Apache HTTP Server source code disclosure vulnerability affecting versions 2.4.0 and 2.4.61. Legal notice: Only run this scanner against servers you own or have explicit written authorization to test. Unauthorized use ma...
CVE-2025-29927-NextJs-Middleware-Simulation
CVE-2025-29927: Next.js Middleware Authorization Bypass Simulation This repository demonstrates the exploitation of CVE-2025-29927 , a critical vulnerability in Next.js that allows attackers to bypass middleware-based authorization checks. The flaw stems from improper handling of the internal...
CVE-2025-29927
🕷️ Next.js CVE-2025-29927 🧑🏻💼 Legal Disclaimer This project is a Next.js application that has been intentionally configured to be vulnerable to an Authorization Bypass in Next.js Middleware CVE-2025-29927. It is provided solely for lawful, educational, and research purposes. By accessing, using,...
vulnerable-nextjs-14-CVE-2025-29927
CVE-2025-29927 Authorization Bypass reproduction This repository is a reproduction of the CVE-2025-29927 vulnerability in the next package How to reproduce 1. Follow the steps below to clone, and run the Next.js application 2. Test authorization denies access to the /api/hello endpoint $ curl...
NextBypass
NextBypass 🚨 Next.js Middleware Authorization Bypass Tool CVE-2025-29927 Features Exploit CVE-2025-29927 via x-middleware-subrequest header Auto-browser integration Proxy/Bookmarklet Vulnerability scanning & log analysis Network traffic monitoring Installation git clone...
CVE-2025-29927
CVE-2025-29927 Next.js Middleware Authorization Bypass The detection template for CVE-2025-29927 is now officially part of the Nuclei Templates repository. https://github.com/projectdiscovery/nuclei-templates/blob/main/headless/cves/2025/CVE-2025-29927-HEADLESS.yaml A critical vulnerability in...
CVE-2025-29927-Testing
Testing script for CVE-2025-29927 Provided by CyberMaxx. CVE-2025-29927 Tester This PowerShell script is designed to help security researchers and system administrators test for CVE-2025-29927 vulnerabilities in Next.js applications. It checks whether a target application is vulnerable to the...
CVE-2025-29927-PoC
CVE-2025-29927 - Next.js Middleware Authorization Bypass PoC This repository contains a Proof of Concept PoC exploit for CVE-2025-29927 , a critical vulnerability in Next.js that allows attackers to bypass authorization checks by abusing a middleware-specific HTTP header. Overview CVE ID:...
nextjs-middleware-bypass-demo
CVE-2025-29927 Demo Original writeup: https://zhero-web-sec.github.io/research-and-things/nextjs-and-the-corrupt-middleware Setup First, run the development server: npm i npm run dev Open http://localhost:3000 with your browser to see the result. Trying out the bypass curl -I http://localhost:300...
CVE-2025-29927
Next.js CVE-2025-29927 This repository contains a proof of concept for CVE-2025-29927 vulnerability in Next.js, where the internal header x-middleware-subrequest can be exploited to bypass middleware checks such as authentication. Affected Versions Next.js 15.x 🧪 This project was tested with...
CVE-2025-29927
CVE-2025-29927 – Next.js Middleware Authorization Bypass This repository contains a functional exploit for CVE-2025-29927, a critical authorization bypass vulnerability in Next.js. The flaw allows attackers to bypass middleware-based authentication and authorization checks, granting unauthorized...
CVE-2025-29927
Introduction Bypass Next.js middleware authentication mechanism by forging the x-middleware-subrequest request header, allowing unauthorized access to protected routes. Environment setup Source code derived from P神, Next.js version 15.2.2 For Next.js 15.x, this issue is fixed in 15.2.3...
CVE-2025-29927
CVE-2025-29927: Next.js Middleware Bypass Vulnerability This repository demonstrates the CVE-2025-29927 vulnerability in Next.js where the internal header x-middleware-subrequest can be used to bypass middleware checks like authentication. Vulnerability Details Next.js uses an internal header...
CVE-2025-29927
CVE-2025-29927: The Next.js Middleware Nightmare This repository is provided strictly for educational purposes only. I did not discover this vulnerability - this is a demonstration and explanation of a publicly disclosed security issue. Using this knowledge to exploit vulnerable systems without...
CVE-2025-29927
CVE-2025-29927 Next.js Middleware Bypass Scanner CVE-2025-29927 CVE-2025-29927 is a specialized security tool for detecting the Next.js middleware bypass vulnerability CVE-2025-29927 affecting Next.js versions 11.1.4 through 15.2.2. This critical vulnerability allows attackers to bypass security...