12110 matches found
CVE-2019-5152
An exploitable information disclosure vulnerability exists in the network packet handling functionality of Shadowsocks-libev 3.3.2. When utilizing a Stream Cipher, a specially crafted set of network packets can cause an outbound connection from the server, resulting in information disclosure. An...
CVE-2020-6113
An exploitable vulnerability exists in the object stream parsing functionality of Nitro Software, Inc.’s Nitro Pro 13.13.2.242 when updating its cross-reference table. When processing an object stream from a PDF document, the application will perform a calculation in order to allocate memory for...
CVE-2024-7423
The Stream plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 4.0.1. This is due to missing or incorrect nonce validation on the networkoptionsaction function. This makes it possible for unauthenticated attackers to update arbitrary options that...
CVE-2024-32984
Yamux is a stream multiplexer over reliable, ordered connections such as TCP/IP. The Rust implementation of the Yamux stream multiplexer uses a vector for pending frames. This vector is not bounded in length. Every time the Yamux protocol requires sending of a new frame, this frame gets appended ...
CVE-2024-8287
Anbox Management Service, in versions 1.17.0 through 1.23.0, does not validate the TLS certificate provided to it by the Anbox Stream Agent. An attacker must be able to machine-in-the-middle the Anbox Stream Agent from within an internal network before they can attempt to take advantage of this...
Discourse cross-site scripting vulnerabilities
Discourse is an open source community discussion platform from Discourse Open Source. The platform includes community, email, and chat room features. Discourse suffers from a cross-site scripting vulnerability that stems from the fact that the activity stream in a user's profile page may be...
This Week in Spring - February 4th, 2025
Hi, Spring fans! Welcome to another installment of This Week in Spring! It's February 4th, 2025, as I write this. We are ten days away from Valentine's day, and about a month away from Devnexus. Lots to look forward to, in both the short term and the long term! Let's dive right into this week's...
com.github.alexmojaki:s3-stream-upload (1.0), com.hotels:circus-train-common-test (10.0.0) +1 more potentially affected by CVE-2025-24961 via org.gaul:s3proxy (>=1.4.0, <=1.6.1)
org.gaul:s3proxy MAVEN version =1.4.0, =0.9.0-preview1, =0.9.0-preview2 Source cves: CVE-2025-24961 Source advisory: MEND:CVE-2025-24961...
com.github.alexmojaki:s3-stream-upload (1.0) potentially affected by CVE-2025-24961 via org.gaul:s3proxy (1.4.0)
org.gaul:s3proxy MAVEN version 1.4.0 is affected by a known vulnerability. The following packages have a transitive dependency on org.gaul:s3proxy and may be impacted: - com.github.alexmojaki:s3-stream-upload 1.0 Source cves: CVE-2025-24961 Source advisory: OSV:GHSA-2CCP-VQMV-4R4X...
WordPress WP Social Stream plugin <= 1.1 - CSRF to Stored XSS vulnerability
CSRF to Stored XSS vulnerability discovered by SOPROBRO Patchstack Alliance in WordPress Plugin WP Social Stream versions = 1.1...
PT-2025-14366
Name of the Vulnerable Software and Affected Versions Linux kernel affected versions not specified Description The issue concerns out-of-bound accesses in the Linux kernel, specifically in the drm/amd/display component. The problem arises because hpo stream to link encoder mapping has a size of M...
Code-Projects Job Recruitment: Code Injection Vulnerabilities
Code-Projects Job Recruitment is an open source job portal from Code-Projects. A code injection vulnerability exists in Code-Projects Job Recruitment version 1.0, which stems from a cross-site scripting attack due to manipulation of the parameter businessstreamname...
PT-2025-4114 · Unknown · Code-Projects Job Recruitment
Name of the Vulnerable Software and Affected Versions: code-projects Job Recruitment version 1.0 Description: A problematic issue has been found in the file / parse/load job-details.php, where the manipulation of the business stream name and company website url arguments leads to cross site...
[SECURITY] Fedora 40 Update: expat-2.6.4-1.fc40
This is expat, the C library for parsing XML, written by James Clark. Expat is a stream oriented XML parser. This means that you register handlers with the parser prior to starting the parse. These handlers are called when the parser discovers the associated structures in the document being parse...
CVE-2024-47891
A security vulnerability exists in the Imagination GPU Driver (Graphics DDK) where software running as a non-privileged user can conduct improper GPU system calls. This flaw triggers use-after-free kernel exceptions due to a race condition resulting in an exploitable double free on the PTL_STREAM...
unbound security update
1.16.2-5.8 - Prevent unbounded name compression CVE-2024-8508 1.16.2-5.7 - Rebuild to propagate to CentOS Stream RHEL-25500...
PT-2025-5630 · Hashicorp · Yamux
Name of the Vulnerable Software and Affected Versions: github.com/hashicorp/yamux affected versions not specified Description: The issue concerns a potential denial of service due to timed out writes. When the default values for Session.config.KeepAliveInterval and...
Bento4 security vulnerabilities
Bento4 is an open source C++ library for reading and writing MP4 files from Axiomatic Systems. A security vulnerability exists in Bento4 that stems from the presence of a buffer overflow vulnerability that allows a local attacker to execute arbitrary code via AP4MemoryByteStream::WritePartial...
KSMBD Heap Buffer Overflow DoS
The vulnerability of the ksmbdvfsstreamread function in the KSMBD daemon of the Linux operating system is related to the execution of operations outside the buffer in memory. Exploiting this vulnerability can allow a remote attacker to disclose sensitive information and cause service failures by...
PT-2025-3460 · Bento4 · Bento4
Name of the Vulnerable Software and Affected Versions: Bento4 mp42avc version 3bdc891602d19789b8e8626e4a3e613a937b4d35 Description: The issue allows a local attacker to execute arbitrary code via the AP4 MemoryByteStream::WritePartial function. This is a buffer overflow vulnerability...