39648 matches found
CVE-2026-28494
ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to versions 7.1.2-16 and 6.9.13-41, a stack buffer overflow exists in ImageMagick's morphology kernel parsing functions. User-controlled kernel strings exceeding a buffer are copied into fixed-siz...
UBUNTU-CVE-2026-28690
ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to versions 7.1.2-16 and 6.9.13-41, a stack buffer overflow vulnerability exists in the MNG encoder. There is a bounds checks missing that could corrupting the stack with attacker-controlled data...
CVE-2026-28494
A flaw was found in ImageMagick. This vulnerability, a stack buffer overflow, allows an attacker to cause stack corruption by providing maliciously crafted kernel strings. This can lead to arbitrary code execution or a denial of service DoS, impacting the availability and integrity of the system...
CVE-2025-70250
Stack buffer overflow vulnerability in D-Link DIR-513 v1.10 via the curTime parameter to goform/formdumpeasysetup...
SUSE CVE-2026-29076
cpp-httplib is a C++11 single-file header-only cross platform HTTP/HTTPS library. Prior to version 0.37.0, cpp-httplib uses std::regex libstdc++ to parse RFC 5987 encoded filename values in multipart Content-Disposition headers. The regex engine in libstdc++ implements backtracking via deep...
ImageMagick security vulnerabilities
ImageMagick is a set of open-source image processing software developed by the ImageMagick project. It can read, convert, and write images in various formats. Versions of ImageMagick prior to 7.1.2-16 and 6.9.13-41 contained security vulnerabilities. These vulnerabilities were caused by stack...
ImageMagick security vulnerabilities
ImageMagick is a set of open-source image processing software developed by the ImageMagick project. It allows for reading, converting, and writing images in various formats. Versions of ImageMagick prior to 7.1.2-16 and 6.9.13-41 contained security vulnerabilities. These vulnerabilities were due ...
ImageMagick buffer error vulnerability
ImageMagick is a set of open-source image processing software developed by the ImageMagick project. It can read, convert, and write images in various formats. Versions of ImageMagick prior to 7.1.2-16 and 6.9.13-41 contained a buffer error vulnerability. This vulnerability stemmed from a stack...
Fortinet FortiManager security vulnerabilities
Fortinet FortiManager is a centralized network security management platform developed by Fortinet, a US-based company. This platform supports centralized management of any number of Fortinet devices and allows for grouping devices into different management domains ADOMs, thereby simplifying the...
Fortinet FortiWeb security vulnerability
Fortinet FortiWeb is a Web application layer firewall developed by the American company Fortinet. It can block threats such as cross-site scripting, SQL injection, cookie poisoning, and schema poisoning, ensuring the security of web applications and protecting sensitive database content. There is...
Siemens SICAM SIAPP SDK security vulnerabilities
Siemens SICAM SIAPP SDK is a software development kit from Siemens, Germany. The Siemens SICAM SIAPP SDK suffers from a stack buffer overflow vulnerability that can be exploited by an attacker to cause a stack overflow, which can be exploited for code execution and denial of service...
Siemens SICAM SIAPP SDK security vulnerabilities
Siemens SICAM SIAPP SDK is a software development kit from Siemens, Germany. A denial of service vulnerability exists in the Siemens SICAM SIAPP SDK, which can be exploited by an attacker to cause a stack overflow that can crash the process and lead to a denial of service...
Fortinet FortiWeb security vulnerability
Fortinet FortiWeb is a Web application layer firewall developed by the American company Fortinet. It can block threats such as cross-site scripting, SQL injection, cookie poisoning, and schema poisoning, ensuring the security of web applications and protecting sensitive database content. There is...
iccDEV security vulnerability
iccDEV is an open-source color configuration code library developed by the International Color Consortium. Versions of iccDEV prior to 2.3.1.5 contained security vulnerabilities. These vulnerabilities stemmed from a stack overflow vulnerability in the CIccBasicStructFactory::CreateStruct function...
iccDEV input validation error vulnerability
iccDEV is an open-source color configuration code library developed by the International Color Consortium. Versions of iccDEV prior to 2.3.1.5 contained a vulnerability related to input validation errors. This vulnerability stemmed from a stack overflow vulnerability in the...
iccDEV buffer error vulnerability
iccDEV is an open-source color configuration code library developed by the International Color Consortium. Versions of iccDEV prior to 2.3.1.5 contained a buffer error vulnerability. This vulnerability stemmed from a stack buffer overflow during the CIccXform3DLut::Apply function execution, which...
Huawei EulerOS: Security Advisory for libwebsockets (EulerOS-SA-2026-1287)
The remote host is missing an update for the Huawei EulerOS SPDX-FileCopyrightText: 2026 Greenbone AG Some text descriptions might be excerpted from a referenced sources, and are Copyright C by the respective right holders. SPDX-License-Identifier: GPL-2.0-only ifdescription...
ALSA-2026:4188 Moderate: gnutls security update
The gnutls packages provide the GNU Transport Layer Security GnuTLS library, which implements cryptographic algorithms and protocols such as SSL, TLS, and DTLS. Security Fixes: gnutls: Stack-based Buffer Overflow in gnutlspkcs11tokeninit Function CVE-2025-9820 gnutls: GnuTLS: Denial of Service vi...
CVE-2026-30980: Stack-based Buffer Overflow
iccDEV provides a set of libraries and tools for working with ICC color management profiles. Prior to 2.3.1.5, there is a stack overflow in CIccBasicStructFactory::CreateStruct causing uncontrolled recursion/stack exhaustion and crash. This vulnerability is fixed in 2.3.1.5...
CVE-2026-25572: Improper Handling of Length Parameter Inconsistency
A vulnerability has been identified in SICAM SIAPP SDK All versions V2.1.7. The SICAM SIAPP SDK server component does not enforce maximum length checks on certain variables before use. This could allow an attacker to send an oversized input that could trigger a stack overflow crashing the process...