1867 matches found
CVE-2026-85100
A vulnerability was detected in 2FastLabs agent-squad up to 1.1.4. Affected by this vulnerability is the function AgentSquad.routeRequest of the file agent-squad/typescript/src/orchestrator.ts of the component Streaming Agent Response Workflow. The manipulation results in resource consumption. It...
CVE-2026-85100 2FastLabs agent-squad Streaming Agent Response Workflow orchestrator.ts AgentSquad.routeRequest resource consumption
A vulnerability was detected in 2FastLabs agent-squad up to 1.1.4. Affected by this vulnerability is the function AgentSquad.routeRequest of the file agent-squad/typescript/src/orchestrator.ts of the component Streaming Agent Response Workflow. The manipulation results in resource consumption. It...
CVE-2026-85100 2FastLabs agent-squad Streaming Agent Response Workflow orchestrator.ts AgentSquad.routeRequest resource consumption
A vulnerability was detected in 2FastLabs agent-squad up to 1.1.4. Affected by this vulnerability is the function AgentSquad.routeRequest of the file agent-squad/typescript/src/orchestrator.ts of the component Streaming Agent Response Workflow. The manipulation results in resource consumption. It...
CVE-2026-85100 2FastLabs agent-squad Streaming Agent Response Workflow orchestrator.ts AgentSquad.routeRequest resource consumption
A vulnerability was detected in 2FastLabs agent-squad up to 1.1.4. Affected by this vulnerability is the function AgentSquad.routeRequest of the file agent-squad/typescript/src/orchestrator.ts of the component Streaming Agent Response Workflow. The manipulation results in resource consumption. It...
EUVD-2026-70370
A vulnerability was detected in 2FastLabs agent-squad up to 1.1.4. Affected by this vulnerability is the function AgentSquad.routeRequest of the file agent-squad/typescript/src/orchestrator.ts of the component Streaming Agent Response Workflow. The manipulation results in resource consumption. It...
CVE-2026-85100
A resource consumption vulnerability in 2FastLabs agent-squad (versions up to 1.1.4 ) affects the function AgentSquad.routeRequest within the Streaming Agent Response Workflow component (file agent-squad/typescript/src/orchestrator.ts). The flaw allows a remote attacker with low privileges to tri...
CVE-2026-85100: Uncontrolled Resource Consumption
A vulnerability was detected in 2FastLabs agent-squad up to 1.1.4. Affected by this vulnerability is the function AgentSquad.routeRequest of the file agent-squad/typescript/src/orchestrator.ts of the component Streaming Agent Response Workflow. The manipulation results in resource consumption. It...
PT-2026-84977
A vulnerability was detected in 2FastLabs agent-squad up to 1.1.4. Affected by this vulnerability is the function AgentSquad.routeRequest of the file agent-squad/typescript/src/orchestrator.ts of the component Streaming Agent Response Workflow. The manipulation results in resource consumption. It...
@meow-meow-dev/server-utilities (>=1.0.1, <=3.5.2), @nile-squad/nile (>=1.2.0, <=1.4.11) +2 more potentially affected by CVE-2026-81888 via @hono/oauth-providers (>=0.6.2, <=0.8.5)
@hono/oauth-providers NPM version =0.6.2, =1.0.1, =1.2.0, =0.1.0, =0.1.1, =0.9.1 Source cves: CVE-2026-81888 Source advisory: GHSA-FM3F-CH8H-QW8Q...
CVE-2026-19041 MissionSquad mcp-api NPM Package Version packages.ts this.packageService.installPackage command injection
A vulnerability has been found in MissionSquad mcp-api up to 1.11.8. The impacted element is the function this.packageService.installPackage of the file src/controllers/packages.ts of the component NPM Package Version Handler. The manipulation leads to command injection. It is possible to initiat...
CVE-2026-19041
The CVE-2026-19041 entry impacts MissionSquad mcp-api up to version 1.11.8. The vulnerability resides in the function this.packageService.installPackage within src/controllers/packages.ts (NPM Package Version Handler) and enables command injection. Exploit appears possible remotely, with a remedi...
CVE-2026-19041 MissionSquad mcp-api NPM Package Version packages.ts this.packageService.installPackage command injection
A vulnerability has been found in MissionSquad mcp-api up to 1.11.8. The impacted element is the function this.packageService.installPackage of the file src/controllers/packages.ts of the component NPM Package Version Handler. The manipulation leads to command injection. It is possible to initiat...
EUVD-2026-53927
A vulnerability has been found in MissionSquad mcp-api up to 1.11.8. The impacted element is the function this.packageService.installPackage of the file src/controllers/packages.ts of the component NPM Package Version Handler. The manipulation leads to command injection. It is possible to initiat...
CVE-2026-19040 MissionSquad mcp-api dcrClients.ts server-side request forgery
A flaw has been found in MissionSquad mcp-api up to 1.11.9. The affected element is an unknown function of the file src/services/dcrClients.ts. Executing a manipulation can lead to server-side request forgery. The attack may be performed from remote. Upgrading to version 1.11.10 is sufficient to...
CVE-2026-19040 MissionSquad mcp-api dcrClients.ts server-side request forgery
A flaw has been found in MissionSquad mcp-api up to 1.11.9. The affected element is an unknown function of the file src/services/dcrClients.ts. Executing a manipulation can lead to server-side request forgery. The attack may be performed from remote. Upgrading to version 1.11.10 is sufficient to...
CVE-2026-19040
MissionSquad mcp-api (versions
mcp-contract-builder (>=0.0.1, <=0.0.7), mcp-contract-executor (>=0.0.1, <=0.0.7) +2 more potentially affected by CVE-2025-64340 via fastmcp (0.3.5)
fastmcp PYPI version 0.3.5 is affected by a known vulnerability. The following packages have a transitive dependency on fastmcp and may be impacted: - mcp-contract-builder =0.0.1, =0.0.1, =0.1.48, =0.1.0, =0.1.3 Source cves: CVE-2025-64340 Source advisory: OSV:PYSEC-2026-2475...
mcp-contract-builder (>=0.0.1, <=0.0.7), mcp-contract-executor (>=0.0.1, <=0.0.7) +2 more potentially affected by CVE-2026-27124 via fastmcp (0.3.5)
fastmcp PYPI version 0.3.5 is affected by a known vulnerability. The following packages have a transitive dependency on fastmcp and may be impacted: - mcp-contract-builder =0.0.1, =0.0.1, =0.1.48, =0.1.0, =0.1.3 Source cves: CVE-2026-27124 Source advisory: OSV:PYSEC-2026-2476...
mcp-contract-builder (>=0.0.1, <=0.0.7), mcp-contract-executor (>=0.0.1, <=0.0.7) +2 more potentially affected by CVE-2025-69196 via fastmcp (0.3.5)
fastmcp PYPI version 0.3.5 is affected by a known vulnerability. The following packages have a transitive dependency on fastmcp and may be impacted: - mcp-contract-builder =0.0.1, =0.0.1, =0.1.48, =0.1.0, =0.1.3 Source cves: CVE-2025-69196 Source advisory: OSV:PYSEC-2026-2474...
mcp-contract-builder (>=0.0.1, <=0.0.7), mcp-contract-executor (>=0.0.1, <=0.0.7) +2 more potentially affected by CVE-2025-62800 via fastmcp (0.3.5)
fastmcp PYPI version 0.3.5 is affected by a known vulnerability. The following packages have a transitive dependency on fastmcp and may be impacted: - mcp-contract-builder =0.0.1, =0.0.1, =0.1.48, =0.1.0, =0.1.3 Source cves: CVE-2025-62800 Source advisory: OSV:PYSEC-2026-1364...