16936 matches found
PT-2025-22171
Name of the Vulnerable Software and Affected Versions Linux kernel affected versions not specified Description A memory leak issue has been identified in the Linux kernel when GSO is enabled. The issue occurs because the skb is mapped to the EXT descriptor instead of the LS descriptor when the...
PT-2025-18475
Name of the Vulnerable Software and Affected Versions Linux kernel versions prior to the fixed version Description A vulnerability in the Linux kernel has been resolved. The issue is related to the wifi mac80211 component, where the skb control block key could be removed before the ieee80211 tx...
Linux Kernel Security Vulnerabilities
Linux kernel is the kernel used by Linux, the open source operating system of the Linux Foundation in the United States. A security vulnerability exists in the Linux kernel that stems from an unreleased copy of the skb in the X25 protocol, which could lead to a memory leak...
PT-2025-22156
Name of the Vulnerable Software and Affected Versions Linux kernel affected versions not specified Description A vulnerability in the Linux kernel has been resolved. The issue arises when a pointer of type struct inet timewait sock is returned from the functions inet lookup established and inet6...
Linux Kernel Security Vulnerabilities
Linux kernel is the kernel used by Linux, the open source operating system of the Linux Foundation in the United States. A security vulnerability exists in Linux kernel that stems from insufficient boundary checking of skb data in net/ppp, which could lead to out-of-bounds access...
CVE-2025-30202 Data exposure via ZeroMQ on multi-node vLLM deployment
vLLM is a high-throughput and memory-efficient inference and serving engine for LLMs. Versions starting from 0.5.2 and prior to 0.8.5 are vulnerable to denial of service and data exposure via ZeroMQ on multi-node vLLM deployment. In a multi-node vLLM deployment, vLLM uses ZeroMQ for some multi-no...
CVE-2025-30202
vLLM is a high-throughput and memory-efficient inference and serving engine for LLMs. Versions starting from 0.5.2 and prior to 0.8.5 are vulnerable to denial of service and data exposure via ZeroMQ on multi-node vLLM deployment. In a multi-node vLLM deployment, vLLM uses ZeroMQ for some multi-no...
CVE-2025-30202: Allocation of Resources Without Limits or Throttling
vLLM is a high-throughput and memory-efficient inference and serving engine for LLMs. Versions starting from 0.5.2 and prior to 0.8.5 are vulnerable to denial of service and data exposure via ZeroMQ on multi-node vLLM deployment. In a multi-node vLLM deployment, vLLM uses ZeroMQ for some multi-no...
Data exposure via ZeroMQ on multi-node vLLM deployment
Impact In a multi-node vLLM deployment, vLLM uses ZeroMQ for some multi-node communication purposes. The primary vLLM host opens an XPUB ZeroMQ socket and binds it to ALL interfaces. While the socket is always opened for a multi-node deployment, it is only used when doing tensor parallelism acros...
GHSA-9F8F-2VMF-885J Data exposure via ZeroMQ on multi-node vLLM deployment
Impact In a multi-node vLLM deployment, vLLM uses ZeroMQ for some multi-node communication purposes. The primary vLLM host opens an XPUB ZeroMQ socket and binds it to ALL interfaces. While the socket is always opened for a multi-node deployment, it is only used when doing tensor parallelism acros...
Binding to an Unrestricted IP Address
Overview vllm is an A high-throughput and memory-efficient inference and serving engine for LLMs Affected versions of this package are vulnerable to Binding to an Unrestricted IP Address through the XPUB ZeroMQ socket. When connected, an attacker will receive internal vLLM state information data...
PT-2025-18215
Name of the Vulnerable Software and Affected Versions vLLM versions 0.5.2 through 0.8.5 Description The issue affects vLLM, a high-throughput and memory-efficient inference and serving engine for LLMs. In a multi-node vLLM deployment, vLLM uses ZeroMQ for some multi-node communication purposes,...
SUSE CVE-2017-9232
Juju before 1.25.12, 2.0.x before 2.0.4, and 2.1.x before 2.1.3 uses a UNIX domain socket without setting appropriate permissions, allowing privilege escalation by users on the system to root...
SUSE-SU-2025:20206-1 Security update for the Linux Kernel
The SUSE Linux Enterprise Micro 6.0 and 6.1 RT kernel was updated to receive various security bugfixes. The following security bugs were fixed: - CVE-2024-27415: netfilter: brnetfilter: skip conntrack input hook for promisc packets bsc1224757. - CVE-2024-50038: netfilter: xtables: fix typo causin...
[SECURITY] Fedora 42 Update: pgbouncer-1.24.1-2.fc42
pgbouncer is a lightweight connection pooler for PostgreSQL and uses libevent for low-level socket handling...
[SECURITY] Fedora 40 Update: pgbouncer-1.24.1-2.fc40
pgbouncer is a lightweight connection pooler for PostgreSQL and uses libevent for low-level socket handling...
[SECURITY] Fedora 41 Update: pgbouncer-1.24.1-2.fc41
pgbouncer is a lightweight connection pooler for PostgreSQL and uses libevent for low-level socket handling...
Missing Authorization
Overview Affected versions of this package are vulnerable to Missing Authorization due to improper permission settings on a UNIX domain socket. An attacker can gain unauthorized access or perform unauthorized actions by running juju-run 'whoami' which escalates privileges to root level. Remediati...
GO-2025-3639 Juju uses a UNIX domain socket without setting appropriate permissions in github.com/juju/juju
Juju uses a UNIX domain socket without setting appropriate permissions in github.com/juju/juju...
SUSE CVE-2020-36789
In the Linux kernel, the following vulnerability has been resolved: can: dev: cangetechoskb: prevent call to kfreeskb in hard IRQ context If a driver calls cangetechoskb during a hardware IRQ which is often, but not always, the case, the 'WARNONinirq' in net/core/skbuff.cskbreleaseheadstate might...