489 matches found
trailmark
Trailmark Trailmark parses source code into a graph of functions, types, calls, and other relationships, then lets you ask structural questions about it: Which entrypoints can reach this function, and along which call paths? What changed in the attack surface between two commits? Which functions...
ChameleonMini
ChameleonMini This is NOT the official repository of ChameleonMini, a freely programmable portable tool for NFC security analysis that can emulate and clone contactless cards, read RFID tags, and sniff/log RF data. This repository brings support for the Chameleon Tiny. Our Project is based on the...
call_map
========== Call Map .. default-role:: code About Call Map is a tool for navigating call graphs in Python, with plans to support other languages. Below is a screen shot after running callmap -m toolz, then clicking on some functions. .. figure:: docs/UI-clicked-on-function.png While Call Map is...
waf-bypass
WAF Bypass Tool WAF Bypass Tool is an open source tool to analyze the security of any WAF for False Positives and False Negatives using predefined and customizable payloads. Check your WAF before an attacker does. WAF Bypass Tool is developed by Nemesida WAF team with the participation of...
QuadraInspect
QuadraInspect / /\ \ / / / / / / / / / / / / / / / / // // / / / / / / / // / // / // / // / / / // // // / / // / / // / \\,/,/,// ,/// /// .//// // The security of mobile devices has become a critical concern due to the increasing amount of sensitive data being stored on them. With the...
CVE-2020-1054
CVE-2020-1054 analysis https://bbs.pediy.com/thread-260884.htm...
ADRecon
ADRecon: Active Directory Recon This repo contains updates to the original concept and code by Prashant Mahajan @prashant3535 while working at Sense of Security. ADRecon is a tool which extracts and combines various artefacts as highlighted below out of an AD environment. The information can be...
cloud
Cloud Monitoring the Cloud Landscape Our mission with this project is to provide an always up-to-date and freely accessible map of the cloud landscape for every major cloud service provider. We've decided to kick things off with collecting SSL certificate data of AWS EC2 and GCP machines,...
dockerscan
DockerScan v2.0 The Most Comprehensive Docker Security Scanner ByDaniel Garcia cr0hn | GitHub | Website Features • Installation • Quick Start • Documentation • Use Cases • What's New • Contributing 📑 Table of Contents Overview Features What's New in v2.0 Installation Quick Start Usage Private...
nuvola
nuvola nuvola with the lowercase n is a tool to dump and perform automatic and manual security analysis on AWS environments configurations and services using predefined, extensible and custom rules created using a simple Yaml syntax. The general idea behind this project is to create an abstracted...
threat-modeling-mcp-server
Threat Modeling MCP Server A Model Context Protocol MCP server for comprehensive threat modeling with guided code validation. Table of Contents Overview Quick Start Prompts Key Features Prerequisites Installation Running with Kiro CLI Output File Management Quick Reference Tools Overview Threat...
FileWatchTower
FileWatchTower - FWT NOTE: This project is no longer maintained and has been published from archived projects for reference. It is available for anyone interested in developing file analysis software. FWT is a security analysis and file monitoring tool that utilizes Sysmon events. It tracks files...
http-desync-guardian
Overview HTTP/1.1 went through a long evolution since 1991 to 2014: HTTP/0.9 – 1991 HTTP/1.0 – 1996 HTTP/1.1 RFC 2068 – 1997 RFC 2616 - 1999 RFC 7230 - 2014 This means there is a variety of servers and clients, which might have different views on request boundaries, creating opportunities for...
dc-sonar
DC Sonar Community Repositories The project consists of repositories: dc-sonar-frontend dc-sonar-user-layer dc-sonar-workers-layer ntlm-scrutinizer Disclaimer It's only for education purposes. Avoid using it on the production Active Directory AD domain. Neither contributor incur any responsibilit...
qiling
Qiling's use case, blog and related work Qiling is an advanced binary emulation framework, with the following features: Emulate multi-platforms: Windows, macOS, Linux, Android, BSD, UEFI, DOS, MBR. Emulate multi-architectures: 8086, X86, X8664, ARM, ARM64, MIPS, RISC-V, PowerPC. Support multiple...
ghidra-evm
Ghidra EVM Module In the last few years, attacks on deployed smart contracts in the Ethereum blockchain have ended up in a significant amount of stolen funds due to programming mistakes. Since smart contracts, once compiled and deployed, are complex to modify and update different practitioners ha...
skills
Trail of Bits Skills Marketplace Trail of Bits skills and plugins for AI-assisted security analysis, testing, and development. Install this marketplace in Claude Code or Codex, or import it into your ChatGPT workspace marketplace. Also see: claude-code-config · codex-config · skills-curated ·...
GhidrAssist
GhidrAssist Author: Jason Tang An advanced LLM-powered plugin for interactive reverse engineering assistance in Ghidra. Description GhidrAssist integrates Large Language Models LLMs into Ghidra to provide intelligent assistance for binary exploration and reverse engineering. It supports any OpenA...
TEE-reversing
TEE Basics & General Introduction to Trusted Execution Environment: ARM's TrustZone https://blog.quarkslab.com/introduction-to-trusted-execution-environment-arms-trustzone.html Introduction to TEE original title: TEEを中心とするCPUセキュリティ機能の動向...
Codeguard-copilot
CodeGuard Copilot — Intelligent Security Ecosystem Your AI-Powered Security Guardian — Now Connected to Live Attacker Intelligence Features • Architecture • Raven Integration • Installation • Roadmap • Contributing What is CodeGuard Copilot? CodeGuard Copilot catches security vulnerabilities as y...