124548 matches found
Unsafe Dependency Resolution
Overview org.jenkins-ci.plugins:script-security is a package that allows Jenkins administrators to control what in-process scripts can be run by less-privileged users. Affected versions of this package are vulnerable to Unsafe Dependency Resolution via Groovy AST transformation annotations during...
io.jenkins.plugins:createos-sandbox (24.vfe318c36a_db_8), io.jenkins.plugins:gitea-checks (606.679.vb_d632867a_6b_b) +10 more potentially affected by CVE-2026-57280 via org.jenkins-ci.plugins:script-security (1402.v94c9ce464861)
org.jenkins-ci.plugins:script-security MAVEN version 1402.v94c9ce464861 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.plugins:script-security and may be impacted: - io.jenkins.plugins:createos-sandbox 24.vfe318c36adb8 -...
Improper Control of Dynamically-Managed Code Resources
Overview org.jenkins-ci.plugins:script-security is a package that allows Jenkins administrators to control what in-process scripts can be run by less-privileged users. Affected versions of this package are vulnerable to Improper Control of Dynamically-Managed Code Resources via incomplete sandbox...
Malicious code in polymarket-stake-maths (npm)
--- -= Per source details. Do not edit below this line.=- Source: amazon-inspector 657363aaa0b94385d30a26c1f4ee67923b0d877975850ad08f8364c2a901d8e7 On npm install, the package's postinstall script scripts/install-check.cjs fetches a JSON config from...
PT-2026-52463
A Joomla user with K2 "create item" rights Author tier by default can submit an article whose embedVideo POST field contains a raw tag; K2 stores it verbatim and renders it unescaped to any visitor of the article page...
CVE-2026-7569
Quest NetVault Backup viewclient Cross-Site Scripting Authentication Bypass Vulnerability. This vulnerability allows remote attackers to bypass authentication on affected installations of Quest NetVault Backup. User interaction is required to exploit this vulnerability in that the target must vis...
CVE-2026-7569 Quest NetVault Backup viewclient Cross-Site Scripting Authentication Bypass Vulnerability
Quest NetVault Backup viewclient Cross-Site Scripting Authentication Bypass Vulnerability. This vulnerability allows remote attackers to bypass authentication on affected installations of Quest NetVault Backup. User interaction is required to exploit this vulnerability in that the target must vis...
CVE-2026-7569 Quest NetVault Backup viewclient Cross-Site Scripting Authentication Bypass Vulnerability
Quest NetVault Backup viewclient Cross-Site Scripting Authentication Bypass Vulnerability. This vulnerability allows remote attackers to bypass authentication on affected installations of Quest NetVault Backup. User interaction is required to exploit this vulnerability in that the target must vis...
CVE-2026-39900 Cacti: Reflected XSS via tab parameter in auth_profile.php JavaScript context
Cacti is an open source performance and fault management framework. Versions 1.2.30 and prior are vulnerable to Reflected XSS via tab parameter in the authprofile.php JavaScript context. This issue has been fixed in version 1.2.31...
CVE-2026-39897
Cacti is an open source performance and fault management framework. Versions 1.2.30 and below contain a Reflected XSS vulnerability in the htmlauthfooter. This issue has been fixed in version 1.2.31...
CVE-2026-55570 SiYuan: Stored XSS results to Electron RCE in SiYuan marketplace via unescaped `data-obj` attribute (Bypass for CVE-2026-45375's patch)
SiYuan is an open-source personal knowledge management system. Prior to 3.7.0, it does not escape the untrusted fields name, version, author, description when they are serialized into the data-obj HTML attribute of each marketplace card. Because the attribute is single-quoted and the value is...
GHSA-MPFF-XHG4-VR45 Jenkins MCP Server Plugin missing a permission check
Jenkins MCP Server Plugin 0.177.v629fdb2557fe and earlier does not perform a permission check in the getReplayScripts MCP tool that returns the replay script of a Pipeline build. This allows attackers with Item/Read permission to obtain the Pipeline script of jobs. MCP Server Plugin...
Jenkins MCP Server Plugin missing a permission check
Jenkins MCP Server Plugin 0.177.v629fdb2557fe and earlier does not perform a permission check in the getReplayScripts MCP tool that returns the replay script of a Pipeline build. This allows attackers with Item/Read permission to obtain the Pipeline script of jobs. MCP Server Plugin...
Jenkins Script Security Plugin sandbox bypass vulnerability
Jenkins Script Security Plugin provides a sandbox feature that allows running user-provided scripts safely by intercepting and checking potentially unsafe operations. Script Security Plugin 1402.v94c9ce464861 and earlier does not intercept the implicit type cast applied to each element of the...
GHSA-72C8-3WWG-R59W Jenkins Pipeline: Groovy Plugin has a CSRF vulnerability
Jenkins Pipeline: Groovy Plugin 4331.v9d06ed4658ff and earlier does not restrict the types that can be instantiated through the Pipeline Snippet Generator, instantiating any type with a constructor annotated with @DataBoundConstructor in response to a request. This allows attackers to have...
GHSA-WP5X-HRRW-6R4G Jenkins Git client Plugin has an OS command injection vulnerability on agents
Jenkins Git client Plugin 6.6.0 and earlier does not correctly escape the workspace directory name when it is embedded into the SSH wrapper script generated by the "Manually provided keys" Git Host Key Verification strategy on Unix agents. This allows attackers able to control the name of a build...
org.jenkins-ci.plugins.workflow:workflow-basic-steps (>=1017.vb_45b_302f0cea, <=1058.vcb_fc1e3a_21a_9), org.jenkins-ci.plugins.workflow:workflow-durable-task-step (>=1246.v5524618ea_097, <=1247.v7f9dfea_b_4fd0) potentially affected by CVE-2026-57281 via org.jenkins-ci.plugins:script-security (1189.vb_a_b_7c8fd5fde)
org.jenkins-ci.plugins:script-security MAVEN version 1189.vbab7c8fd5fde is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.plugins:script-security and may be impacted: - org.jenkins-ci.plugins.workflow:workflow-basic-steps...
org.jenkins-ci.plugins:embeddable-build-status (>=2.0-beta1, <=2.0.4) potentially affected by CVE-2026-57280 via org.jenkins-ci.plugins:script-security (1.49)
org.jenkins-ci.plugins:script-security MAVEN version 1.49 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.plugins:script-security and may be impacted: - org.jenkins-ci.plugins:embeddable-build-status =2.0-beta1, =2.0.4 Source cves:...
com.openshift.jenkins.plugins:openshift-client (1.1.0.424.v829cb_ccf8798), io.jenkins.plugins:openshift-k8s-credentials (>=168.v79a_983191991, <=276.v708b_2cd34a_9e) +7 more potentially affected by CVE-2026-57280 via org.jenkins-ci.plugins:script-security (1313.v7a_6067dc7087)
org.jenkins-ci.plugins:script-security MAVEN version 1313.v7a6067dc7087 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.plugins:script-security and may be impacted: - com.openshift.jenkins.plugins:openshift-client 1.1.0.424.v829cbccf8798...
com.logmein:pipeline-bamboo (>=0.0.1, <=0.0.2), de.taimos:pipeline-aws (>=1.0, <=1.20) +22 more potentially affected by CVE-2026-57280 via org.jenkins-ci.plugins:script-security (1.24)
org.jenkins-ci.plugins:script-security MAVEN version 1.24 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.plugins:script-security and may be impacted: - com.logmein:pipeline-bamboo =0.0.1, =1.0, =y, =1.0.0-b22, =1.0.0-b22, =1.0.0-b22,...