Lucene search
+L

19605 matches found

Hacker One
Hacker One
•added 2023/06/04 8:02 a.m.•62 views

Internet Bug Bounty: [CVE-2023-22799] Possible ReDoS based DoS vulnerability in GlobalID

A ReDoS-based DoS vulnerability was discovered in the GlobalID gem, affecting versions 0.2.1 and above. Crafted input could cause the regular expression engine to consume excessive processing time, leading to a denial of service. The issue has been fixed in version 1.0.1...

7.5CVSS6.5AI score0.01049EPSS
SaveExploits0
Hacker One
Hacker One
•added 2023/06/04 7:16 a.m.•52 views

Internet Bug Bounty: [CVE-2022-44571] Possible Denial of Service Vulnerability in Rack Content-Disposition parsing

A denial of service vulnerability was discovered in the Content-Disposition parsing component of Rack. This vulnerability could be exploited by carefully crafted input to cause the parsing process to consume an unexpected amount of time, potentially leading to a denial of service attack. The...

7.5CVSS6.5AI score0.01503EPSS
SaveExploits0
Hacker One
Hacker One
•added 2023/06/04 7:06 a.m.•54 views

Internet Bug Bounty: [CVE-2022-44570] Possible Denial of Service Vulnerability in Rack’s Range header parsing

A denial of service vulnerability was discovered in the Range header parsing component of Rack. This vulnerability could be exploited by sending carefully crafted input to the Range header, causing the parsing component to consume an unexpected amount of time and potentially leading to a denial o...

7.5CVSS6.4AI score0.01626EPSS
SaveExploits0
Veracode
Veracode
•added 2023/05/30 1:14 p.m.•32 views

Arbitrary Code Execution

ruby-saml is vulnerable to Arbitrary Code Execution. The vulnerability exists due to a lack of using prepared statements in xmlsecurity.rb which allow an attacker to execute arbitrary codes into the system...

9.8CVSS8.7AI score0.01332EPSS
SaveExploits0References5Affected Software1
CNVD
CNVD
•added 2023/05/29 12:00 a.m.•129 views

Directory Traversal Vulnerability in GitLab CE/EE

GitLab is an open source application developed using Ruby on Rails that implements a self-hosted Git project repository that can be accessed through a web interface for public and private projects.GitLab EE is the GitLab Enterprise Edition and GitLab CE is the GitLab Community Edition. GitLab CE/...

5CVSS8.2AI score0.71641EPSS
SaveExploits5Affected Software1
Tenable Nessus
Tenable Nessus
•added 2023/05/29 12:00 a.m.•38 views

Oracle Linux 8 : pcs (ELSA-2023-3082)

The remote Oracle Linux 8 host has packages installed that are affected by multiple vulnerabilities as referenced in the ELSA-2023-3082 advisory. 0.10.15-4.0.1.el88.1 - Replace HAM-logo.png with a generic one 0.10.15-4.el88.1 - Fix displaying differences between configuration checkpoints in pcs...

7.5CVSS6.9AI score0.0183EPSS
SaveExploits0References3
osv_ghsa
osv_ghsa
•added 2023/05/27 9:30 p.m.•54 views

GHSA-R364-2PJ4-PF7F ruby-saml vulnerable to XPath injection

xmlsecurity.rb in the ruby-saml gem before 1.0.0 for Ruby allows XPath injection and code execution because prepared statements are not used...

9.8CVSS8.5AI score0.01332EPSS
SaveExploits0References9
Github Security Blog
Github Security Blog
•added 2023/05/27 9:30 p.m.•56 views

ruby-saml vulnerable to XPath injection

xmlsecurity.rb in the ruby-saml gem before 1.0.0 for Ruby allows XPath injection and code execution because prepared statements are not used...

9.8CVSS8.5AI score0.01332EPSS
SaveExploits0References9Affected Software1
NVD
NVD
•added 2023/05/27 7:15 p.m.•63 views

CVE-2015-20108

xmlsecurity.rb in the ruby-saml gem before 1.0.0 for Ruby allows XPath injection and code execution because prepared statements are not used...

9.8CVSS9.9AI score0.01332EPSS
SaveExploits0References5
osv_debian
osv_debian
•added 2023/05/27 7:15 p.m.•35 views

DEBIAN-CVE-2015-20108

xmlsecurity.rb in the ruby-saml gem before 1.0.0 for Ruby allows XPath injection and code execution because prepared statements are not used...

9.8CVSS8.5AI score0.01332EPSS
SaveExploits0References1
osv_cve
osv_cve
•added 2023/05/27 7:15 p.m.•28 views

CVE-2015-20108

xmlsecurity.rb in the ruby-saml gem before 1.0.0 for Ruby allows XPath injection and code execution because prepared statements are not used...

9.8CVSS8.5AI score0.01332EPSS
SaveExploits0References5
UbuntuCve
UbuntuCve
•added 2023/05/27 7:15 p.m.•23 views

CVE-2015-20108

xmlsecurity.rb in the ruby-saml gem before 1.0.0 for Ruby allows XPath injection and code execution because prepared statements are not used...

9.8CVSS8.5AI score0.01332EPSS
SaveExploits0References6
osv_ubuntu
osv_ubuntu
•added 2023/05/27 7:15 p.m.•62 views

UBUNTU-CVE-2015-20108

xmlsecurity.rb in the ruby-saml gem before 1.0.0 for Ruby allows XPath injection and code execution because prepared statements are not used...

9.8CVSS8.5AI score0.01332EPSS
SaveExploits0References6
Mend
Mend
•added 2023/05/27 12:00 a.m.•14 views

CVE-2015-20108

xmlsecurity.rb in the ruby-saml gem before 1.0.0 for Ruby allows XPath injection and code execution because prepared statements are not used...

9.8CVSS8.5AI score0.01332EPSS
SaveExploits0References9
Vulnrichment
Vulnrichment
•added 2023/05/27 12:00 a.m.•27 views

CVE-2015-20108

xmlsecurity.rb in the ruby-saml gem before 1.0.0 for Ruby allows XPath injection and code execution because prepared statements are not used...

8.5AI score0.01332EPSS
SaveExploits0References5
CVE
CVE
•added 2023/05/27 12:00 a.m.•106 views

CVE-2015-20108

The CVE-2015-20108 issue affects the ruby-saml gem prior to 1.0.0, where xml_security.rb enables XPath injection and code execution because prepared statements are not used. Affected component: ruby-saml XML security handling. Root cause: lack of prepared statements in XPath processing leads to i...

9.8CVSS8.5AI score0.01332EPSS
SaveExploits0References5Affected Software1
Debian CVE
Debian CVE
•added 2023/05/27 12:00 a.m.•71 views

CVE-2015-20108

xmlsecurity.rb in the ruby-saml gem before 1.0.0 for Ruby allows XPath injection and code execution because prepared statements are not used...

9.8CVSS8.5AI score0.01332EPSS
SaveExploits0
Rapid7 Vulnerability Database (full)
Rapid7 Vulnerability Database (full)
•added 2023/05/27 12:00 a.m.•5 views

CVE-2015-20108: Improper Neutralization of Special Elements used in a Command

xmlsecurity.rb in the ruby-saml gem before 1.0.0 for Ruby allows XPath injection and code execution because prepared statements are not used...

9.8CVSS8.7AI score0.01332EPSS
SaveExploits0References3
Positive Technologies
Positive Technologies
•added 2023/05/27 12:00 a.m.•16 views

PT-2023-10309 · Ruby · Ruby-Saml

Name of the Vulnerable Software and Affected Versions: ruby-saml gem versions prior to 1.0.0 Description: The issue allows XPath injection and code execution in the ruby-saml gem because prepared statements are not used. This is related to the xml security.rb file. Recommendations: For versions...

9.8CVSS8.5AI score0.01332EPSS
SaveExploits0References18
CNNVD
CNNVD
•added 2023/05/27 12:00 a.m.•26 views

OneLogin ruby-saml command injection vulnerability

Onelogin OneLogin ruby-saml is a Ruby-based SAML Security Assertion Markup Language library for Single Sign-On SSO services from Onelogin, USA. A security vulnerability exists in OneLogin ruby-saml prior to version 1.0.0, which stems from not using pre-defined statements, causing xmlsecurity.rb i...

9.8CVSS8.8AI score0.01332EPSS
SaveExploits0References6
Rows per page
Query Builder