19605 matches found
ruby: Arbitrary memory address read vulnerability with Regex search
A flaw was found in Ruby. If attacker-supplied data is provided to the Ruby regex compiler, it is possible to extract arbitrary heap data relative to the start of the text, including pointers and sensitive strings...
REXML: DoS parsing an XML with many `<`s in an attribute value
REXML is an XML toolkit for Ruby. The REXML gem before 3.2.6 has a denial of service vulnerability when it parses an XML that has many s in an attribute value. Those who need to parse untrusted XMLs may be impacted to this vulnerability. The REXML gem 3.2.7 or later include the patch to fix this...
Moderate: Red Hat Security Advisory: ruby security update
An update for ruby is now available for Red Hat Enterprise Linux 8. Red Hat Product Security has rated this update as having a security impact of Moderate. A Common Vulnerability Scoring System CVSS base score, which gives a detailed severity rating, is available for each vulnerability from the C...
Ruby Programming Language Installed (Linux)
Binary data rubynixinstalled.nbin...
RHEL 8 : ruby (RHSA-2024:4499)
The remote Redhat Enterprise Linux 8 host has packages installed that are affected by multiple vulnerabilities as referenced in the RHSA-2024:4499 advisory. Ruby is an extensible, interpreted, object-oriented, scripting language. It has features to process text files and to perform system...
ALSA-2024:4499 Moderate: ruby security update
Ruby is an extensible, interpreted, object-oriented, scripting language. It has features to process text files and to perform system management tasks. Security Fixes: rubygem-uri: ReDoS vulnerability - upstream's incomplete fix for CVE-2023-28755 CVE-2023-36617 ruby: Buffer overread vulnerability...
Moderate: ruby security update
Ruby is an extensible, interpreted, object-oriented, scripting language. It has features to process text files and to perform system management tasks. Security Fixes: rubygem-uri: ReDoS vulnerability - upstream's incomplete fix for CVE-2023-28755 CVE-2023-36617 ruby: Buffer overread vulnerability...
CVE-2024-27090
Decidim is a participatory democracy framework, written in Ruby on Rails, originally developed for the Barcelona City government online and offline participation website. If an attacker can infer the slug or URL of an unpublished or private resource, and this resource can be embbeded such as a...
CVE-2024-27090 Decidim vulnerable to data disclosure through the embed feature
Decidim is a participatory democracy framework, written in Ruby on Rails, originally developed for the Barcelona City government online and offline participation website. If an attacker can infer the slug or URL of an unpublished or private resource, and this resource can be embbeded such as a...
CVE-2024-27090 Decidim vulnerable to data disclosure through the embed feature
Decidim is a participatory democracy framework, written in Ruby on Rails, originally developed for the Barcelona City government online and offline participation website. If an attacker can infer the slug or URL of an unpublished or private resource, and this resource can be embbeded such as a...
CVE-2024-27090: Exposure of Sensitive Information to an Unauthorized Actor
Decidim is a participatory democracy framework, written in Ruby on Rails, originally developed for the Barcelona City government online and offline participation website. If an attacker can infer the slug or URL of an unpublished or private resource, and this resource can be embbeded such as a...
Decidim security breach
Decidim is a participatory democracy framework, written in Ruby on Rails. A security vulnerability exists in versions of Decidim prior to 0.27.6, which stems from the ability to access certain data from an unpublished or private resource if an attacker can infer the slug or URL of that resource...
RailsAdmin Cross-site Scripting vulnerability in the list view
Impact RailsAdmin list view has the XSS vulnerability, caused by improperly-escaped HTML title attribute. The issue was originally reported in https://github.com/railsadminteam/railsadmin/issues/3686. Patches Upgrade to 3.1.4. The vulnerability itself was patched in 3.1.3 but it has a functionali...
RailsAdmin Cross-site Scripting vulnerability in the list view
Impact RailsAdmin list view has the XSS vulnerability, caused by improperly-escaped HTML title attribute. The issue was originally reported in https://github.com/railsadminteam/railsadmin/issues/3686. Patches Upgrade to 3.1.3 or 2.3.0. Workarounds 1. Copy the index view located under the path...
CVE-2024-37260
Server-Side Request Forgery SSRF vulnerability in Theme-Ruby Foxiz.This issue affects Foxiz: from n/a through 2.3.5...
CVE-2024-37260
Server-Side Request Forgery SSRF vulnerability in Theme-Ruby Foxiz.This issue affects Foxiz: from n/a through 2.3.5...
CVE-2024-37260
CVE-2024-37260 is a Server-Side Request Forgery (SSRF) vulnerability affecting WordPress Foxiz Theme (Foxiz) versions up to 2.3.5. Public sources (NVD, CVE listings) confirm the issue and its high/critical impact metrics (CVSS v3.1: 9.3 base score; network attack, no user interaction). The Wordfe...
PT-2024-27425 · Foxiz · Foxiz
Name of the Vulnerable Software and Affected Versions: Foxiz versions 2.3.5 and earlier Description: A Server-Side Request Forgery SSRF vulnerability has been identified in Theme-Ruby Foxiz. This issue allows for unauthorized access to internal resources, potentially leading to sensitive data...
CVE-2024-37260: Server-Side Request Forgery (SSRF)
Server-Side Request Forgery SSRF vulnerability in Theme-Ruby Foxiz.This issue affects Foxiz: from n/a through 2.3.5...
CBL Mariner 2.0 Security Update: ruby / rubygem-rexml (CVE-2024-35176)
The version of ruby / rubygem-rexml installed on the remote CBL Mariner 2.0 host is prior to tested version. It is, therefore, affected by a vulnerability as referenced in the CVE-2024-35176 advisory. - REXML is an XML toolkit for Ruby. The REXML gem before 3.2.6 has a denial of service...