Lucene search
+L

19605 matches found

Tenable Nessus
Tenable Nessus
•added 2024/12/23 12:00 a.m.•22 views

Amazon Linux 2 : ruby (ALAS-2024-2706)

The version of ruby installed on the remote host is prior to 2.0.0.648-36. It is, therefore, affected by a vulnerability as referenced in the ALAS2-2024-2706 advisory. An issue was discovered in the WEBrick toolkit through 1.8.1 for Ruby. It allows HTTP request smuggling by providing both a...

6.8AI score0.00393EPSS
SaveExploits0References4
Photon
Photon
•added 2024/12/23 12:00 a.m.•26 views

Important Photon OS Security Update - PHSA-2024-5.0-91-0432

Updates of 'rubygem-nokogiri' packages of Photon OS have been released...

7.5CVSS7.9AI score0.01823EPSS
SaveExploits0
osv_bit
osv_bit
•added 2024/12/20 9:50 a.m.•145 views

BIT-RAILS-2024-26142 Rails possible ReDoS vulnerability in Accept header parsing in Action Dispatch

Rails is a web-application framework. Starting in version 7.1.0, there is a possible ReDoS vulnerability in the Accept header parsing routines of Action Dispatch. This vulnerability is patched in 7.1.3.1. Ruby 3.2 has mitigations for this problem, so Rails applications using Ruby 3.2 or newer are...

7.5CVSS6.3AI score0.01498EPSS
SaveExploits0References6
Microsoft CVE
Microsoft CVE
•added 2024/12/19 8:00 a.m.•19 views

REXML denial of service vulnerability

...

5.9CVSS6.3AI score0.01205EPSS
SaveExploits0
osv_rlsa
osv_rlsa
•added 2024/12/19 4:19 a.m.•41 views

RLSA-2024:10860 Important: ruby:3.1 security update

Ruby is an extensible, interpreted, object-oriented, scripting language. It has features to process text files and to perform system management tasks. Security Fixes: rexml: REXML ReDoS vulnerability CVE-2024-49761 For more details about the security issues, including the impact, a CVSS score,...

7.5CVSS6.7AI score0.0142EPSS
SaveExploits0References2
Rockylinux
Rockylinux
•added 2024/12/19 4:19 a.m.•35 views

ruby:3.1 security update

An update is available for rubygem-pg, module.rubygem-mysql2, rubygem-mysql2, module.rubygem-pg. This update affects Rocky Linux 9. A Common Vulnerability Scoring System CVSS base score, which gives a detailed severity rating, is available for each vulnerability from the CVE list Ruby is an...

8.7CVSS6.6AI score0.0142EPSS
SaveExploits0
osv_rlsa
osv_rlsa
•added 2024/12/19 4:18 a.m.•36 views

RLSA-2024:10834 Important: ruby:3.1 security update

Ruby is an extensible, interpreted, object-oriented, scripting language. It has features to process text files and to perform system management tasks. Security Fixes: rexml: REXML ReDoS vulnerability CVE-2024-49761 For more details about the security issues, including the impact, a CVSS score,...

8.7CVSS6.7AI score0.0142EPSS
SaveExploits0References2
osv_rlsa
osv_rlsa
•added 2024/12/19 4:18 a.m.•41 views

RLSA-2024:10850 Important: ruby:2.5 security update

Ruby is an extensible, interpreted, object-oriented, scripting language. It has features to process text files and to perform system management tasks. Security Fixes: rexml: REXML ReDoS vulnerability CVE-2024-49761 For more details about the security issues, including the impact, a CVSS score,...

8.7CVSS6.7AI score0.0142EPSS
SaveExploits0References2
Rockylinux
Rockylinux
•added 2024/12/19 4:18 a.m.•51 views

ruby:2.5 security update

An update is available for ruby, rubygem-bson, module.rubygem-bson, rubygem-bundler, rubygem-abrt, module.rubygem-pg, rubygem-mysql2, module.ruby, rubygem-mongo, module.rubygem-bundler, rubygem-pg, module.rubygem-mongo, module.rubygem-abrt, module.rubygem-mysql2. This update affects Rocky Linux 8...

8.7CVSS6.6AI score0.0142EPSS
SaveExploits0
Rockylinux
Rockylinux
•added 2024/12/19 4:18 a.m.•29 views

ruby:3.1 security update

An update is available for ruby, rubygem-abrt, module.rubygem-pg, rubygem-mysql2, module.ruby, rubygem-pg, module.rubygem-abrt, module.rubygem-mysql2. This update affects Rocky Linux 8. A Common Vulnerability Scoring System CVSS base score, which gives a detailed severity rating, is available for...

8.7CVSS6.6AI score0.0142EPSS
SaveExploits0
Tenable Nessus
Tenable Nessus
•added 2024/12/19 12:00 a.m.•21 views

RockyLinux 9 : ruby:3.1 (RLSA-2024:10860)

The remote RockyLinux 9 host has packages installed that are affected by a vulnerability as referenced in the RLSA-2024:10860 advisory. rexml: REXML ReDoS vulnerability CVE-2024-49761 Tenable has extracted the preceding description block directly from the RockyLinux security advisory. Note that...

8.7CVSS7AI score0.0142EPSS
SaveExploits0References3
Amazon
Amazon
•added 2024/12/19 12:00 a.m.•23 views

Important: ruby

Issue Overview: An issue was discovered in the WEBrick toolkit through 1.8.1 for Ruby. It allows HTTP request smuggling by providing both a Content-Length header and a Transfer-Encoding header, e.g., "GET /admin HTTP/1.1\r\n" inside of a "POST /user HTTP/1.1\r\n" request. NOTE: the supplier's...

6.9AI score0.00393EPSS
SaveExploits0
Amazon
Amazon
•added 2024/12/19 12:00 a.m.•14 views

Important: ruby

Issue Overview: An issue was discovered in the WEBrick toolkit through 1.8.1 for Ruby. It allows HTTP request smuggling by providing both a Content-Length header and a Transfer-Encoding header, e.g., "GET /admin HTTP/1.1\r\n" inside of a "POST /user HTTP/1.1\r\n" request. NOTE: the supplier's...

6.9AI score0.00393EPSS
SaveExploits0
Tenable Nessus
Tenable Nessus
•added 2024/12/19 12:00 a.m.•21 views

RockyLinux 8 : ruby:2.5 (RLSA-2024:10850)

The remote RockyLinux 8 host has packages installed that are affected by a vulnerability as referenced in the RLSA-2024:10850 advisory. rexml: REXML ReDoS vulnerability CVE-2024-49761 Tenable has extracted the preceding description block directly from the RockyLinux security advisory. Note that...

8.7CVSS7AI score0.0142EPSS
SaveExploits0References3
Hacker One
Hacker One
•added 2024/12/18 3:20 a.m.•474 views

Internet Bug Bounty: [CVE-2024-54133] Possible Content Security Policy bypass in Action Dispatch

A vulnerability was discovered in the contentsecuritypolicy helper in Action Pack of Ruby on Rails. Carefully crafted inputs were able to inject new directives into the Content-Security-Policy CSP header, potentially leading to a bypass of the CSP and its protection against cross-site scripting X...

2.3CVSS5.4AI score0.01002EPSS
SaveExploits0
CBLMariner
CBLMariner
•added 2024/12/17 11:15 p.m.•23 views

CVE-2024-49761 affecting package ruby for versions less than 3.3.5-1

CVE-2024-49761 affecting package ruby for versions less than 3.3.5-1. A patched version of the package is available...

8.7CVSS6.8AI score0.0142EPSS
SaveExploits0
CBLMariner
CBLMariner
•added 2024/12/17 11:15 p.m.•17 views

CVE-2024-43398 affecting package ruby for versions less than 3.3.5-1

CVE-2024-43398 affecting package ruby for versions less than 3.3.5-1. An upgraded version of the package is available that resolves this issue...

5.9CVSS6.1AI score0.01205EPSS
SaveExploits0
CBLMariner
CBLMariner
•added 2024/12/17 11:15 p.m.•26 views

CVE-2024-39908 affecting package ruby for versions less than 3.3.5-1

CVE-2024-39908 affecting package ruby for versions less than 3.3.5-1. An upgraded version of the package is available that resolves this issue...

4.3CVSS6AI score0.01493EPSS
SaveExploits0
Wolfi
Wolfi
•added 2024/12/17 9:30 p.m.•10 views

GHSA-5MPW-4546-2WCR vulnerabilities

Vulnerabilities for packages: ruby3.2-elasticsearch, ruby3.3-elasticsearch...

5.9AI score
SaveExploits0
Chainguard
Chainguard
•added 2024/12/17 9:30 p.m.•22 views

GHSA-5MPW-4546-2WCR vulnerabilities

Vulnerabilities for packages: ruby3.2-elasticsearch, ruby3.3-elasticsearch...

5.9AI score
SaveExploits0
Rows per page
Query Builder