19580 matches found
RHSA-2025:23140 Red Hat Security Advisory: ruby:3.3 security update
Bulletin has no description...
Oracle Linux 10 : ruby (ELSA-2025-23141)
The remote Oracle Linux 10 host has packages installed that are affected by multiple vulnerabilities as referenced in the ELSA-2025-23141 advisory. - Fix possible denial of service in resolv gem CVE-2025-24294 - Fix URI Credential Leakage Bypass previous fixes. CVE-2025-61594 Tenable has extracte...
Oracle Linux 9 : ruby:3.3 (ELSA-2025-23063)
The remote Oracle Linux 9 host has packages installed that are affected by multiple vulnerabilities as referenced in the ELSA-2025-23063 advisory. - Fix possible denial of service in resolv gem CVE-2025-24294 - Fix URI Credential Leakage Bypass previous fixes. CVE-2025-61594 Tenable has extracted...
Moderate: Red Hat Security Advisory: ruby security update
An update for ruby is now available for Red Hat Enterprise Linux 10. Red Hat Product Security has rated this update as having a security impact of Moderate. A Common Vulnerability Scoring System CVSS base score, which gives a detailed severity rating, is available for each vulnerability from the...
resolv: Denial of Service in resolv gem
A denial of service flaw was found in resolv ruby gem. This flaw allows an attacker to craft a malicious DNS packet containing a highly compressed domain name. When the resolv library parses this packet, the name decompression process consumes a large amount of CPU resources, as the library does...
rexml: REXML denial of service
A denial of service flaw has been discovered in the rubygem REXML. Certain input can cause excess cpu usage and given sufficiently large input this can affect program performance...
Moderate: Red Hat Security Advisory: ruby:3.3 security update
An update for the ruby:3.3 module is now available for Red Hat Enterprise Linux 9.4 Extended Update Support. Red Hat Product Security has rated this update as having a security impact of Moderate. A Common Vulnerability Scoring System CVSS base score, which gives a detailed severity rating, is...
ruby:3.3 security update
ruby 3.3.10-5 - Upgrade to Ruby 3.3.10. Resolves: RHEL-106820 - Fix possible denial of service in resolv gem CVE-2025-24294 - Fix URI Credential Leakage Bypass previous fixes. CVE-2025-61594 - Fix REXML denial of service. CVE-2025-58767 Resolves: RHEL-122012 rubygem-abrt rubygem-mysql2 rubygem-pg...
ruby:3.3 security update
ruby 3.3.10-5 - Upgrade to Ruby 3.3.10. Resolves: RHEL-127912 - Fix possible denial of service in resolv gem CVE-2025-24294 - Fix URI Credential Leakage Bypass previous fixes. CVE-2025-61594 - Fix REXML denial of service. CVE-2025-58767 Resolves: RHEL-122015 rubygem-mysql2 rubygem-pg...
Linux Distros Unpatched Vulnerability : CVE-2025-66568
The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - The ruby-saml library implements the client side of an SAML authorization. Versions up to and including 1.12.4, are vulnerable to authentication bypass through...
Oracle Linux 8 : ruby:3.3 (ELSA-2025-23062)
The remote Oracle Linux 8 host has packages installed that are affected by multiple vulnerabilities as referenced in the ELSA-2025-23062 advisory. - Fix possible denial of service in resolv gem CVE-2025-24294 - Fix URI Credential Leakage Bypass previous fixes. CVE-2025-61594 Tenable has extracted...
ruby security update
3.3.10-11 - Upgrade to Ruby 3.3.10. Resolves: RHEL-130160 - Fix possible denial of service in resolv gem CVE-2025-24294 - Fix URI Credential Leakage Bypass previous fixes. CVE-2025-61594 - Fix REXML denial of service. CVE-2025-58767 Resolves: RHEL-122028...
Linux Distros Unpatched Vulnerability : CVE-2025-66567
The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - The ruby-saml library is for implementing the client side of a SAML authorization. ruby-saml versions up to and including 1.12.4 contain an authentication bypas...
RHEL 9 : ruby:3.3 (RHSA-2025:23140)
The remote Redhat Enterprise Linux 9 host has packages installed that are affected by a vulnerability as referenced in the RHSA-2025:23140 advisory. Ruby is an extensible, interpreted, object-oriented, scripting language. It has features to process text files and to perform system management task...
rexml: REXML denial of service
A denial of service flaw has been discovered in the rubygem REXML. Certain input can cause excess cpu usage and given sufficiently large input this can affect program performance...
Moderate: Red Hat Security Advisory: ruby:3.3 security update
An update for the ruby:3.3 module is now available for Red Hat Enterprise Linux 8. Red Hat Product Security has rated this update as having a security impact of Moderate. A Common Vulnerability Scoring System CVSS base score, which gives a detailed severity rating, is available for each...
org.jenkins-ci.main:jenkins-test-harness (1.442), org.jenkins-ci.main:jenkins-war (1.442) +6 more potentially affected by CVE-2025-67639 via org.jenkins-ci.main:jenkins-core (1.442)
org.jenkins-ci.main:jenkins-core MAVEN version 1.442 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.main:jenkins-core and may be impacted: - org.jenkins-ci.main:jenkins-test-harness 1.442 - org.jenkins-ci.main:jenkins-war 1.442 -...
org.jenkins-ci.main:jenkins-test-harness (1.442), org.jenkins-ci.main:jenkins-war (1.442) +6 more potentially affected by CVE-2025-67635 via org.jenkins-ci.main:jenkins-core (1.442)
org.jenkins-ci.main:jenkins-core MAVEN version 1.442 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.main:jenkins-core and may be impacted: - org.jenkins-ci.main:jenkins-test-harness 1.442 - org.jenkins-ci.main:jenkins-war 1.442 -...
org.jenkins-ci.main:jenkins-test-harness (1.505), org.jenkins-ci.main:jenkins-war (1.505) +6 more potentially affected by CVE-2025-67638 via org.jenkins-ci.main:jenkins-core (1.505)
org.jenkins-ci.main:jenkins-core MAVEN version 1.505 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.main:jenkins-core and may be impacted: - org.jenkins-ci.main:jenkins-test-harness 1.505 - org.jenkins-ci.main:jenkins-war 1.505 -...
net.praqma:monkit-plugin (>=0.2.5, <=1.0.0), org.jenkins-ci.main:jenkins-test-harness (1.426) +7 more potentially affected by CVE-2025-67637 via org.jenkins-ci.main:jenkins-core (1.426)
org.jenkins-ci.main:jenkins-core MAVEN version 1.426 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.main:jenkins-core and may be impacted: - net.praqma:monkit-plugin =0.2.5, =0.1, =1.0, =1.3 Source cves: CVE-2025-67637 Source advisory:...