19506 matches found
OESA-2026-2762 vim security update
Vim is an advanced text editor that seeks to provide the power of the de-facto Unix editor 'Vi', with a more complete feature set. Vim is a highly configurable text editor built to enable efficient text editing. It is an improved version of the vi editor distributed with most UNIX systems. Securi...
OESA-2026-2761 vim security update
Vim is an advanced text editor that seeks to provide the power of the de-facto Unix editor 'Vi', with a more complete feature set. Vim is a highly configurable text editor built to enable efficient text editing. It is an improved version of the vi editor distributed with most UNIX systems. Securi...
OESA-2026-2763 vim security update
Vim is an advanced text editor that seeks to provide the power of the de-facto Unix editor 'Vi', with a more complete feature set. Vim is a highly configurable text editor built to enable efficient text editing. It is an improved version of the vi editor distributed with most UNIX systems. Securi...
TencentOS Server 3: ruby:3.3 (TSSA-2026:0546)
The version of Tencent Linux installed on the remote TencentOS Server 3 host is prior to tested version. It is, therefore, affected by a vulnerability as referenced in the TSSA-2026:0546 advisory. Package updates are available for TencentOS Server 3 that fix the following vulnerabilities:...
ruby:4.0 security update
ruby 4.0.3-32 - Upgrade to Ruby 4.0.3. Resolves: RHEL-171933 - Fix ERB: Arbitrary code execution via deserialization bypass CVE-2026-41316 Resolves: RHEL-171258 - Fix JSON: Denial of Service or Information Disclosure via format string injection CVE-2026-33210 Resolves: RHEL-173458 rubygem-mysql2...
CVE-2026-54904: Loop with Unreachable Exit Condition
concurrent-ruby is a modern concurrency tools for Ruby. Prior to 1.3.7, Concurrent::AtomicReferenceupdate can enter a permanent busy retry loop when the current value is Float::NAN. The issue is caused by the interaction between AtomicReferenceupdate, which retries until compareandsetoldvalue,...
CVE-2026-54906: Missing Lock Check
concurrent-ruby is a modern concurrency tools for Ruby. Prior to 1.3.7, Concurrent::ReadWriteLockreleasewritelock does not verify that the calling thread acquired the write lock. Any thread with access to the lock object can release an active write lock held by another thread. A second writer can...
CVE-2026-54905: Wrap-around Error
concurrent-ruby is a modern concurrency tools for Ruby. Prior to 1.3.7, Concurrent::ReentrantReadWriteLock can incorrectly grant a write lock after one thread acquires the read lock 32,768 times. The lock stores a thread's local read and write hold counts in one integer. The low 15 bits are used...
GHSA-5V8H-3H3Q-446P vulnerabilities
Vulnerabilities for packages: pact-broker-docker-fips, pact-broker-docker, logstash, gitlab-rails-ce, logstash-fips, ruby3.2-rails, kube-logging-operator, ruby4.0-rails, ruby3.4-rails, ruby3.3-rails, commercial-gitlab-rails-ee...
GHSA-5PRR-V3J2-97MH vulnerabilities
Vulnerabilities for packages: pact-broker-docker-fips, pact-broker-docker, logstash, gitlab-rails-ce, logstash-fips, ruby3.2-rails, kube-logging-operator, ruby4.0-rails, ruby3.4-rails, ruby3.3-rails, commercial-gitlab-rails-ee...
GHSA-WFPW-MMFH-QQ69 vulnerabilities
Vulnerabilities for packages: pact-broker-docker-fips, pact-broker-docker, logstash, gitlab-rails-ce, logstash-fips, ruby3.2-rails, kube-logging-operator, ruby4.0-rails, ruby3.4-rails, ruby3.3-rails, commercial-gitlab-rails-ee...
GHSA-8678-W3JW-XFC2 vulnerabilities
Vulnerabilities for packages: pact-broker-docker-fips, pact-broker-docker, logstash, gitlab-rails-ce, logstash-fips, ruby3.2-rails, kube-logging-operator, ruby4.0-rails, ruby3.4-rails, ruby3.3-rails, commercial-gitlab-rails-ee...
GHSA-9CV2-CFXC-V4V2 vulnerabilities
Vulnerabilities for packages: pact-broker-docker-fips, pact-broker-docker, logstash, gitlab-rails-ce, logstash-fips, ruby3.2-rails, kube-logging-operator, ruby4.0-rails, ruby3.4-rails, ruby3.3-rails, commercial-gitlab-rails-ee...
GHSA-P67V-3W7G-WJG7 vulnerabilities
Vulnerabilities for packages: pact-broker-docker-fips, pact-broker-docker, logstash, gitlab-rails-ce, logstash-fips, ruby3.2-rails, kube-logging-operator, ruby4.0-rails, ruby3.4-rails, ruby3.3-rails, commercial-gitlab-rails-ee...
GHSA-WJV4-X9W8-WM3H vulnerabilities
Vulnerabilities for packages: pact-broker-docker-fips, pact-broker-docker, logstash, gitlab-rails-ce, logstash-fips, ruby3.2-rails, kube-logging-operator, ruby4.0-rails, ruby3.4-rails, ruby3.3-rails, commercial-gitlab-rails-ee...
CVE-2026-54904 vulnerabilities
Vulnerabilities for packages: logstash, logstash-fips, ruby3.2-rails, ruby3.3-fluentd-kubernetes-daemonset, kube-logging-operator, ruby3.4-fluentd-kubernetes-daemonset, ruby4.0-fluentd-kubernetes-daemonset, ruby4.0-rails, ruby3.4-rails, ruby3.2-fluentd-kubernetes-daemonset,...
CVE-2026-54905 vulnerabilities
Vulnerabilities for packages: logstash, logstash-fips, ruby3.2-rails, ruby3.3-fluentd-kubernetes-daemonset, kube-logging-operator, ruby3.4-fluentd-kubernetes-daemonset, ruby4.0-fluentd-kubernetes-daemonset, ruby4.0-rails, ruby3.4-rails, ruby3.2-fluentd-kubernetes-daemonset,...
CVE-2026-54906 vulnerabilities
Vulnerabilities for packages: logstash, logstash-fips, ruby3.2-rails, ruby3.3-fluentd-kubernetes-daemonset, kube-logging-operator, ruby3.4-fluentd-kubernetes-daemonset, ruby4.0-fluentd-kubernetes-daemonset, ruby4.0-rails, ruby3.4-rails, ruby3.2-fluentd-kubernetes-daemonset,...
GHSA-6WX8-W4F5-WWCR vulnerabilities
Vulnerabilities for packages: logstash, logstash-fips, ruby3.2-rails, ruby3.3-fluentd-kubernetes-daemonset, kube-logging-operator, ruby3.4-fluentd-kubernetes-daemonset, ruby4.0-fluentd-kubernetes-daemonset, ruby4.0-rails, ruby3.4-rails, ruby3.2-fluentd-kubernetes-daemonset,...
GHSA-H8W8-99G7-QMVJ vulnerabilities
Vulnerabilities for packages: logstash, logstash-fips, ruby3.2-rails, ruby3.3-fluentd-kubernetes-daemonset, kube-logging-operator, ruby3.4-fluentd-kubernetes-daemonset, ruby4.0-fluentd-kubernetes-daemonset, ruby4.0-rails, ruby3.4-rails, ruby3.2-fluentd-kubernetes-daemonset,...