Lucene search
+L

22 matches found

Kitploit
Kitploit
•added 2026/10/12 12:08 a.m.•25 views

Http11Probe

Http11Probe Http11Probe is a compliance and security tester for HTTP/1.1 servers. It throws malformed, ambiguous, and oversized requests at a server over raw TCP sockets and checks how it responds against what RFC 9110 and RFC 9112 actually require. These are the awkward cases like bare LF line...

6.3AI score
SaveExploits0References1
Tenable Nessus
Tenable Nessus
•added 2026/09/30 12:00 a.m.•7 views

AlmaLinux 9.6 [TuxCare] Security Update: libsoup / libsoup-devel / libsoup-doc (ALMALINUX9.6:CLSA-2026:1787783675)

The AlmaLinux 9.6 host has packages installed that are affected by a vulnerability as referenced in the TuxCare ALMALINUX9.6:CLSA-2026:1787783675 advisory. - A flaw was found in libsoup. The chunked transfer encoding parser uses a permissive parsing function for chunk sizes that silently accepts...

7.2CVSS5.7AI score0.00277EPSS
SaveExploits1References3
OSV
OSV
•added 2026/07/24 11:16 p.m.•21 views

AZL-94095 CVE-2026-66338 affecting package libsoup 3.4.4-16

A flaw was found in libsoup. The chunked transfer encoding parser uses a permissive parsing function for chunk sizes that silently accepts inputs violating RFC 9112, including leading whitespace, plus sign prefixes, and trailing invalid characters. When libsoup operates behind a strict frontend...

7.2CVSS5.7AI score0.00277EPSS
SaveExploits1References1
UbuntuCve
UbuntuCve
•added 2026/07/24 11:16 p.m.•13 views

CVE-2026-66338

A flaw was found in libsoup. The chunked transfer encoding parser uses a permissive parsing function for chunk sizes that silently accepts inputs violating RFC 9112, including leading whitespace, plus sign prefixes, and trailing invalid characters. When libsoup operates behind a strict frontend...

7.2CVSS5.7AI score0.00277EPSS
SaveExploits1References5
Rapid7 Vulnerability Database (full)
Rapid7 Vulnerability Database (full)
•added 2026/07/24 12:00 a.m.•6 views

CVE-2026-66338: Inconsistent Interpretation of HTTP Requests

A flaw was found in libsoup. The chunked transfer encoding parser uses a permissive parsing function for chunk sizes that silently accepts inputs violating RFC 9112, including leading whitespace, plus sign prefixes, and trailing invalid characters. When libsoup operates behind a strict frontend...

7.2CVSS5.7AI score0.00277EPSS
SaveExploits1References4
Cvelist
Cvelist
•added 2026/07/14 8:51 a.m.•61 views

CVE-2026-6790

In Eclipse Jetty, for HTTP/1, HTTP/2 and HTTP/3 requests, there is no strict check that the request authority host and port matches what provided in the Host header if present. This was not enforced in earlier HTTP RFC for example, in RFC 2616, but it is in the latest RFC 9110 and 9112. This...

5.3CVSS0.0031EPSS
SaveExploits0References1
OSV
OSV
•added 2026/06/15 8:46 p.m.•29 views

GHSA-HVCG-QMG6-JM4C Netty: HttpObjectDecoder skips arbitrary initial control characters when only initial CRLF characters are permitted

Summary Before reading the first request-line, HttpObjectDecoder skips every byte for which Character.isISOControlb is true 0x00–0x1F and 0x7F as well as all whitespace. RFC 9112 §2.2 only asks servers to ignore empty CRLF lines preceding the request-line — a carefully scoped robustness allowance...

5.3CVSS6.6AI score0.00398EPSS
SaveExploits0References5
EUVD
EUVD
•added 2026/05/19 7:25 p.m.•31 views

EUVD-2026-29951

Bandit: Unauthenticated DoS via chunked request trailers in Bandit HTTP/1 decoder...

8.7CVSS5.8AI score0.00941EPSS
SaveExploits1References5
OSV
OSV
•added 2026/05/07 12:22 a.m.•70 views

GHSA-38F8-5428-X5CV Netty vulnerable to HTTP Request Smuggling due to malformed Transfer-Encoding

Summary Netty incorrectly parses malformed Transfer-Encoding, enabling request smuggling attacks. Details Netty incorrectly marks a request as chunked when malformed "Transfer-Encoding: chunked, identity" is present. According to RFC...

6.5CVSS7.2AI score0.00293EPSS
SaveExploits1References4
Positive Technologies
Positive Technologies
•added 2026/05/05 12:00 a.m.•33 views

PT-2026-38377

Name of the Vulnerable Software and Affected Versions Netty versions prior to 4.2.13.Final Netty versions prior to 4.1.133.Final Description Netty incorrectly parses malformed Transfer-Encoding headers, which can lead to request smuggling attacks. Specifically, the framework incorrectly marks a...

7.8CVSS7.1AI score0.00293EPSS
SaveExploits1
RedhatCVE
RedhatCVE
•added 2026/03/26 3:03 p.m.•12 views

CVE-2026-23941

Inconsistent Interpretation of HTTP Requests 'HTTP Request Smuggling' vulnerability in Erlang OTP inets httpd module allows HTTP Request Smuggling. This vulnerability is associated with program files lib/inets/src/httpserver/httpdrequest.erl and program routines httpdrequest:parseheaders/7. The...

7CVSS7.4AI score0.0047EPSS
SaveExploits0References1
UbuntuCve
UbuntuCve
•added 2026/03/13 7:54 p.m.•13 views

CVE-2026-23941

Inconsistent Interpretation of HTTP Requests 'HTTP Request Smuggling' vulnerability in Erlang OTP inets httpd module allows HTTP Request Smuggling. This vulnerability is associated with program files lib/inets/src/httpserver/httpdrequest.erl and program routines httpdrequest:parseheaders/7. The...

9.4CVSS7.4AI score0.0047EPSS
SaveExploits0References7
EUVD
EUVD
•added 2026/03/13 9:11 a.m.•24 views

EUVD-2026-11776

Inconsistent Interpretation of HTTP Requests 'HTTP Request Smuggling' vulnerability in Erlang OTP inets httpd module allows HTTP Request Smuggling. This vulnerability is associated with program files lib/inets/src/httpserver/httpdrequest.erl and program routines httpdrequest:parseheaders/7. The...

7CVSS7.4AI score0.0047EPSS
SaveExploits0References5
Tenable Nessus
Tenable Nessus
•added 2023/08/31 12:00 a.m.•22 views

CBL Mariner 2.0 Security Update: rubygem-protocol-http1 (CVE-2023-38697)

The version of rubygem-protocol-http1 installed on the remote CBL Mariner 2.0 host is prior to tested version. It is, therefore, affected by a vulnerability as referenced in the CVE-2023-38697 advisory. - protocol-http1 provides a low-level implementation of the HTTP/1 protocol. RFC 9112 Section...

5.8CVSS5.7AI score0.00754EPSS
SaveExploits0References2
UbuntuCve
UbuntuCve
•added 2023/08/04 6:15 p.m.•25 views

CVE-2023-38697

protocol-http1 provides a low-level implementation of the HTTP/1 protocol. RFC 9112 Section 7.1 defined the format of chunk size, chunk data and chunk extension. The value of Content-Length header should be a string of 0-9 digits, the chunk size should be a string of hex digits and should split...

5.8CVSS6.1AI score0.00754EPSS
SaveExploits0References6
Prion
Prion
•added 2023/08/04 6:15 p.m.•24 views

Design/Logic Flaw

protocol-http1 provides a low-level implementation of the HTTP/1 protocol. RFC 9112 Section 7.1 defined the format of chunk size, chunk data and chunk extension. The value of Content-Length header should be a string of 0-9 digits, the chunk size should be a string of hex digits and should split...

5CVSS4.9AI score0.00754EPSS
SaveExploits0References4Affected Software1
Vulnrichment
Vulnrichment
•added 2023/08/04 5:32 p.m.•17 views

CVE-2023-38697 protocol-http1 HTTP Request/Response Smuggling vulnerability

protocol-http1 provides a low-level implementation of the HTTP/1 protocol. RFC 9112 Section 7.1 defined the format of chunk size, chunk data and chunk extension. The value of Content-Length header should be a string of 0-9 digits, the chunk size should be a string of hex digits and should split...

5.8CVSS5.4AI score0.00754EPSS
SaveExploits0References4
OSV
OSV
•added 2023/08/04 5:32 p.m.•36 views

CVE-2023-38697 protocol-http1 HTTP Request/Response Smuggling vulnerability

protocol-http1 provides a low-level implementation of the HTTP/1 protocol. RFC 9112 Section 7.1 defined the format of chunk size, chunk data and chunk extension. The value of Content-Length header should be a string of 0-9 digits, the chunk size should be a string of hex digits and should split...

5.8CVSS5.4AI score
SaveExploits0References6
Debian CVE
Debian CVE
•added 2023/08/04 5:32 p.m.•99 views

CVE-2023-38697

protocol-http1 provides a low-level implementation of the HTTP/1 protocol. RFC 9112 Section 7.1 defined the format of chunk size, chunk data and chunk extension. The value of Content-Length header should be a string of 0-9 digits, the chunk size should be a string of hex digits and should split...

5.8CVSS5.1AI score0.00754EPSS
SaveExploits0
OSV
OSV
•added 2023/08/03 4:36 p.m.•56 views

GHSA-6JWC-QR2Q-7XWJ protocol-http1 HTTP Request/Response Smuggling vulnerability

Impact RFC 9112 Section 7.1 defined the format of chunk size, chunk data and chunk extension detailed ABNF is in Appendix section. In summary: - The value of Content-Length header should be a string of 0-9 digits. - The chunk size should be a string of hex digits and should split from chunk data...

5.8CVSS5.5AI score0.00754EPSS
SaveExploits0References7
Rows per page
Query Builder