5 matches found
peanut-restify (>=1.1.0, <=1.1.66) potentially affected by unknown CVE via restify-swagger-jsdoc (>=1.1.2, <=1.2.1)
restify-swagger-jsdoc NPM version =1.1.2, =1.1.0, =1.1.66 Source cves: unknown CVE Source advisory: MEND:WS-2019-0213...
WS-2019-0213
restify-swagger-jsdoc versions before 3.2.1 has a path traversal vulnerability when failing to properly sanitize URLs, which may allow attackers to access server files outside the swagger-ui folder by using relative paths...
GHSA-GVFF-25CC-4F66 Path Traversal in restify-swagger-jsdoc
Versions of restify-swagger-jsdoc prior to 3.2.1 are vulnerable to Path Traversal. The package fails to properly sanitize URLs, which may allow attackers to access server files outside the swagger-ui folder by using relative paths. Recommendation Upgrade to version 3.2.1 or later...
Path Traversal in restify-swagger-jsdoc
Versions of restify-swagger-jsdoc prior to 3.2.1 are vulnerable to Path Traversal. The package fails to properly sanitize URLs, which may allow attackers to access server files outside the swagger-ui folder by using relative paths. Recommendation Upgrade to version 3.2.1 or later...
PT-2020-21319
Name of the Vulnerable Software and Affected Versions restify-swagger-jsdoc versions prior to 3.2.1 Description The issue arises from the package's failure to properly sanitize URLs, potentially allowing attackers to access server files outside the swagger-ui folder by using relative paths...