Lucene search
+L

10562 matches found

osv_azl
osv_azl
•added 2022/07/15 8:15 p.m.•18 views

AZL-44553 CVE-2022-25858 affecting package js-jquery 3.5.0-4

The package terser before 4.8.1, from 5.0.0 and before 5.14.2 are vulnerable to Regular Expression Denial of Service ReDoS due to insecure usage of regular expressions...

7.5CVSS7.4AI score0.03253EPSS
SaveExploits1References1
UbuntuCve
UbuntuCve
•added 2022/07/15 8:15 p.m.•70 views

CVE-2022-25858

The package terser before 4.8.1, from 5.0.0 and before 5.14.2 are vulnerable to Regular Expression Denial of Service ReDoS due to insecure usage of regular expressions...

7.5CVSS6.8AI score0.03253EPSS
SaveExploits1References6
Prion
Prion
•added 2022/07/15 8:15 p.m.•24 views

Code injection

The package terser before 4.8.1, from 5.0.0 and before 5.14.2 are vulnerable to Regular Expression Denial of Service ReDoS due to insecure usage of regular expressions...

5CVSS8.3AI score0.03253EPSS
SaveExploits1References5Affected Software1
osv_ubuntu
osv_ubuntu
•added 2022/07/15 8:15 p.m.•28 views

UBUNTU-CVE-2022-25858

The package terser before 4.8.1, from 5.0.0 and before 5.14.2 are vulnerable to Regular Expression Denial of Service ReDoS due to insecure usage of regular expressions...

7.5CVSS6.8AI score0.03253EPSS
SaveExploits1References7
osv_cve
osv_cve
•added 2022/07/15 8:00 p.m.•40 views

CVE-2022-25858 Regular Expression Denial of Service (ReDoS)

The package terser before 4.8.1, from 5.0.0 and before 5.14.2 are vulnerable to Regular Expression Denial of Service ReDoS due to insecure usage of regular expressions...

5.3CVSS7.1AI score0.03253EPSS
SaveExploits1References7
Cvelist
Cvelist
•added 2022/07/15 8:00 p.m.•66 views

CVE-2022-25858 Regular Expression Denial of Service (ReDoS)

The package terser before 4.8.1, from 5.0.0 and before 5.14.2 are vulnerable to Regular Expression Denial of Service ReDoS due to insecure usage of regular expressions...

5.3CVSS7.6AI score0.03253EPSS
SaveExploits1References5
CVE
CVE
•added 2022/07/15 8:00 p.m.•562 views

CVE-2022-25858

CVE-2022-25858 affects terser: versions 4.8.1 and later (and 5.x from 5.0.0 up to before 5.14.2) are vulnerable to ReDoS due to insecure regex usage during minification. Impact can be a Denial of Service via crafted inputs. Mitigation: upgrade terser to 4.8.1+ or to 5.14.2+ (i.e., the fixed relea...

7.5CVSS6.2AI score0.03253EPSS
SaveExploits1References5Affected Software1
Debian CVE
Debian CVE
•added 2022/07/15 8:00 p.m.•60 views

CVE-2022-25858

The package terser before 4.8.1, from 5.0.0 and before 5.14.2 are vulnerable to Regular Expression Denial of Service ReDoS due to insecure usage of regular expressions...

7.5CVSS7.6AI score0.03253EPSS
SaveExploits1
Mend
Mend
•added 2022/07/15 8:00 p.m.•7 views

CVE-2022-25858

The package terser before 4.8.1, from 5.0.0 and before 5.14.2 are vulnerable to Regular Expression Denial of Service ReDoS due to insecure usage of regular expressions...

7.5CVSS0.03253EPSS
SaveExploits1References8
attackerkb
attackerkb
•added 2022/07/15 8:00 p.m.•13 views

CVE-2022-25858

The package terser before 4.8.1, from 5.0.0 and before 5.14.2 are vulnerable to Regular Expression Denial of Service ReDoS due to insecure usage of regular expressions...

7.5CVSS6.8AI score0.03253EPSS
SaveExploits1References6
CNVD
CNVD
•added 2022/07/15 12:00 a.m.•34 views

Apache Tapestry Denial of Service Vulnerability (CNVD-2022-69475)

Apache Tapestry is a web application framework written in the Java language from the Apache Foundation, U.S. A denial-of-service vulnerability exists in versions of Apache Tapestry prior to 5.8.1, which stems from a vulnerability in the way content types are handled to improper regular expression...

7.5CVSS4AI score0.01973EPSS
SaveExploits0References1
Rapid7 Vulnerability Database (full)
Rapid7 Vulnerability Database (full)
•added 2022/07/15 12:00 a.m.•4 views

CVE-2022-25858: Inefficient Regular Expression Complexity

The package terser before 4.8.1, from 5.0.0 and before 5.14.2 are vulnerable to Regular Expression Denial of Service ReDoS due to insecure usage of regular expressions...

7.5CVSS7.3AI score0.03253EPSS
SaveExploits1References2
CNNVD
CNNVD
•added 2022/07/15 12:00 a.m.•13 views

Terser security vulnerabilities

terser is a JavaScript parser, handler, and compressor toolkit for ES6+ from the individual developers of terser. A security vulnerability exists in terser versions prior to 4.8.1, 5.0.0, and 5.14.2, which stems from the insecure use of regular expressions, resulting in vulnerability to a Regular...

7.5CVSS6.7AI score0.03253EPSS
SaveExploits1References12
NVD
NVD
•added 2022/07/14 8:15 p.m.•40 views

CVE-2022-31147

The jQuery Validation Plugin jquery-validation provides drop-in validation for forms. Versions of jquery-validation prior to 1.19.5 are vulnerable to regular expression denial of service ReDoS when an attacker is able to supply arbitrary input to the url2 method. This is due to an incomplete fix...

7.5CVSS0.0224EPSS
SaveExploits1References3
osv_cve
osv_cve
•added 2022/07/14 7:30 p.m.•47 views

CVE-2022-31147 jquery-validation ReDoS in url2 due to incomplete fix of CVE-2021-43306

The jQuery Validation Plugin jquery-validation provides drop-in validation for forms. Versions of jquery-validation prior to 1.19.5 are vulnerable to regular expression denial of service ReDoS when an attacker is able to supply arbitrary input to the url2 method. This is due to an incomplete fix...

7.5CVSS7.7AI score0.0224EPSS
SaveExploits1References5
Debian CVE
Debian CVE
•added 2022/07/14 7:30 p.m.•79 views

CVE-2022-31147

The jQuery Validation Plugin jquery-validation provides drop-in validation for forms. Versions of jquery-validation prior to 1.19.5 are vulnerable to regular expression denial of service ReDoS when an attacker is able to supply arbitrary input to the url2 method. This is due to an incomplete fix...

7.5CVSS7.7AI score0.0224EPSS
SaveExploits1
RedHat Linux
RedHat Linux
•added 2022/07/14 12:56 p.m.•18 views

nodejs-ansi-regex: Regular expression denial of service (ReDoS) matching ANSI escape codes

A regular expression denial of service ReDoS vulnerability was found in nodejs-ansi-regex. This could possibly cause an application using ansi-regex to use an excessive amount of CPU time when matching crafted ANSI escape codes...

7.8CVSS7.1AI score0.03552EPSS
SaveExploits1References5
Github Security Blog
Github Security Blog
•added 2022/07/14 12:00 a.m.•68 views

Apache Tapestry 5.8.1 vulnerable to ReDoS via Content Types causing catastrophic backtracking

Apache Tapestry up to version 5.8.1 is vulnerable to Regular Expression Denial of Service ReDoS in the way it handles Content Types. Specially crafted Content Types may cause catastrophic backtracking, taking exponential time to complete. Specifically, this is about the regular expression used on...

7.5CVSS7.3AI score0.01973EPSS
SaveExploits0References4Affected Software1
OpenVAS
OpenVAS
•added 2022/07/14 12:00 a.m.•33 views

Apache Tapestry < 5.8.2 DoS Vulnerability

Apache Tapestry is prone to a regular expression denial of service ReDoS vulnerability. Copyright C 2022 Greenbone Networks GmbH Some text descriptions might be excerpted from a referenced sources, and are Copyright C by the respective right holders. SPDX-License-Identifier: GPL-2.0-or-later This...

7.5CVSS7.5AI score0.01973EPSS
SaveExploits0References1
Snyk
Snyk
•added 2022/07/13 2:50 p.m.•20 views

Regular Expression Denial of Service (ReDoS)

Overview react-native-reanimated is a More powerful alternative to Animated library for React Native. Affected versions of this package are vulnerable to Regular Expression Denial of Service ReDoS due to improper usage of regular expression in the parser of Colors.js. PoC js new...

7.5CVSS7.1AI score0.01637EPSS
SaveExploits1References2
Rows per page
Query Builder