Lucene search
+L

59 matches found

Cvelist
Cvelist
•added 2026/10/21 11:40 a.m.•29 views

CVE-2026-56388 Apache bRPC: Out-of-Bounds Write in Redis Command Parser

The Redis server command parser in Apache bRPC accepts an empty RESP array as a command header. A remote unauthenticated attacker who can reach a bRPC server with Redis service enabled can send an empty array header followed by a bulk string, causing an out-of-bounds write in the parser and...

0.00953EPSS
SaveExploits0References1
EUVD
EUVD
•added 2026/10/21 11:40 a.m.•13 views

EUVD-2026-107174

The Redis server command parser in Apache bRPC accepts an empty RESP array as a command header. A remote unauthenticated attacker who can reach a bRPC server with Redis service enabled can send an empty array header followed by a bulk string, causing an out-of-bounds write in the parser and...

6.2AI score0.00953EPSS
SaveExploits0References1
CVE
CVE
•added 2026/10/21 11:40 a.m.•27 views

CVE-2026-56388

The Apache bRPC Redis server command parser is vulnerable to an out-of-bounds write due to improper handling of RESP array counts. Specifically, RedisCommandParser::ConsumeImpl accepted zero as a count, resizing the command argument vector to zero elements. If an attacker sends an empty RESP arra...

9.1CVSS6.2AI score0.00953EPSS
SaveExploits0References1
Positive Technologies
Positive Technologies
•added 2026/10/21 12:00 a.m.•9 views

PT-2026-120533

The Redis server command parser in Apache bRPC accepts an empty RESP array as a command header. A remote unauthenticated attacker who can reach a bRPC server with Redis service enabled can send an empty array header followed by a bulk string, causing an out-of-bounds write in the parser and...

6.2AI score0.00953EPSS
SaveExploits0References3
AstraLinux
AstraLinux
•added 2026/10/15 3:53 p.m.•14 views

Astra Linux – Vulnerability in Redis

Redis is an open-source, in-memory database that persists data on disk. The redis-cli command-line tool and the redis-sentinel service may be vulnerable to integer overflow when parsing specially crafted large multi-bulk network replies. This issue arises due to a vulnerability in the hiredis...

9CVSS7AI score0.02558EPSS
SaveExploits0References2
Snyk
Snyk
•added 2026/09/08 8:57 p.m.•7 views

CRLF Injection

Overview Affected versions of this package are vulnerable to CRLF Injection in AbstractAggregateConnection::write in src/Connection/AbstractAggregateConnection.php, which re-parses the already serialized pipeline buffer by splitting on \r\n and rebuilding chunks through Command::deserializeComman...

9.8CVSS8.5AI score0.00726EPSS
SaveExploits0References2
osv_ghsa
osv_ghsa
•added 2026/09/08 8:57 p.m.•21 views

GHSA-W6F5-V2H6-G786 Predis: Redis command injection and denial of service via CRLF smuggling in pipelined commands on aggregate connections

Summary An improper CRLF neutralization flaw in Predis' pipeline handling on aggregate connections lets an unauthenticated attacker who can influence any pipelined argument — a value or a key, e.g. a URL slug used as a cache key — smuggle arbitrary Redis commands into the connection. - On cluster...

9.8CVSS8.7AI score0.00726EPSS
SaveExploits0References7
Github Security Blog
Github Security Blog
•added 2026/09/02 9:20 p.m.•4 views

Malicious code in auth0-chalk-redis-command (npm)

The package auth0-chalk-redis-command was found to contain malicious code. --- Credit: OpenSSF source...

5.8AI score
SaveExploits0References2Affected Software1
Ubuntu
Ubuntu
•added 2026/06/08 1:38 p.m.•39 views

USN-8401-1: Netty vulnerabilities

It was discovered that Netty's HTTP proxy handler did not properly validate headers when constructing CONNECT requests. An attacker could possibly use this issue to inject arbitrary HTTP headers into CONNECT requests. This issue only affected Ubuntu 18.04 LTS, Ubuntu 20.04 LTS, Ubuntu 22.04 LTS,...

9.8CVSS7.1AI score0.01065EPSS
SaveExploits6
osv_usn
osv_usn
•added 2026/06/08 1:38 p.m.•45 views

USN-8401-1 netty vulnerabilities

It was discovered that Netty's HTTP proxy handler did not properly validate headers when constructing CONNECT requests. An attacker could possibly use this issue to inject arbitrary HTTP headers into CONNECT requests. This issue only affected Ubuntu 18.04 LTS, Ubuntu 20.04 LTS, Ubuntu 22.04 LTS,...

9.8CVSS7.1AI score0.01065EPSS
SaveExploits6References7
EUVD
EUVD
•added 2025/10/07 12:30 a.m.•15 views

EUVD-2019-19104

Malware in sbrugna...

6.1CVSS6.8AI score0.02196EPSS
SaveExploits1References12
EUVD
EUVD
•added 2025/10/03 8:07 p.m.•22 views

EUVD-2025-14851

Malicious code in bioql PyPI...

6.5CVSS5.9AI score0.00413EPSS
SaveExploits1References3
osv_mal
osv_mal
•added 2025/09/05 5:10 p.m.•13 views

MAL-2025-43545 Malicious code in auth0-chalk-redis-command (npm)

The package auth0-chalk-redis-command was found to contain malicious code...

7AI score
SaveExploits0
RedhatCVE
RedhatCVE
•added 2025/04/26 5:00 a.m.•41 views

CVE-2025-26268

DragonflyDB Dragonfly before 1.27.0 allows authenticated users to cause a denial of service daemon crash via a crafted Redis command. The validity of the scan cursor was not checked...

6.5CVSS5.9AI score0.00413EPSS
SaveExploits1References1
NVD
NVD
•added 2025/04/17 6:15 p.m.•29 views

CVE-2025-26268

DragonflyDB Dragonfly before 1.27.0 allows authenticated users to cause a denial of service daemon crash via a crafted Redis command. The validity of the scan cursor was not checked...

6.5CVSS0.00413EPSS
SaveExploits1References3
Mend
Mend
•added 2025/04/17 12:00 a.m.•10 views

CVE-2025-26268

DragonflyDB Dragonfly before 1.27.0 allows authenticated users to cause a denial of service daemon crash via a crafted Redis command. The validity of the scan cursor was not checked...

6.5CVSS5.8AI score0.00413EPSS
SaveExploits1References5
Cvelist
Cvelist
•added 2025/04/17 12:00 a.m.•37 views

CVE-2025-26268

DragonflyDB Dragonfly before 1.27.0 allows authenticated users to cause a denial of service daemon crash via a crafted Redis command. The validity of the scan cursor was not checked...

3.3CVSS0.00413EPSS
SaveExploits1References3
CVE
CVE
•added 2025/04/17 12:00 a.m.•125 views

CVE-2025-26268

DragonflyDB pre-1.27.0 is affected. Authenticated users can trigger a denial of service (daemon crash) by sending a crafted Redis command, caused by the scan cursor validity check being missing. Affected: DragonflyDB Dragonfly versions prior to 1.27.0. Remediation: upgrade to 1.27.0 or later (or ...

6.5CVSS5.8AI score0.00413EPSS
SaveExploits1References3Affected Software1
Positive Technologies
Positive Technologies
•added 2025/04/17 12:00 a.m.•24 views

PT-2025-17214 · Redis +1 · Redis +1

Name of the Vulnerable Software and Affected Versions: DragonflyDB Dragonfly versions prior to 1.27.0 Description: The issue allows authenticated users to cause a denial of service, resulting in a daemon crash, by sending a crafted Redis command. The problem stems from the lack of validation of t...

6.5CVSS5.8AI score0.00413EPSS
SaveExploits1References8
Vulnrichment
Vulnrichment
•added 2025/04/17 12:00 a.m.•16 views

CVE-2025-26268

DragonflyDB Dragonfly before 1.27.0 allows authenticated users to cause a denial of service daemon crash via a crafted Redis command. The validity of the scan cursor was not checked...

3.3CVSS5.8AI score0.00413EPSS
SaveExploits1References3
Rows per page
Query Builder