20365 matches found
Langflow OSS - Superuser Token Issuance
Langflow OSS with default AUTOLOGIN exposes /api/v1/autologin, which returns a superuser access token to any unauthenticated request. id: CVE-2026-9103 info: name: Langflow OSS - Superuser Token Issuance author: str4k3r severity: critical description: | Langflow OSS with default AUTOLOGIN exposes...
Splunk Enterprise Patroni REST API - Missing Authentication RCE
Splunk Enterprise versions 10.2.0 through 10.2.6 and 10.4.0 through 10.4.2 expose the Patroni REST API PostgreSQL sidecar on SHC members without authentication. An unauthenticated attacker can PATCH /config to set a malicious archivecommand and POST /restart to trigger it, achieving remote code...
Flowise < 3.1.3 - Remote Code Execution
Flowise prior to 3.1.3 contains a remote code execution vulnerability caused by allowing authenticated users to set arbitrary TypeORM DataSource options including entities that load local JavaScript files, letting authenticated users execute arbitrary code on the server, exploit requires user...
Netgear RAX43 1.0.3.96 - Command Injection/Authentication Bypass Buffer Overrun
Netgear RAX43 version 1.0.3.96 contains a command injection and authentication bypass vulnerability. The readycloudcontrol.cgi CGI application is vulnerable to command injection in the name parameter. Additionally, the URL parsing functionality in the cgi-bin endpoint of the router containers a...
CVE-2026-109618-109619-audit
CVE-2026-109618 / CVE-2026-109619 Audit of the "php2shell" claims, plus one working local PoC. 中文 · PHP 8.5.4 · lab-only MITRE: CVERECORDDNE · NVD: no record · php.net: pre-announcement only. This repo audits the technical claims; it does not confirm the identifiers. 30-second verdict Question|...
CVE-2019-19356
NETIS router WF2419 RCE CVE-2019-19356 Context The vulnerability is an authenticated Remote Code Execution RCE as root through the NETIS WF2419 router Web management page. The vulnerability has been found on firmware version V1.2.31805 and on the last available firmware version V2.2.36123. Other...
Jackson_RCE-CVE-2019-12384
Environment Setup Import the project into IDEA, configure Maven to automatically import dependencies, then write the following file into a local empty web directory and save it as exec.sql. Start an HTTP server: CREATE ALIAS SHELLEXEC AS $$ String shellexecString cmd throws java.io.IOException...
cve-2019-15107
CVE-2019-15107 - Webmin Unauthenticated RCE Description This repository contains a proof-of-concept PoC exploit for CVE-2019-15107 affecting Webmin versions 1.890 through 1.920. The script exploits a backdoor in versions 1.890 through 1.920 that allows unauthenticated users to inject commands int...
CVE-2026-64638-PoC-XSS2Shell-
XSS2Shell — WordPress Pre-Auth XSS → RCE Chain PoC CVE-2026-64638 · Reflected XSS on wp-login.php · CVSS 8.9 v4.0 · Patched in WordPress 7.0.3 ⚠️ AUTHORIZED TESTING ONLY. This tool is for security research and authorized penetration testing against systems you own or have explicit written...
ai-ide-config-guard
valtik-ai-ide-config-guard Scan a repository for AI-IDE configuration files that can trigger RCE, credential theft, or persistent compromise of developer machines when the repo is opened in Claude Code, Cursor, Windsurf, Continue, or any VS Code fork. Built in response to the April 2026 AI-IDE...
CVE-2025-2005
WordPress FEUP Arbitrary File Upload Exploit CVE-2025-2005 This repository provides a Proof of Concept PoC exploit for the WordPress Front End Users plugin versions up to 3.2.32, which is vulnerable to arbitrary file upload due to missing MIME/file-type validation in its registration form.This...
php2shell-scanner
php2shell-scanner Non-destructive scanner with opt-in probe for CVE-2026-109618 RCE via OOM corruption and CVE-2026-109619 RCE via stale global state — core PHP bugs fixed in 8.2.35 / 8.3.36 / 8.4.27 / 8.5.12. ✅ Verified against the official php-src advisories 2026-10-21, Critical. The CVE IDs an...
wordpress-batch-rce-lab
wp2shell: WordPress Batch RCE A technical breakdown of CVE-2026-63030, a logic bug in WordPress core's REST API batch endpoint that lets an anonymous request dispatch under a different request's route and permission check, chaining into CVE-2026-60137 SQL injection for unauthenticated remote code...
CVE-2022-46169
CVE-2022-46169 Exploit Exploit to CVE-2022-46169 vulnerability on Cacti 1.2.19 Options -u --url victim's url -f --forwarded X-Forwarded value to bypass the auth -m --mode: check for Checking for Vulnerable Servers, or exploit for Fun exploitation mode :D Usage 1. $ ./cve202246169.py -u...
CVE-2022-46169
CVE 2022-46169 This script exploits an unauthenticated command injection vulnerability in Cacti versions through 1.2.22 in order to achieve unauthenticated remote code execution and gain a reverse shell...
sagex3-cve-2020-7388-poc
sagex3-cve-2020-7388-poc Proof of concept exploit code for CVE-2020-7388, an unauthenticated RCE as SYSTEM on Sage X3's AdxDSrv Service Overview Sage X3 exposes an administrative service on port TCP/1818 default, but changeable under the process "AdxDSrv.exe," part of the AdxAdmin component. This...
POC-CVE-2026-58048
CVE-2026-58048 CVSS 4.0: 9.4 Critical | CWE-89: SQL Injection | NVD Authenticated cPanel user → arbitrary SQL as MySQL root via database rename. cPanel improperly preserves the user's session sqlmode ANSIQUOTES when executing rename operations as root — a backtick in the database name breaks out ...
Blackash-CVE-2025-48593
🚨 CVE-2025-48593 Zero-Click Remote Code Execution in Android System 🚨 "A single malicious packet can own your device." — Android Security Team, Nov 2025 🎯 Vulnerability Snapshot Attribute| Details ---|--- CVE ID| CVE-2025-48593 Severity| 🔴 Critical RCE, Zero-Click CVSS Est.| 9.8 Pending NVD...
CVE-2024-51378
CyberPanel Command Injection Vulnerability - CVE-2024-51378 Exploit for CyberPanel Pre-Auth RCE Remote Code Execution via Command Injection Author: Luka Petrovic refr4g Date Disclosed: October 2024 Overview Proof-of-concept PoC exploit for a command injection vulnerability CVE-2024-51378 in...
CVE-2024-25600-Bricks-Builder-plugin-for-WordPress
CVE-2024-25600 Exploit Tool 🚀 Description 📝 This tool 🛠️ is designed to exploit the CVE-2024-25600 vulnerability 🕳️ found in the Bricks Builder plugin for WordPress. The vulnerability allows for unauthenticated remote code execution on affected websites 💻. The tool automates the exploitation...