12950 matches found
EulerOS Virtualization 3.0.2.2 : vim (EulerOS-SA-2023-1303)
According to the versions of the vim packages installed, the EulerOS Virtualization installation on the remote host is affected by the following vulnerabilities : - vim is vulnerable to Heap-based Buffer Overflow CVE-2021-3778, CVE-2021-3872, CVE-2021-3927, CVE-2021-3984, CVE-2021-4019,...
Ubuntu: Security Advisory (USN-5171-2)
The remote host is missing an update for the SPDX-FileCopyrightText: 2023 Greenbone AG Some text descriptions might be excerpted from a referenced sources, and are Copyright C by the respective right holders. SPDX-License-Identifier: GPL-2.0-only ifdescription...
GitLab EE security vulnerabilities
GitLab Enterprise Edition EE is a content management system from the U.S.-based GitLab, Inc. A security vulnerability exists in GitLab EE versions 13.7 through 15.4.6, 15.5 through 15.5.5, and 15.6 through 15.6.1, which stems from the presence of an information leak...
Eclipse GlassFish path traversal vulnerability
Eclipse GlassFish is an open source application server from the Eclipse Foundation. A security vulnerability exists in Eclipse GlassFish versions 5.1.0 through 6.2.5, which stems from not filtering paths that begin with a specific string...
DEBIAN-CVE-2023-0414
Crash in the EAP dissector in Wireshark 4.0.0 to 4.0.2 allows denial of service via packet injection or crafted capture file...
GLPI security vulnerabilities
GLPI is an open source IT and asset management software for individual developers. The software provides a full-featured IT resource management interface that you can use to build databases to fully manage IT computers, monitors, servers, printers, network devices, phones, and even toner and ink...
Binwalk path traversal vulnerability
Binwalk is a fast, easy-to-use tool from ReFirm Labs open source. It is used to analyze, reverse engineer and extract firmware images. A path traversal vulnerability exists in ReFirm Labs Binwalk versions 2.1.2b through 2.3.2, which stems from the presence of a path traversal that allows an...
Devolutions Remote Desktop Manager security vulnerabilities
Devolutions Remote Desktop Manager is an application from Devolutions Canada. It provides remote desktop management functionality. A security vulnerability exists in Devolutions Remote Desktop Manager versions 2022.3.29 to 2022.3.30, which stems from when it switches to offline mode, the forced...
OpenSearch Project information leakage vulnerability
OpenSearch Project is OpenSearch Project open source a community-driven, Apache 2.0 licensed open source search and analytics suite. Making it easy to access, search, visualize and analyze data. An information disclosure vulnerability exists in OpenSearch Project versions 1.0.0 through 1.3.7 and...
Regular Expression Denial of Service (ReDoS)
Overview semver is a semantic version parser used by npm. Affected versions of this package are vulnerable to Regular Expression Denial of Service ReDoS via the function new Range, when untrusted user data is provided as a range. PoC js const semver = require'semver' const lengths2 = 2000, 4000,...
007putra-my-bot (1.1.1), 03-asenkronsdasdsadavehttprequest (1.0.0) +17734 more potentially affected by CVE-2022-25883 via semver (>=7.0.0, <=7.5.1)
semver NPM version =7.0.0, =7.5.1 is affected by a known vulnerability. The following packages have a transitive dependency on semver and may be impacted: - 007putra-my-bot 1.1.1 - 03-asenkronsdasdsadavehttprequest 1.0.0 - 0xgank-tea-advice-pull 1.0.0 - 0xgank-tea-balance-pencil 1.0.0 -...
DEBIAN-CVE-2022-38725
An integer overflow in the RFC3164 parser in One Identity syslog-ng 3.0 through 3.37 allows remote attackers to cause a Denial of Service via crafted syslog input that is mishandled by the tcp or network function. syslog-ng Premium Edition 7.0.30 and syslog-ng Store Box 6.10.0 are also affected...
ALPINE-CVE-2022-47015
MariaDB Server before 10.3.34 thru 10.9.3 is vulnerable to Denial of Service. It is possible for function spiderdbmbase::printwarnings to dereference a null pointer...
ALPINE-CVE-2022-47021
A null pointer dereference issue was discovered in functions opgetdata and opopen1 in opusfile.c in xiph opusfile 0.9 thru 0.12 allows attackers to cause denial of service or other unspecified impacts...
IBM Cloud Pak for Security log information leakage vulnerability
IBM Cloud Pak for Security is an application from International Business Machines IBM, Inc. an open security platform that connects to your existing data sources to generate deeper insights and enables you to take automated action faster. A log information disclosure vulnerability exists in IBM...
Vim code issues and vulnerabilities
Vim is a cross-platform text editor. A code issue vulnerability exists in vim versions 8.1.2269 through 9.0.0339, which stems from a null pointer dereference in the function guix11createblankmouse in guix11.c, allowing attackers to cause a denial of service or other unspecified impact...
RecollateralizationLib: Flaw in basket range calculation leads to early basket compromise and loss to RToken holders
Lines of code Vulnerability details Impact This report deals with how the recollateralization algorithm underestimates the number of baskets it can hold by calculating unnecessary costs for collateral that does not need to be traded. When this number of baskets it thinks it can hold is reached -...
Regular Expression Denial Of Service (ReDoS)
rack is vulnerable to Regular Expression Denial of Service ReDoS attacks. The vulnerability exists in the Range header parsing component of the library, which allows an attacker to significantly slow down the processing via passing a carefully crafted input...
Basket range formula is inefficient, leading the protocol to unnecessary haircut
Lines of code Vulnerability details Impact The BackingManager.manageTokens function checks if there's any deficit in collateral, in case there is, if there's a surplus from another collateral token it trades it to cover the deficit, otherwise it goes for a 'haircut' and cuts the amount of basket...
Denial of service via header parsing in Rack
There is a possible denial of service vulnerability in the Range header parsing component of Rack. This vulnerability has been assigned the CVE identifier CVE-2022-44570. Versions Affected: = 1.5.0 Not affected: None. Fixed Versions: 2.0.9.2, 2.1.4.2, 2.2.6.2, 3.0.0.1 Impact Carefully crafted inp...