13134 matches found
📄 React Server 19.2.0 Remote Code Execution
React Server versions 19.0.0, 19.1.0, 19.1.1, and 19.2.0 proof of concept remote code execution exploit. Exploit Title: React Server 19.2.0 - Remote Code Execution Date: 2025-12-05 Exploit Author: EynaExp https://github.com/EynaExp Vendor Homepage: https://react.dev Software Link:...
Ruby Rack < 2.2.23 / 3.0.x < 3.1.21 / 3.2 < 3.2.6 Multiple Vulnerabilities
The version of the Rack Ruby library installed on the remote host is prior to 2.2.23, prior to 3.1.21, or prior to 3.2.6. It is, therefore, affected by multiple vulnerabilities: - Rack::Utils.getbyteranges parses HTTP Range header without limiting the number of individual byte ranges, leading to...
OpenClaw security vulnerabilities
OpenClaw is an open-source intelligent artificial assistant developed by OpenClaw. Version 2026.2.13 to 2026.3.24 of OpenClaw contained security vulnerabilities. These vulnerabilities were caused by ANSI escape sequence injections in the approval prompts, which could allow attackers to forge...
SUSE SLED15 / SLES15 / openSUSE 15 : Recommended update for shadow (SUSE-SU-SUSE-RU-2026:1228-1)
The remote SUSE Linux SLED15 / SLEDSAP15 / SLES15 / SLESSAP15 / openSUSE 15 host has packages installed that are affected by multiple vulnerabilities as referenced in the SUSE-SU-SUSE-RU-2026:1228-1 advisory. shadow is updated to 4.17.2 to bring lots of features and bug fixes. - util-linux-2.41...
PT-2026-32048
Name of the Vulnerable Software and Affected Versions Net::CIDR::Lite versions prior to 0.23 Description The Net::CIDR::Lite Perl module before version 0.23 does not properly validate the IPv6 group count, potentially allowing a bypass of IP Access Control Lists ACLs. Recommendations Update to...
wolfSSL (CyaSSL) security vulnerabilities
wolfSSL CyaSSL is a small, portable embedded SSL programming library developed by the American company wolfSSL, aimed at developers working with embedded systems. There is a security vulnerability in wolfSSL, where the ECCSI signature verifier does not check the scalar range, allowing specially...
EUVD-2026-21006
Inconsistent Interpretation of HTTP Requests 'HTTP Request/Response Smuggling' vulnerability in Apache Tomcat via invalid chunk extension. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.18, from 10.1.0-M1 through 10.1.52, from 9.0.0.M1 through 9.0.115, from 8.5.0 through 8.5.100,...
brace-expansion: brace-expansion: Denial of Service via unbounded brace range expansion
A flaw was found in the brace-expansion component. This denial of service DoS vulnerability allows a remote attacker to provide specially crafted input containing repeated numeric brace ranges. This input causes the library to attempt an unbounded expansion, consuming excessive CPU and memory...
CVE-2026-34971
Wasmtime is a runtime for WebAssembly. From 32.0.0 to before 36.0.7, 42.0.2, and 43.0.1, Wasmtime's Cranelift compilation backend contains a bug on aarch64 when performing a certain shape of heap accesses which means that the wrong address is accessed. When combined with explicit bounds checks a...
CVE-2026-34946
Wasmtime is a runtime for WebAssembly. From 25.0.0 to before 36.0.7, 42.0.2, and 43.0.1, Wasmtime's Winch compiler contains a vulnerability where the compilation of the table.fill instruction can result in a host panic. This means that a valid guest can be compiled with Winch, on any architecture...
@albirex/platformatic-logto (>=1.0.0, <=3.1.2), @aoi-js/server (>=1.2.3, <=1.2.11) +117 more potentially affected by CVE-2026-35041 via fast-jwt (>=5.0.0, <=6.0.1)
fast-jwt NPM version =5.0.0, =1.0.0, =1.2.3, =1.0.6, =1.0.11, =1.9.4, =0.1.2, =0.16.13, =0.16.13, =2.0.5, =5.0.1, =1.0.6, =9.0.2, =0.4.15, =0.10.0, =0.81.0 and more Source cves: CVE-2026-35041 Source advisory: OSV:GHSA-CJW9-GHJ4-FWXF...
@jsprismarine/client (>=0.12.2-unstable-20250320195345, <=0.13.1), @jsprismarine/prismarine (>=0.12.2-unstable-20250320195345, <=0.13.1) +1 more potentially affected by CVE-2026-35040 via fast-jwt (>=6.0.0, <=6.0.1)
fast-jwt NPM version =6.0.0, =0.12.2-unstable-20250320195345, =0.12.2-unstable-20250320195345, =0.12.2-unstable-20250320195345, =0.13.1 Source cves: CVE-2026-35040 Source advisory: OSV:GHSA-3J8V-CGW4-2G6Q...
CVE-2026-34020
Use of GET Request Method With Sensitive Query Strings vulnerability in Apache OpenMeetings. The REST login endpoint uses HTTP GET method with username and password passed as query parameters. Please check references regarding possible impact This issue affects Apache OpenMeetings: from 3.1.3...
CVE-2026-35205 Helm's plugin verification fails open when .prov is missing, allowing unsigned plugin install
Helm is a package manager for Charts for Kubernetes. From 4.0.0 to 4.1.3, Helm will install plugins missing provenance .prov file when signature verification is required. This vulnerability is fixed in 4.1.4...
OpenClaw security vulnerabilities
OpenClaw is an open-source intelligent artificial assistant developed by OpenClaw. Versions of OpenClaw prior to 2026.3.22 contained security vulnerabilities. These vulnerabilities stemmed from insufficient range validation in the device.pair.approve method, which could lead to privilege escalati...
OpenClaw security vulnerabilities
OpenClaw is an open-source intelligent artificial assistant developed by OpenClaw. Version 2026.3.11 to 2026.3.24 of OpenClaw contains security vulnerabilities. These vulnerabilities stem from session isolation bypass, which may lead to sessions being blocked from access...
CVE-2026-5173
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 16.9.6 before 18.8.9, 18.9 before 18.9.5, and 18.10 before 18.10.3 that could have allowed an authenticated user to invoke unintended server-side methods through websocket connections due to improper access control...
CVE-2026-39892
cryptography is a package designed to expose cryptographic primitives and recipes to Python developers. From 45.0.0 to before 46.0.7, if a non-contiguous buffer was passed to APIs which accepted Python buffers e.g. Hash.update, this could lead to buffer overflows. This vulnerability is fixed in...
CVE-2026-35407
Saleor is an e-commerce platform. From 2.10.0 to before 3.23.0a3, 3.22.47, 3.21.54, and 3.20.118, a business-logic and authorization flaw was found in the account email change workflow, the confirmation flow did not verify that the email change confirmation token was issued for the given...
@frontmcp/adapters (>=0.5.0, <=1.0.3), frontmcp (0.5.0) potentially affected by CVE-2026-39885 via mcp-from-openapi (>=2.0.0, <=2.1.2)
mcp-from-openapi NPM version =2.0.0, =0.5.0, =1.0.3 - frontmcp 0.5.0 Source cves: CVE-2026-39885 Source advisory: OSV:GHSA-V6PH-XCQ9-QXXJ...