29 matches found
com.cisco.oss.foundation.queue:queue-rabbitmq (>=1.0.3-1, <=1.0.4-2), com.daedafusion:events-rabbitmq (1.0) +5 more potentially affected by CVE-2026-106121 via com.rabbitmq:amqp-client (3.4.4)
com.rabbitmq:amqp-client MAVEN version 3.4.4 is affected by a known vulnerability. The following packages have a transitive dependency on com.rabbitmq:amqp-client and may be impacted: - com.cisco.oss.foundation.queue:queue-rabbitmq =1.0.3-1, =3.0.0, =2.1.0-rc1, =2.1.0-rc1, =2.1.0-rc1, =2.3.3 Sour...
com.automationrockstars:gunter-rabbit (>=1.0.2, <=2.0.3), com.rabbitmq.jms:rabbitmq-jms (1.4.7) +4 more potentially affected by CVE-2026-106121 via com.rabbitmq:amqp-client (3.6.2)
com.rabbitmq:amqp-client MAVEN version 3.6.2 is affected by a known vulnerability. The following packages have a transitive dependency on com.rabbitmq:amqp-client and may be impacted: - com.automationrockstars:gunter-rabbit =1.0.2, =1.1.1, =3.3.0.cr1, =3.3.0.cr1, =2.1.0-alpha.1, =2.1.0-alpha.2...
com.cisco.oss.foundation.queue:queue-rabbitmq (>=1.0.3-1, <=1.0.4-2), com.daedafusion:events-rabbitmq (1.0) +5 more potentially affected by CVE-2026-106122 via com.rabbitmq:amqp-client (3.4.4)
com.rabbitmq:amqp-client MAVEN version 3.4.4 is affected by a known vulnerability. The following packages have a transitive dependency on com.rabbitmq:amqp-client and may be impacted: - com.cisco.oss.foundation.queue:queue-rabbitmq =1.0.3-1, =3.0.0, =2.1.0-rc1, =2.1.0-rc1, =2.1.0-rc1, =2.3.3 Sour...
com.automationrockstars:gunter-rabbit (>=1.0.2, <=2.0.3), com.rabbitmq.jms:rabbitmq-jms (1.4.7) +4 more potentially affected by CVE-2026-106122 via com.rabbitmq:amqp-client (3.6.2)
com.rabbitmq:amqp-client MAVEN version 3.6.2 is affected by a known vulnerability. The following packages have a transitive dependency on com.rabbitmq:amqp-client and may be impacted: - com.automationrockstars:gunter-rabbit =1.0.2, =1.1.1, =3.3.0.cr1, =3.3.0.cr1, =2.1.0-alpha.1, =2.1.0-alpha.2...
com.cisco.oss.foundation.queue:queue-rabbitmq (>=1.0.3-1, <=1.0.4-2), com.daedafusion:events-rabbitmq (1.0) +5 more potentially affected by CVE-2026-106123 via com.rabbitmq:amqp-client (3.4.4)
com.rabbitmq:amqp-client MAVEN version 3.4.4 is affected by a known vulnerability. The following packages have a transitive dependency on com.rabbitmq:amqp-client and may be impacted: - com.cisco.oss.foundation.queue:queue-rabbitmq =1.0.3-1, =3.0.0, =2.1.0-rc1, =2.1.0-rc1, =2.1.0-rc1, =2.3.3 Sour...
com.cisco.oss.foundation.queue:queue-rabbitmq (>=1.0.3-1, <=1.0.4-2), com.daedafusion:events-rabbitmq (1.0) +5 more potentially affected by CVE-2026-61634 via com.rabbitmq:amqp-client (3.4.4)
com.rabbitmq:amqp-client MAVEN version 3.4.4 is affected by a known vulnerability. The following packages have a transitive dependency on com.rabbitmq:amqp-client and may be impacted: - com.cisco.oss.foundation.queue:queue-rabbitmq =1.0.3-1, =3.0.0, =2.1.0-rc1, =2.1.0-rc1, =2.1.0-rc1, =2.3.3 Sour...
com.automationrockstars:gunter-rabbit (>=1.0.2, <=2.0.3), com.rabbitmq.jms:rabbitmq-jms (1.4.7) +4 more potentially affected by CVE-2026-63335 via com.rabbitmq:amqp-client (3.6.2)
com.rabbitmq:amqp-client MAVEN version 3.6.2 is affected by a known vulnerability. The following packages have a transitive dependency on com.rabbitmq:amqp-client and may be impacted: - com.automationrockstars:gunter-rabbit =1.0.2, =1.1.1, =3.3.0.cr1, =3.3.0.cr1, =2.1.0-alpha.1, =2.1.0-alpha.2...
com.cisco.oss.foundation.queue:queue-rabbitmq (>=1.0.3-1, <=1.0.4-2), com.daedafusion:events-rabbitmq (1.0) +5 more potentially affected by CVE-2026-63337 via com.rabbitmq:amqp-client (3.4.4)
com.rabbitmq:amqp-client MAVEN version 3.4.4 is affected by a known vulnerability. The following packages have a transitive dependency on com.rabbitmq:amqp-client and may be impacted: - com.cisco.oss.foundation.queue:queue-rabbitmq =1.0.3-1, =3.0.0, =2.1.0-rc1, =2.1.0-rc1, =2.1.0-rc1, =2.3.3 Sour...
com.automationrockstars:gunter-rabbit (>=1.0.2, <=2.0.3), com.rabbitmq.jms:rabbitmq-jms (1.4.7) +4 more potentially affected by CVE-2026-69219 via com.rabbitmq:amqp-client (3.6.2)
com.rabbitmq:amqp-client MAVEN version 3.6.2 is affected by a known vulnerability. The following packages have a transitive dependency on com.rabbitmq:amqp-client and may be impacted: - com.automationrockstars:gunter-rabbit =1.0.2, =1.1.1, =3.3.0.cr1, =3.3.0.cr1, =2.1.0-alpha.1, =2.1.0-alpha.2...
com.cisco.oss.foundation.queue:queue-rabbitmq (>=1.0.3-1, <=1.0.4-2), com.daedafusion:events-rabbitmq (1.0) +5 more potentially affected by CVE-2026-69220 via com.rabbitmq:amqp-client (3.4.4)
com.rabbitmq:amqp-client MAVEN version 3.4.4 is affected by a known vulnerability. The following packages have a transitive dependency on com.rabbitmq:amqp-client and may be impacted: - com.cisco.oss.foundation.queue:queue-rabbitmq =1.0.3-1, =3.0.0, =2.1.0-rc1, =2.1.0-rc1, =2.1.0-rc1, =2.3.3 Sour...
MGASA-2026-0314 Updated librabbitmq packages fix security vulnerabilities
The updated packages fix security vulnerabilities: An issue was discovered in the C AMQP client library aka rabbitmq-c through 0.13.0 for RabbitMQ. Credentials can only be entered on the command line e.g., for amqp-publish or amqp-consume and are thus visible to local attackers by listing a proce...
BIT-RABBITMQ-C-2023-35789
An issue was discovered in the C AMQP client library aka rabbitmq-c through 0.13.0 for RabbitMQ. Credentials can only be entered on the command line e.g., for amqp-publish or amqp-consume and are thus visible to local attackers by listing a process and its arguments...
Azure Linux 3.0 Security Update: librabbitmq (CVE-2023-35789)
The version of librabbitmq installed on the remote Azure Linux 3.0 host is prior to tested version. It is, therefore, affected by a vulnerability as referenced in the CVE-2023-35789 advisory. - An issue was discovered in the C AMQP client library aka rabbitmq-c through 0.13.0 for RabbitMQ...
OPENSUSE-SU-2025:15410-1 erlang-rabbitmq-client-3.13.7-5.1 on GA media
These are all security issues fixed in the erlang-rabbitmq-client-3.13.7-5.1 package on the GA media of openSUSE Tumbleweed...
erlang-rabbitmq-client-3.13.7-4.1 on GA media (moderate)
erlang-rabbitmq-client-3.13.7-4.1 on GA media Announcement ID: openSUSE-SU-2025:15291-1 Rating: moderate Cross-References: CVE-2025-30219 CVSS scores: CVE-2025-30219 SUSE : 6.1 CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:C/C:H/I:N/A:L CVE-2025-30219 SUSE : 5.7...
OPENSUSE-SU-2025:15291-1 erlang-rabbitmq-client-3.13.7-4.1 on GA media
These are all security issues fixed in the erlang-rabbitmq-client-3.13.7-4.1 package on the GA media of openSUSE Tumbleweed...
An issue was discovered in the C AMQP client library (aka rabbitmq-c) through 0.13.0 for RabbitMQ. Credentials can only be entered on the command line (e.g., for amqp-publish or amqp-consume) and are thus visible to local attackers by listing a process and its arguments.
...
OPENSUSE-SU-2024:11294-1 erlang-rabbitmq-client-3.9.7-1.1 on GA media
These are all security issues fixed in the erlang-rabbitmq-client-3.9.7-1.1 package on the GA media of openSUSE Tumbleweed...
OPENSUSE-SU-2024:10370-1 erlang-rabbitmq-client-3.5.4-1.4 on GA media
These are all security issues fixed in the erlang-rabbitmq-client-3.5.4-1.4 package on the GA media of openSUSE Tumbleweed...
CVE-2023-46120
The RabbitMQ Java client library allows Java and JVM-based applications to connect to and interact with RabbitMQ nodes. maxBodyLebgth was not used when receiving Message objects. Attackers could send a very large Message causing a memory overflow and triggering an OOM Error. Users of RabbitMQ may...