41 matches found
CVE-2026-107479
An integer truncation vulnerability in the QTextCodec conversion functions of the Qt 5 Core Compatibility APIs module impacts the Qt Framework. An application using the affected functionality could crash...
EUVD-2026-116890
An integer truncation vulnerability in the QTextCodec conversion functions of the Qt 5 Core Compatibility APIs module impacts the Qt Framework. An application using the affected functionality could crash...
PT-2026-136945
An integer truncation vulnerability in the QTextCodec conversion functions of the Qt 5 Core Compatibility APIs module impacts the Qt Framework. An application using the affected functionality could crash...
CVE-2026-107479: Qt: An integer truncation vulnerability in the QTextCodec conversion functions of the Qt 5 Core Compatibility APIs module…
An integer truncation vulnerability in the QTextCodec conversion functions of the Qt 5 Core Compatibility APIs module impacts the Qt Framework. An application using the affected functionality could crash...
CVE-2026-107590
An out-of-bounds write vulnerability in the Qt QTextCodec iconv-based encoding of the Qt 5 Compatibility APIs module Qt Core in Qt 5 and earlier impacts Qt. Under certain conditions, encoding text with QTextCodec may write outside an internal buffer. This can cause the application to crash and ma...
PT-2026-125890
An out-of-bounds read vulnerability in the QTextCodec TSCII encoding of the Qt 5 Compatibility APIs module Qt Core in Qt 5 and earlier impacts Qt. Applications that convert text to the TSCII encoding through QTextCodec may read memory outside the input buffer, which can cause the application to...
EUVD-2018-7395
Malware in sbrugna...
QtNetwork: Multiple Vulnerabilities
Background QtNetwork provides a set of APIs for programming applications that use TCP/IP. It is part of the Qt framework. Description Multiple vulnerabilities have been discovered in QtNetwork. Please review the CVE identifiers referenced below for details. Impact Please review the referenced CVE...
GLSA-202402-03 : QtGui: Multiple Vulnerabilities
The remote host is affected by the vulnerability described in GLSA-202402-03 QtGui: Multiple Vulnerabilities - Qt 5.x before 5.15.6 and 6.x through 6.1.2 has an out-of-bounds write in QOutlineMapper::convertPath called from QRasterPaintEngine::fill and QPaintEngineEx::stroke. CVE-2021-38593 - An...
Rocky Linux 8 : qt5-qtbase (RLSA-2022:1796)
The remote Rocky Linux 8 host has packages installed that are affected by a vulnerability as referenced in the RLSA-2022:1796 advisory. - Qt 5.x before 5.15.6 and 6.x through 6.1.2 has an out-of-bounds write in QOutlineMapper::convertPath called from QRasterPaintEngine::fill and...
Oracle Linux 7 : qt (ELSA-2020-1172)
The remote Oracle Linux 7 host has packages installed that are affected by multiple vulnerabilities as referenced in the ELSA-2020-1172 advisory. 1:4.8.7-8 - Fix QImage allocation failure in qgifhandler Resolves: bz1667863 - Fix QTgaFile CPU exhaustion Resolves: bz1667879 - Fix QBmpHandler...
NewStart CGSL CORE 5.05 / MAIN 5.05 : qt5-qttranslations Multiple Vulnerabilities (NS-SA-2023-0014)
The remote NewStart CGSL host, running version CORE 5.05 / MAIN 5.05, has qt5-qttranslations packages installed that are affected by multiple vulnerabilities: - QXmlStream in Qt 5.x before 5.11.3 has a double-free or corruption during parsing of a specially crafted illegal XML document...
NewStart CGSL CORE 5.05 / MAIN 5.05 : qt5-qtserialport Multiple Vulnerabilities (NS-SA-2023-0011)
The remote NewStart CGSL host, running version CORE 5.05 / MAIN 5.05, has qt5-qtserialport packages installed that are affected by multiple vulnerabilities: - QXmlStream in Qt 5.x before 5.11.3 has a double-free or corruption during parsing of a specially crafted illegal XML document...
Medium: qt5-qtbase
Issue Overview: Qt 5.x before 5.15.6 and 6.x through 6.1.2 has an out-of-bounds write in QOutlineMapper::convertPath called from QRasterPaintEngine::fill and QPaintEngineEx::stroke. CVE-2021-38593 Affected Packages: qt5-qtbase Note: This advisory is applicable to Amazon Linux 2 AL2 Core repositor...
USN-5081-1: Qt vulnerabilities
It was discovered that Qt incorrectly handled certain XBM image files. If a user or automated system were tricked into opening a specially crafted PPM file, a remote attacker could cause Qt to crash, resulting in a denial of service. CVE-2020-17507 It was discovered that Qt incorrectly handled...
Fedora 32 : kf5-messagelib / qt5-qtwebengine (2021-bdaf015218)
The remote Fedora 32 host has packages installed that are affected by a vulnerability as referenced in the FEDORA-2021-bdaf015218 advisory. - This update rebases QtWebEngine to the latest Qt 5 release, 5.15.2, fixing dozens of security issues. The same version is already shipped on Fedora 33 and...
[SECURITY] Fedora 32 Update: calamares-3.2.11-14.fc32
Calamares is a distribution-independent installer framework, designed to in stall from a live CD/DVD/USB environment to a hard disk. It includes a graphical installation program based on Qt 5. This package includes the Calamares framework and the required configuration files to produce a working...
Fedora: Security Advisory for calamares (FEDORA-2020-da859aadde)
The remote host is missing an update for the SPDX-FileCopyrightText: 2020 Greenbone AG Some text descriptions might be excerpted from a referenced sources, and are Copyright C by the respective right holders. SPDX-License-Identifier: GPL-2.0-only ifdescription...
Fedora: Security Advisory for calamares (FEDORA-2020-73471e6414)
The remote host is missing an update for the Copyright C 2020 Greenbone Networks GmbH Some text descriptions might be excerpted from a referenced sources, and are Copyright C by the respective right holders. SPDX-License-Identifier: GPL-2.0-or-later This program is free software; you can...