74662 matches found
hexora v0.3.1
hexora Hexora is a static analysis tool designed to detect malicious and harmful patterns in Python code. It combines a rule-based static analysis engine with a machine-learned model that scores entire source files to classify them as malicious or benign. It can be used to: Audit project...
voidaccess v2.0.1
VoidAccess Self-hostable OSINT for turning dark-web research queries into structured threat intelligence. Built for security researchers, threat-intelligence teams, and authorized investigators who need collection, enrichment, relationship mapping, and export in one workflow. Terminal Output Quic...
Deploy MQTT Reverse Agent
Generate and optionally execute a stdlib Python MQTT reverse agent from an existing shell session. Pairs with listeners/iot/reversemqttshell. !/usr/bin/env python3 -- coding: utf-8 -- """Post module: package/show MQTT reverse agent for delivery from a shell session.""" from kittysploit import fro...
ImCurvin v1.3.0
ImCurvin' ImCurvin is an open-source web security auditing and penetration testing tool designed to automate environment misconfiguration detection, track exposed configuration blueprints, and probe backend vulnerabilities. Detailed information regarding ImCurvin can be found at...
antimatter (0.1.3), autotrain-advanced (>=0.6.42, <=0.6.44) +12 more potentially affected by CVE-2026-9856 via transformers (4.34.1)
transformers PYPI version 4.34.1 is affected by a known vulnerability. The following packages have a transitive dependency on transformers and may be impacted: - antimatter 0.1.3 - autotrain-advanced =0.6.42, =4.3.0, =1.22.0rc1, =1.0.1, =0.1.69, =0.1.73 - spacy-transformers 1.3.2 Source cves:...
Malicious Package
Overview trongriden is a malicious package. This package contains malicious code, and its content was removed from the official package manager. While this package might be attempting to impersonate a valid organization, there is no connection between that organization and this package authorship...
Malicious code in trongriden (PyPI)
--- -= Per source details. Do not edit below this line.=- Source: kam193 dfb2a16e0023940b622e66acf21c1597d4127d94fb730610f509960e49754c3f Package appears to be designed for private key exfiltration, but no known usage. The name appears to be related to the cryptocurrency TRX Tron / Tronix. Some...
MAL-2026-11429 Malicious code in trongriden (PyPI)
--- -= Per source details. Do not edit below this line.=- Source: kam193 dfb2a16e0023940b622e66acf21c1597d4127d94fb730610f509960e49754c3f Package appears to be designed for private key exfiltration, but no known usage. The name appears to be related to the cryptocurrency TRX Tron / Tronix. Some...
offensive-security-labs
Offensive Security Labs A collection of hands-on offensive cy...
[SECURITY] Fedora 43 Update: GitPython-3.1.55-1.fc43
GitPython is a python library used to interact with git repositories, high-level like git-porcelain, or low-level like git-plumbing. It provides abstractions of git objects for easy access of repository data, a nd additionally allows you to access the git repository more directly using eith er a...
CVE-2026-67338
JupyterLab before 4.5.9 contains a stored cross-site scripting vulnerability in the Extension Manager that fails to validate URI protocols in package metadata URLs. Attackers can publish malicious PyPI packages with javascript: URLs in project metadata that execute arbitrary JavaScript in the...
sealights-python-agent (>=0.2.213, <=0.2.247) potentially affected by CVE-2026-67326 via gitpython (2.1.13)
gitpython PYPI version 2.1.13 is affected by a known vulnerability. The following packages have a transitive dependency on gitpython and may be impacted: - sealights-python-agent =0.2.213, =0.2.247 Source cves: CVE-2026-67326 Source advisory: OSV:PYSEC-2026-3980...
PYSEC-2026-3980
GitPython before 3.1.50 fails to validate newline characters in the section parameter of configwriter, allowing attackers to inject arbitrary section headers into .git/config. Attackers can inject newlines to create a forged core section with hooksPath pointing to attacker-controlled directories,...
UBUNTU-CVE-2026-67338
JupyterLab before 4.5.9 contains a stored cross-site scripting vulnerability in the Extension Manager that fails to validate URI protocols in package metadata URLs. Attackers can publish malicious PyPI packages with javascript: URLs in project metadata that execute arbitrary JavaScript in the...
UBUNTU-CVE-2026-67325
GitPython before 3.1.51 contains an incomplete command injection blocklist that fails to account for git's long-option prefix abbreviation feature. Attackers can bypass the unsafe options guard by using abbreviated option names like uploadp instead of uploadpack, which git resolves to dangerous...
CVE-2026-67338
JupyterLab before 4.5.9 contains a stored cross-site scripting vulnerability in the Extension Manager that fails to validate URI protocols in package metadata URLs. Attackers can publish malicious PyPI packages with javascript: URLs in project metadata that execute arbitrary JavaScript in the...
CVE-2026-67326
GitPython before 3.1.50 fails to validate newline characters in the section parameter of configwriter, allowing attackers to inject arbitrary section headers into .git/config. Attackers can inject newlines to create a forged core section with hooksPath pointing to attacker-controlled directories,...
EUVD-2026-51849
JupyterLab before 4.5.9 contains a stored cross-site scripting vulnerability in the Extension Manager that fails to validate URI protocols in package metadata URLs. Attackers can publish malicious PyPI packages with javascript: URLs in project metadata that execute arbitrary JavaScript in the...
CVE-2026-67338 JupyterLab before 4.5.9 Stored XSS via Extension Manager
JupyterLab before 4.5.9 contains a stored cross-site scripting vulnerability in the Extension Manager that fails to validate URI protocols in package metadata URLs. Attackers can publish malicious PyPI packages with javascript: URLs in project metadata that execute arbitrary JavaScript in the...
CVE-2026-67338
CVE-2026-67338 affects JupyterLab prior to 4.5.9. A stored cross-site scripting vulnerability resides in the Extension Manager where URI protocols in package metadata URLs are not validated. This allows an attacker to publish malicious PyPI packages with javascript: URLs in project metadata, enab...