74609 matches found
CLEANSTART-2026-YJ27178 hpack is an HTTP/2 Header Encoding for Python
Security vulnerability affects the py3-hpack package. hpack is an HTTP/2 Header Encoding for Python...
[SECURITY] Fedora 45 Update: python-cssselect2-0.10.1-1.fc45
cssselect2 is a straightforward implementation of CSS4 Selectors for markup documents HTML, XML, etc. that can be read by ElementTree-like parsers, including cElementTree, lxml, html5lib, etc...
MGASA-2026-0463 Updated python-pillow packages fix security vulnerabilities
Prevent decompression bomb when parsing PDF WindowsViewer.getcommand injection EPS image infinite loop JPEG2000 image memory usage McIdas out-of-bounds OOB read Out-of-bounds OOB read when saving 1 mode TGA images Out-of-bounds OOB write from large RankFilter sizes Out-of-bounds OOB write from...
Updated python-pillow packages fix security vulnerabilities
Prevent decompression bomb when parsing PDF WindowsViewer.getcommand injection EPS image infinite loop JPEG2000 image memory usage McIdas out-of-bounds OOB read Out-of-bounds OOB read when saving 1 mode TGA images Out-of-bounds OOB write from large RankFilter sizes Out-of-bounds OOB write from...
PT-2026-103973
Name of the Vulnerable Software and Affected Versions confluent-kafka-python versions prior to 2.15.1 Description Improper TLS certificate validation in the HashiCorp Vault KMS integration may allow a remote attacker to obtain sensitive information. TLS Transport Layer Security is a cryptographic...
CVE-2026-104020: Uncontrolled Recursion
Uncontrolled recursion in the Ion reader in Amazon Ion Python before 0.15.0 might allow a remote unauthenticated actor to crash the application using the library, resulting in a denial of service, via a crafted, deeply nested Ion value. To remediate this issue, users should upgrade to version...
PT-2026-104018
Name of the Vulnerable Software and Affected Versions Powertools for AWS Lambda Python versions prior to 3.35.0 Description A fail-open error handling issue exists within the data masking utility. This flaw may allow actors to read sensitive field values that the application intended to mask...
AlmaLinux 9.2 [TuxCare] Security Update: python3.11 / python3.11-debug / python3.11-devel / python3.11-idle / etc (ALMALINUX9.2:CLSA-2025:1740645491)
The AlmaLinux 9.2 host has packages installed that are affected by a vulnerability as referenced in the TuxCare ALMALINUX9.2:CLSA-2025:1740645491 advisory. - The email module of Python through 3.11.3 incorrectly parses e-mail addresses that contain a special character. The wrong portion of an...
Rocky Linux 9.6 [TuxCare] Security Update: python-unversioned-command / python3 / python3-debug / etc Multiple Vulnerabilities (ALMALINUX9.6:CLSA-2026:1786764414)
The Rocky Linux 9.6 host has packages installed that are affected by multiple vulnerabilities as referenced in the TuxCare ALMALINUX9.6:CLSA-2026:1786764414 advisory. - When loading a plist file, the plistlib module reads data in size specified by the file itself, meaning a malicious file can cau...
Rocky Linux 8.6 [CIQ] Security Update: python38-cffi / python38-cffi-debuginfo Multiple Vulnerabilities (ciqsa-2026_0200)
The Rocky Linux 8.6 host has packages installed that are affected by multiple vulnerabilities as referenced in the CIQ ciqsa-20260200 advisory. This advisory aggregates security fixes for the python-cffi SRPM in CIQ LTS 8.6. It addresses 4 CVEs: CVE-2015-20107, CVE-2020-10735, CVE-2021-28861,...
Rocky Linux 9 [CIQ] Security Update: python3.14-cryptography / python3.14-cryptography-debuginfo / etc Multiple Vulnerabilities (crlsa-2026_64774)
The Rocky Linux 9 host has packages installed that are affected by multiple vulnerabilities as referenced in the CIQ crlsa-202664774 advisory. python-cryptography: python-cryptography: Duplicate self-signed intermediates can cause exponential path-building CVE-2026-69249 python-cryptography:...
Rocky Linux 10.2 [CIQ] Security Update: python3.14-pip / python3.14-pip-wheel (crlsa-2026_36193)
The Rocky Linux 10.2 host has packages installed that are affected by a vulnerability as referenced in the CIQ crlsa-202636193 advisory. python-pip: Path traversal via malicious entry point name in pip wheel installation allows arbitrary file overwrite CVE-2026-8643 Tenable has extracted the...
AlmaLinux 9.6 [TuxCare] Security Update: python-unversioned-command / python3 / python3-debug / etc Multiple Vulnerabilities (ALMALINUX9.6:CLSA-2026:1778233301)
The AlmaLinux 9.6 host has packages installed that are affected by multiple vulnerabilities as referenced in the TuxCare ALMALINUX9.6:CLSA-2026:1778233301 advisory. - CPython 3.9 and earlier doesn't disallow configuring an empty list for SSLContext.setnpnprotocols which is an invalid value for th...
Rocky Linux 8 [CIQ] Security Update: Cython-debugsource / PyYAML-debugsource / numpy-debugsource / etc (crlsa-2022_7592)
The Rocky Linux 8 host has packages installed that are affected by a vulnerability as referenced in the CIQ crlsa-20227592 advisory. python: mailcap: findmatch function does not sanitize the second argument CVE-2015-20107 Tenable has extracted the preceding description block directly from the CIQ...
Rocky Linux 8.6 [CIQ] Security Update: python3-pillow / python3-pillow-debuginfo / python3-pillow-devel / etc (ciqsa-2026_0245)
The Rocky Linux 8.6 host has packages installed that are affected by a vulnerability as referenced in the CIQ ciqsa-20260245 advisory. This advisory aggregates security fixes for the python-pillow SRPM in CIQ LTS 8.6. It addresses 1 CVE: CVE-2024-28219. Tenable has extracted the preceding...
Rocky Linux 8 [CIQ] Security Update: python3.12 / python3.12-debug / python3.12-debuginfo / etc (crlsa-2026_39893)
The Rocky Linux 8 host has packages installed that are affected by a vulnerability as referenced in the CIQ crlsa-202639893 advisory. python: Python: CPU Denial of Service in HTML parser via repeated unterminated markup declarations CVE-2026-15308 Tenable has extracted the preceding description...
AlmaLinux 9.2 [TuxCare] Security Update: python-unversioned-command / python3 / python3-debug / etc Multiple Vulnerabilities (ALMALINUX9.2:CLSA-2025:1753208636)
The AlmaLinux 9.2 host has packages installed that are affected by multiple vulnerabilities as referenced in the TuxCare ALMALINUX9.2:CLSA-2025:1753208636 advisory. Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number...
Rocky Linux 8.6 [CIQ] Security Update: python39-pycparser Multiple Vulnerabilities (ciqsa-2026_0757)
The Rocky Linux 8.6 host has a package installed that is affected by multiple vulnerabilities as referenced in the CIQ ciqsa-20260757 advisory. This advisory aggregates security fixes for the python-pycparser SRPM in CIQ LTS 8.6. It addresses 4 CVEs: CVE-2015-20107, CVE-2020-10735, CVE-2021-28861...
Rocky Linux 8 [CIQ] Security Update: python3.11 / python3.11-debug / python3.11-debuginfo / etc Multiple Vulnerabilities (crlsa-2026_11062)
The Rocky Linux 8 host has packages installed that are affected by multiple vulnerabilities as referenced in the CIQ crlsa-202611062 advisory. python: Python: Arbitrary code execution or information disclosure via use-after-free in decompression modules CVE-2026-6100 python: cpython: Python:...
Rocky Linux 9 [CIQ] Security Update: python3.14 / python3.14-debug / python3.14-debuginfo / etc Multiple Vulnerabilities (crlsa-2026_28247)
The Rocky Linux 9 host has packages installed that are affected by multiple vulnerabilities as referenced in the CIQ crlsa-202628247 advisory. python: cpython: Python: Arbitrary code execution via command injection in webbrowser.open API CVE-2026-4786 python: Python: Cross-Site Scripting XSS...