74608 matches found
CVE-2026-104873: Incorrect Authorization
LangGraph Python SDK is used to connect to running LangGraph API servers, manage assistants, threads and stream runs from Python applications. From 0.1.45 until 0.4.4, the langgraph-sdk resource-scoped authorization decorators @auth.on.threads, @auth.on.assistants, and @auth.on.crons ignore the...
PT-2026-104432
Name of the Vulnerable Software and Affected Versions LangGraph Python SDK versions 0.1.45 through 0.4.3 Description Resource-scoped authorization decorators @auth.on.threads, @auth.on.assistants, and @auth.on.crons ignore the actions argument and register the selected handler for every action on...
mako TemplateLookup Function Unauthenticated Access
The vulnerability of the TemplateLookup.gettemplate function in the mako/lookup.py file of the Sqlalchemy mako template library in Python is related to an incorrect path name limitation for accessing restricted directories. Exploiting this vulnerability could allow an attacker to gain unauthorize...
SUSE SLES12 Security Update : python-PyYAML (SUSE-SU-2026:4402-1)
The remote SUSE Linux SLES12 / SLESSAP12 host has a package installed that is affected by a vulnerability as referenced in the SUSE-SU-2026:4402-1 advisory. - Update to 5.3.1. - CVE-2020-14343: A vulnerability was discovered in the PyYAML library, where it was susceptible to arbitrary code...
PT-2026-104334
Name of the Vulnerable Software and Affected Versions Apache Thrift versions prior to 0.25.0 Description An allocation of resources without limits or throttling issue exists in the C++, Java, Go, netstd, Python, and Delphi bindings. Specifically, the TJSONProtocol accepts a single JSON string or...
CVE-2026-66055: Allocation of Resources Without Limits or Throttling
Allocation of Resources Without Limits or Throttling vulnerability in Apache Thrift C++, Java, Go, netstd, Python and Delphi bindings. This issue affects Apache Thrift: before 0.25.0. Users are recommended to upgrade to version 0.25.0, which fixes the issue...
PT-2026-104193
Name of the Vulnerable Software and Affected Versions Apache Thrift versions prior to 0.25.0 Description The Apache Thrift Python bindings contain an issue where resources are allocated without limits or throttling and a resource is initialized with an insecure default. Recommendations Update to...
CVE-2026-66858: Uncontrolled Recursion
The protocol skip routine in several Apache Thrift bindings did not apply the binding's recursion limit, so a message that nests unknown fields deeply enough can exhaust the stack. Affected: the Python C++ accelerator the pure-Python protocols are not affected, the PHP library and its...
CVE-2026-94634: Allocation of Resources Without Limits or Throttling
Allocation of resources without limits or throttling, Initialization of a resource with an insecure default vulnerability in Apache Thrift Python bindings. This issue affects Apache Thrift: before 0.25.0. Users are recommended to upgrade to version 0.25.0, which fixes the issue...
WordPress Authorizer 3.15.3 Privilege Escalation Scanner
WordPress Authorizer versions through 3.15.3 contain an unauthenticated privilege escalation vulnerability. The supplied Python tool passively detects installed versions and optionally inspects Azure OAuth2 configuration...
CVE-2026-85087: Improper Certificate Validation
Improper certificate validation, Return of wrong status code vulnerability in Apache Thrift python bindings. This issue affects Apache Thrift: before 0.25.0. Users are recommended to upgrade to version 0.25.0, which fixes the issue...
Linux Distros Unpatched Vulnerability : CVE-2026-77387
The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - geopy is a geocoding library for Python. Prior to 2.5.0, geopy.Point and Point.fromstring can spend excessive CPU time due to inefficient regular-expression...
Fedora 45 : buildstream (2026-d77557766a)
The remote Fedora 45 host has a package installed that is affected by a vulnerability as referenced in the FEDORA-2026-d77557766a advisory. CVE-2026-82331 CWE-59: tar source plugin symlink escape while fetching a malicious tarball Python = 3.12, so the packaged /usr/bin/bst was already using...
SUSE SLED15 / SLES15 Security Update : python-tornado6 (SUSE-SU-2026:4403-1)
The remote SUSE Linux SLED15 / SLEDSAP15 / SLES15 / SLESSAP15 host has a package installed that is affected by multiple vulnerabilities as referenced in the SUSE-SU-2026:4403-1 advisory. - CVE-2023-54397: Tornado before 6.3.3 contains an HTTP request smuggling vulnerability due to improper parsin...
Critical: Red Hat Security Advisory: Satellite 6.16.14 Async Update
An update is now available for Red Hat Satellite 6.16 for RHEL 8 and RHEL 9. Red Hat Product Security has rated this update as having a security impact of Important. A Common Vulnerability Scoring System CVSS base score, which gives a detailed severity rating, is available for each vulnerability...
CVE-2026-104002
A fail-open error handling issue within the data masking utility of Powertools for AWS Lambda Python might allow actors to read sensitive field values that the application intended to mask. To remediate this issue, users should upgrade to version 3.35.0...
CVE-2026-104020
Uncontrolled recursion in the Ion reader in Amazon Ion Python before 0.15.0 might allow a remote unauthenticated actor to crash the application using the library, resulting in a denial of service, via a crafted, deeply nested Ion value. To remediate this issue, users should upgrade to version...
CVE-2026-104002
A fail-open error handling issue within the data masking utility of Powertools for AWS Lambda Python might allow actors to read sensitive field values that the application intended to mask. To remediate this issue, users should upgrade to version 3.35.0...
CVE-2026-104002 Fail-open error handling in the data masking utility in Powertools for AWS Lambda (Python)
A fail-open error handling issue within the data masking utility of Powertools for AWS Lambda Python might allow actors to read sensitive field values that the application intended to mask. To remediate this issue, users should upgrade to version 3.35.0...
CVE-2026-104002 Fail-open error handling in the data masking utility in Powertools for AWS Lambda (Python)
A fail-open error handling issue within the data masking utility of Powertools for AWS Lambda Python might allow actors to read sensitive field values that the application intended to mask. To remediate this issue, users should upgrade to version 3.35.0...