74606 matches found
CVE-2026-105801: Improper Control of Generation of Code
openapi-python-client generates Python clients from OpenAPI documents. Prior to 0.29.1, the generator does not safely neutralize malicious OpenAPI document content before rendering string, docstring, and f-string contexts in generated Python. The generated Python client can contain...
PT-2026-107101
Name of the Vulnerable Software and Affected Versions hydra-optuna-sweeper versions 1.2.0 through 1.3.0 hydra-optuna-sweeper versions 1.4.0.dev1 through 1.4.0.dev9 Description The hydra-optuna-sweeper package accepts a configuration-controlled dotted path in hydra.sweeper.custom search space, whi...
Important: python3.12 security update
Python is an interpreted, interactive, object-oriented programming language, which includes modules, classes, exceptions, very high level dynamic data types and dynamic typing. Python supports interfaces to many system calls and libraries, as well as to various windowing systems. Security Fixes:...
Linux Distros Unpatched Vulnerability : CVE-2026-105782
The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - Scrapy is a high-level web crawling and scraping framework for Python. From 1.4.0 until 2.14.2, RefererMiddleware in scrapy/spidermiddlewares/referer.py treated...
CVE-2026-105812: Improper Control of Generation of Code
Improper control of code generation in the agent import functionality of Amazon Bedrock AgentCore Starter Toolkit before 0.3.14 might allow an authenticated same-account actor to execute arbitrary code when a user imports and runs or deploys a Bedrock Agent, via crafted configuration values...
ALSA-2026:77017 Important: python3.12 security update
Python is an interpreted, interactive, object-oriented programming language, which includes modules, classes, exceptions, very high level dynamic data types and dynamic typing. Python supports interfaces to many system calls and libraries, as well as to various windowing systems. Security Fixes:...
ALSA-2026:77021 Important: python3.14 security update
Python is an interpreted, interactive, object-oriented programming language, which includes modules, classes, exceptions, very high level dynamic data types and dynamic typing. Python supports interfaces to many system calls and libraries, as well as to various windowing systems. Security Fixes:...
ALSA-2026:77028 Important: python3.12 security update
Python is an interpreted, interactive, object-oriented programming language, which includes modules, classes, exceptions, very high level dynamic data types and dynamic typing. Python supports interfaces to many system calls and libraries, as well as to various windowing systems. Security Fixes:...
PT-2026-107261
Name of the Vulnerable Software and Affected Versions Amazon Bedrock AgentCore Starter Toolkit versions prior to 0.3.14 Description Improper control of code generation within the agent import functionality allows an authenticated actor within the same account to execute arbitrary code. This occur...
PT-2026-106762
Name of the Vulnerable Software and Affected Versions openapi-python-client versions prior to 0.29.1 Description The generator fails to safely neutralize malicious content from OpenAPI documents before rendering string, docstring, and f-string contexts in the generated Python code. This allows an...
CentOS Linux 8.4 [TuxCare] Security Update: libxml2 / libxml2-devel / libxml2-static / python3-libxml2 (CENTOS8.4:CLSA-2026:1791280039)
The CentOS Linux 8.4 host has packages installed that are affected by a vulnerability as referenced in the TuxCare CENTOS8.4:CLSA-2026:1791280039 advisory. - A flaw was found in libxml2 with Python bindings enabled. A remote attacker could exploit this vulnerability by providing a specially craft...
ALSA-2026:77020 Important: python3.12 security update
Python is an interpreted, interactive, object-oriented programming language, which includes modules, classes, exceptions, very high level dynamic data types and dynamic typing. Python supports interfaces to many system calls and libraries, as well as to various windowing systems. Security Fixes:...
ALSA-2026:77018 Important: python3.14 security update
Python is an interpreted, interactive, object-oriented programming language, which includes modules, classes, exceptions, very high level dynamic data types and dynamic typing. Python supports interfaces to many system calls and libraries, as well as to various windowing systems. Security Fixes:...
Important: python3.12 security update
Python is an interpreted, interactive, object-oriented programming language, which includes modules, classes, exceptions, very high level dynamic data types and dynamic typing. Python supports interfaces to many system calls and libraries, as well as to various windowing systems. Security Fixes:...
SUSE CVE-2026-66055
Allocation of Resources Without Limits or Throttling vulnerability in Apache Thrift C++, Java, Go, netstd, Python and Delphi bindings. This issue affects Apache Thrift: before 0.25.0. Users are recommended to upgrade to version 0.25.0, which fixes the issue...
SUSE CVE-2026-66858
The protocol skip routine in several Apache Thrift bindings did not apply the binding's recursion limit, so a message that nests unknown fields deeply enough can exhaust the stack. Affected: the Python C++ accelerator the pure-Python protocols are not affected, the PHP library and its...
drmlapp (1.0.6), python-webex-bot (0.51.0) potentially affected by CVE-2026-102598 via werkzeug (0.15.1)
werkzeug PYPI version 0.15.1 is affected by a known vulnerability. The following packages have a transitive dependency on werkzeug and may be impacted: - drmlapp 1.0.6 - python-webex-bot 0.51.0 Source cves: CVE-2026-102598 Source advisory: OSV:GHSA-G6X2-HCCM-HH4M...
amundsen-metadata (>=2.5.5, <=3.5.0), bspider (>=0.0.5a0, <=0.0.8) +13 more potentially affected by CVE-2026-102598 via werkzeug (0.15.5)
werkzeug PYPI version 0.15.5 is affected by a known vulnerability. The following packages have a transitive dependency on werkzeug and may be impacted: - amundsen-metadata =2.5.5, =0.0.5a0, =1.3.1, =1.2.3, =0.1.3, =0.0.1, =0.0.9, =0.50.0, =1.0.6, =0.1.0, =4.2.0, =0.10.21, =0.15.37 Source cves:...
sd-python-wrapper (>=0.1.2, <=0.1.26) potentially affected by CVE-2026-96749 via pymongo (3.2.0)
pymongo PYPI version 3.2.0 is affected by a known vulnerability. The following packages have a transitive dependency on pymongo and may be impacted: - sd-python-wrapper =0.1.2, =0.1.26 Source cves: CVE-2026-96749 Source advisory: OSV:GHSA-V4X9-3549-CRWV...
capreolus (>=0.1.0, <=0.1.5), ckanext-nhm (>=3.7.1, <=6.9.8) +19 more potentially affected by CVE-2026-96749 via pymongo (3.9.0)
pymongo PYPI version 3.9.0 is affected by a known vulnerability. The following packages have a transitive dependency on pymongo and may be impacted: - capreolus =0.1.0, =3.7.1, =3.0.2, =3.7.0, =0.2.0, =0.0.2, =0.0.2, =0.9.2rc1, =0.0.2, =0.1.2, =0.0.1, =0.0.8 and more Source cves: CVE-2026-96749...