74606 matches found
PYSEC-2026-3562 `datamodel-code-generator` vulnerable to code execution on import via `x-python-type` JSON-Schema extension in datamodel-code-generator
Summary datamodel-code-generator honours a custom x-python-type JSON-Schema extension that lets a schema author override the generated Python type for a field. The value is forwarded verbatim into the generated Python source as the field annotation, with a single sanitisation pass that is trivial...
datamodel-code-generator vulnerable to code injection via `x-python-import` / `customTypePath` in generated import statements
SummaryA malicious input schema OpenAPI / JSON Schema can execute arbitrary Python code on the machine that imports the generated model. The x-python-import and customTypePath schema extensions flow, unsanitized, into the import statements datamodel-code-generator emits. A newline embedded in the...
PYSEC-2026-3551 AWS Bedrock AgentCore: Improper neutralization of argument delimiters in the Python SDK install_packages()
Summary The AWS Bedrock AgentCore Python SDK bedrock-agentcore provides tools for building AI agents, including a Code Interpreter client that installs Python packages into a managed sandbox. An issue exists where, under certain circumstances, improper neutralization of argument delimiters in the...
dike (>=0.1.0, <=0.4.0), liara (>=2.1.0, <=2.3.2) +9 more potentially affected by CVE-2026-61632 via pymdown-extensions (8.2.0)
pymdown-extensions PYPI version 8.2.0 is affected by a known vulnerability. The following packages have a transitive dependency on pymdown-extensions and may be impacted: - dike =0.1.0, =2.1.0, =0.1.0, =0.19.1, =0.13.0, =0.3.0, =2.2.0, =0.1.0, =0.1.6 Source cves: CVE-2026-61632 Source advisory:...
cewler (1.2.0.post1), python-xdoc (>=0.1.0, <=0.1.1) potentially affected by CVE-2026-59938 via pypdf (4.0.1)
pypdf PYPI version 4.0.1 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - cewler 1.2.0.post1 - python-xdoc =0.1.0, =0.1.1 Source cves: CVE-2026-59938 Source advisory: OSV:PYSEC-2026-3611...
cewler (1.2.0.post1), python-xdoc (>=0.1.0, <=0.1.1) potentially affected by CVE-2026-59935 via pypdf (4.0.1)
pypdf PYPI version 4.0.1 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - cewler 1.2.0.post1 - python-xdoc =0.1.0, =0.1.1 Source cves: CVE-2026-59935 Source advisory: OSV:PYSEC-2026-3613...
cewler (1.2.0.post1), python-xdoc (>=0.1.0, <=0.1.1) potentially affected by CVE-2026-59936 via pypdf (4.0.1)
pypdf PYPI version 4.0.1 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - cewler 1.2.0.post1 - python-xdoc =0.1.0, =0.1.1 Source cves: CVE-2026-59936 Source advisory: OSV:PYSEC-2026-3612...
ai-enterprise-agent (>=0.0.4, <=0.0.9), almax-common (>=1.0.5.dev20240601224039, <=1.0.7.dev20240801212517) +25 more potentially affected by CVE-2026-59937 via pypdf (4.2.0)
pypdf PYPI version 4.2.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - ai-enterprise-agent =0.0.4, =1.0.5.dev20240601224039, =2024.7.4, =0.6.22, =0.2.1, =0.2.0, =0.0.5, =0.2.1, =3.3.2, =0.1.0, =0.0.1, =4.7.1, =0.1.0, =0.1...
cewler (1.2.0.post1), python-xdoc (>=0.1.0, <=0.1.1) potentially affected by CVE-2026-59937 via pypdf (4.0.1)
pypdf PYPI version 4.0.1 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - cewler 1.2.0.post1 - python-xdoc =0.1.0, =0.1.1 Source cves: CVE-2026-59937 Source advisory: OSV:PYSEC-2026-3610...
MAL-2026-11519 Malicious code in launchdarkly-ai-server-sdk (PyPI)
--- -= Per source details. Do not edit below this line.=- Source: amazon-inspector 460d36c416400537f8c90171c7821b191e0af69df3ec9f0c906300f50b0ea93f launchdarkly-ai-server-sdk 1.0.1 pypi was scanned across 7 files with no a static rule matches and no traced behavior of concern. No install-time or...
Malicious code in psbt-utils (PyPI)
--- -= Per source details. Do not edit below this line.=- Source: amazon-inspector 40293a9b1851f25decc83d08f82fab01f1f373d95e13dc937575b7182d470720 psbt-utils presents itself as a PSBT/Bitcoin wallet signing library handling WIF and hex private keys. update.py contains a fetchanddecrypt loader th...
Security Bulletin:IDNA for Python Vulnerability: Resource Consumption and Denial-of-Service Risk with Long Inputs
Summary Internationalized Domain Names in Applications IDNA for Python provides support for Internationalized Domain Names in Applications IDNA and Unicode IDNA Compatibility Processing. In versions prior to 3.15, payloads such as "\u0660" N or "\u30fb" N + "\u6f22" utilize the validcontexto...
Exploit for CVE-2026-21016
--- CVE-2026-21016 – Malicious PyPI Package Install Hook se...
[SECURITY] Fedora 44 Update: python-nh3-0.3.6-4.fc44
Python binding to Ammonia HTML sanitizer Rust crate...
1m-handshake (>=0.1.3, <=0.1.7), 360solutions-bc-mcp (>=0.5.3, <=0.5.6) +3157 more potentially affected by CVE-2026-69247 via cryptography (>=44.0.0, <=49.0.0)
cryptography PYPI version =44.0.0, =0.1.3, =0.5.3, =2.3.0, =0.1.0, =0.1.1, =2.4.15, =0.45.0.dev1, =0.46.2 and more Source cves: CVE-2026-69247 Source advisory: SNYK:PYTHON-CRYPTOGRAPHY-18516621...
PT-2026-73547
TuxCare rebuilt python-multipart to address 1 CVE. Fixed in 0.0.6.post1+tuxcare...
PT-2026-73717
TuxCare rebuilt python-multipart to address 1 CVE. Fixed in 0.0.6.post2+tuxcare...
PT-2026-67861
Name of the Vulnerable Software and Affected Versions Open WebUI versions 0.9.6 through 0.10.x Description The built-in knowledge search tools allow a chat participant to specify a pattern used to grep knowledge files. When patterns contain regex metacharacters, they are compiled using Python's...
PT-2026-75375
TuxCare rebuilt python-multipart to address 1 CVE. Fixed in 0.0.6.post6+tuxcare...
RHEL 8 / 9 : Red Hat Ansible Automation Platform 2.5 Product Security and Bug Fix Update (Important) (RHSA-2026:50319)
The remote Redhat Enterprise Linux 8 / 9 host has packages installed that are affected by multiple vulnerabilities as referenced in the RHSA-2026:50319 advisory. Red Hat Ansible Automation Platform provides an enterprise framework for building, deploying and managing IT automation at scale. IT...