74152 matches found
Langflow AI Custom Component Authenticated RCE
Langflow versions 1.0.0 through 1.11.1 are susceptible to authenticated remote code execution due to improper enforcement of security restrictions of code generation on the /api/v1/customcomponent endpoint. The endpoint accepts attacker controlled code that is then passed to Python's exec functio...
OPENSUSE-SU-2026:11635-1 python313-uv-0.12.7-1.1 on GA media
These are all security issues fixed in the python313-uv-0.12.7-1.1 package on the GA media of openSUSE Tumbleweed...
CVE-2026-55485: Exposure of Sensitive Information to an Unauthorized Actor
Piccolo Admin is an admin interface and content management system for Python, built on top of Piccolo. Prior to 1.14.0, piccoloadmin/endpoints.py uses superuservalidators to block PUT, PATCH, DELETE, and POST requests by non-superusers but permits GET requests to configured user and session table...
Langflow AI authenticated RCE
Langflow versions 1.11.1 and below are susceptible to authenticated remote code execution. By saving a flow where data.type is empty, an authenticated user can bypass the flow guard and execute arbitrary Python code. Module Options msf use exploit/multi/http/langflow/authrcecve202619295 msf...
PT-2026-83301
BISHENG before 2.6.0 contains a remote code execution vulnerability in the workflow run once endpoint that allows authenticated users to execute arbitrary Python code. Attackers can submit crafted Code node definitions to the POST /api/v1/workflow/run once endpoint, which executes them with exec...
WS-2026-0038
mcpgateway.services.promptservice.PromptService renders user-supplied prompt templates using Jinja2 plain Environment instead of SandboxedEnvironment. An authenticated user with permission to register or update prompt templates can store a malicious template that, on subsequent rendering, execute...
openSUSE 16 Security Update : python-pip (openSUSE-SU-2026:21643-1)
The remote openSUSE 16 host has packages installed that are affected by a vulnerability as referenced in the openSUSE- SU-2026:21643-1 advisory. This update for python-pip fixes the following issue: - CVE-2026-13346: incorrect handling of doubly-encoded package URLs from malicious indexes allows...
Python Library OpenEXR 3.4.0 < 3.4.14 DoS (CVE-2026-68516)
The version of the OpenEXR Python package installed on the remote host is 3.4.x prior to 3.4.14. It is, therefore, affected by a denial of service vulnerability: - A crafted HTJ2K-compressed EXR whose JPEG 2000 SIZ fields place the first tile outside the visible image can reach invalid tile and...
Fedora 44 : pyOpenSSL / python-cryptography / python-pynitrokey (2026-9f07e6bc2b)
The remote Fedora 44 host has packages installed that are affected by a vulnerability as referenced in the FEDORA-2026-9f07e6bc2b advisory. Includes a fix for CVE-2026-69247, refer to https://github.com/pyca/cryptography/security/advisories/GHSA-g6cj-pr64-35w5 for a more detailed description. Ful...
Python Library OpenEXR 3.4.0 < 3.4.13 DoS (CVE-2026-53532)
The version of the OpenEXR Python package installed on the remote host is 3.4.x prior to 3.4.13. It is, therefore, affected by a denial of service vulnerability: - A crafted HTJ2K-compressed EXR file causes an unconditional process abort in any application that calls exrstartread on untrusted...
GHSA-6HX8-3WJJ-GR8G WebOb: Open redirect in Location header normalization via leading C0 control / space characters
Summary This is a third follow-up to CVE-2024-42353 / GHSA-mg3v-6m49-jhp3 and CVE-2026-44889 / GHSA-fh3h-vg37-cc95. WebOb makes the Location header absolute when it serves a redirect. To stop a relative or protocol-relative target from redirecting users off-host, it checks the value for a URI...
Security Bulletin: IBM Maximo Application Suite - Monitor Component uses kafka_python-2.3.0-py2.py3-none-any.wh which is vulnerable to multiple CVEs.
Summary IBM Maximo Application Suite - Monitor Component uses kafkapython-2.3.0-py2.py3-none-any.wh which is vulnerable to CVE-2026-10142, CVE-2026-10143. This bulletin contains information addressing the vulnerability. Vulnerability Details CVEID:CVE-2026-10142 DESCRIPTION: kafka-python prior to...
CVE-2026-10036 SpeechBrain < 1.1.1 Arbitrary Code Execution via CKPT.yaml Parsing
SpeechBrain before 1.1.1 contains an arbitrary code execution vulnerability that allows attackers to execute arbitrary code by supplying a crafted CKPT.yaml checkpoint metadata file parsed with PyYAML's unsafe loader during candidate enumeration in Checkpointer.recoverifpossible. Attackers can...
Security Bulletin: Multiple vulnerabilities that affects IBM Db2 Genius Hub
Summary The following dependency packages are being used by IBM Db2 Genius Hub had vulnerabilties which were resolved. - fastapi, follow-redirects, dompurify, bn.js, elliptic, form-data, js-yaml, poetry, golang.org/x/text, transformers, qs, langchain, brace-expansion, echarts, golang.org/x/sys,...
PYSEC-2026-3739
NLTK before 3.10.3 contains an uncontrolled recursion vulnerability in nltk.featstruct.FeatStructReader that allows unauthenticated attackers to cause a denial of service by supplying deeply nested feature-structure input. Attackers can craft trivial payloads with nested brackets that exceed...
PYSEC-2026-3964
opensslencrypt pip package openssl-encrypt versions = 1.4.8 do not redact the keyserver bearer token passed as the positional argument to 'keyserver set-token' in the --debug argv dump, because sanitizeargvfordebug fails to sanitize it. As a result the token is printed in cleartext to stderr unde...
UBUNTU-CVE-2026-81726
NLTK through 3.10.3 contains a path traversal vulnerability in model-artifact APIs that bypass pathsec enforcement by using raw file operations on caller-controlled paths. Attackers can read or write files outside allowed sandbox roots through TransitionParser, AveragedPerceptron, PerceptronTagge...
PYSEC-2026-3779
opensslencrypt versions before 1.4.9 fail to validate encryption status of embedded post-quantum private keys in file metadata. Attackers can craft files with unencrypted embedded PQC keys that decrypt under any password, bypassing authentication and producing attacker-chosen plaintext with false...
PYSEC-2026-3776
opensslencrypt versions before 1.4.9 contain a shell injection vulnerability in the info command's reconstructed CLI block that interpolates untrusted metadata fields without quoting. Attackers can craft metadata values like peppername containing shell commands that execute when users copy the...
CVE-2026-81724
NLTK before 3.10.3 contains an uncontrolled recursion vulnerability in nltk.featstruct.FeatStructReader that allows unauthenticated attackers to cause a denial of service by supplying deeply nested feature-structure input. Attackers can craft trivial payloads with nested brackets that exceed...