2242 matches found
ethpm (>=0.1.4a2, <=0.1.4a7), pytest-ethereum (>=0.1.2a2, <=0.1.3a4) +1 more potentially affected by CVE-2025-21607 via vyper (0.5.0b1)
vyper PYPI version 0.5.0b1 is affected by a known vulnerability. The following packages have a transitive dependency on vyper and may be impacted: - ethpm =0.1.4a2, =0.1.2a2, =0.1.2b6, =0.1.2b7 Source cves: CVE-2025-21607 Source advisory: OSV:GHSA-VGF2-GVX8-XWC3...
[SECURITY] Fedora 41 Update: pytest-8.3.4-1.fc41
The pytest framework makes it easy to write small tests, yet scales to support complex functional testing for applications and libraries...
Fedora 41 : pytest (2024-b747462264)
The remote Fedora 41 host has a package installed that is affected by a vulnerability as referenced in the FEDORA-2024-b747462264 advisory. Update to pytest 8.3.4 Tenable has extracted the preceding description block directly from the Fedora security advisory. Note that Nessus has not tested for...
OPENSUSE-SU-2024:14561-1 python310-pytest-html-4.1.1-4.1 on GA media
These are all security issues fixed in the python310-pytest-html-4.1.1-4.1 package on the GA media of openSUSE Tumbleweed...
MAL-2025-960 Malicious code in pytest-tt-ddriven (PyPI)
--- -= Per source details. Do not edit below this line.=- Source: kam193 0fc281f8b24ee3d2420a1c1b3815d5c6a9a9420e0baebe4ea975d530181606a0 Importing the module triggers sending out the hostname to the package author. It looks to be a placeholder/pentest activity related to BytedDance. --- Category...
Malicious code in pytest-tt-ddriven (PyPI)
--- -= Per source details. Do not edit below this line.=- Source: kam193 0fc281f8b24ee3d2420a1c1b3815d5c6a9a9420e0baebe4ea975d530181606a0 Importing the module triggers sending out the hostname to the package author. It looks to be a placeholder/pentest activity related to BytedDance. --- Category...
OPENSUSE-SU-2024:14433-1 python310-pytest-html-4.1.1-3.1 on GA media
These are all security issues fixed in the python310-pytest-html-4.1.1-3.1 package on the GA media of openSUSE Tumbleweed...
OPENSUSE-SU-2024:14403-1 python310-pytest-html-4.1.1-2.1 on GA media
These are all security issues fixed in the python310-pytest-html-4.1.1-2.1 package on the GA media of openSUSE Tumbleweed...
Security Bulletin: Vulnerability in pytest-dev py affects IBM watsonx.data
Summary pytest-dev py is vulnerable to a denial of service, caused by a regular expression denial of service ReDoS flaw by the InfoSvnCommand argument. By sending a specially-crafted regex info data, a remote attacker could exploit this vulnerability to cause a denial of service condition. This c...
Exploit for CVE-2024-39700
CVE-2024-39700 Proof of Concept Repositories created using th...
autodoraemon (>=1.0.0, <=1.0.8), dash-tools (>=0.16.0, <=1.8.2) +3 more potentially affected by CVE-2024-6345 via setuptools (47.1.0)
setuptools PYPI version 47.1.0 is affected by a known vulnerability. The following packages have a transitive dependency on setuptools and may be impacted: - autodoraemon =1.0.0, =0.16.0, =0.0.2, =1.0.1, =1.0.35 Source cves: CVE-2024-6345 Source advisory: OSV:GHSA-CX63-2MW6-8HW5...
MAL-2024-5287 Malicious code in jupyter-pytest-fi-console (PyPI)
--- -= Per source details. Do not edit below this line.=-...
Malicious code in jupyter-pytest-fi-console (PyPI)
--- -= Per source details. Do not edit below this line.=-...
CLSA-2024-1718192341 Update of alt-php
Bump epoch Disable ESM notification after installation: - remove ESM hook for apt-system - remove ESM infra/apps repositories from apt sources list Automatically mark some pytest to skip if FIPS kernel is running in a disabled state they always fail in this mode...
PT-2024-41912
Bump epoch Disable ESM notification after installation: - remove ESM hook for apt-system - remove ESM infra/apps repositories from apt sources list Automatically mark some pytest to skip if FIPS kernel is running in a disabled state they always fail in this mode...
Oracle Linux 8 : python27:2.7 (ELSA-2024-2987)
The remote Oracle Linux 8 host has packages installed that are affected by multiple vulnerabilities as referenced in the ELSA-2024-2987 advisory. - Fix CVE-2021-20095 Resolves: rhbz1955615 - Fix CVE-2019-6446 - Fix CVE-2014-1858, CVE-2014-1859: 1062009, 1062359 - Security fix for CVE-2022-48560...
python27:2.7 security update
babel 2.5.1-10 - Fix CVE-2021-20095 Resolves: rhbz1955615 2.5.1-9 - Bumping due to problems with modular RPM upgrade path - Resolves: rhbz1695587 2.5.1-8 - Fix unversioned requires/buildrequires - Resolves: rhbz1628242 2.5.1-7 - Remove unversioned binaries - Resolves: rhbz1613343 2.5.1-6 - Make...
RHEL 8 : python27:2.7 (RHSA-2023:5990)
The remote Redhat Enterprise Linux 8 host has packages installed that are affected by a vulnerability as referenced in the RHSA-2023:5990 advisory. Python is an interpreted, interactive, object-oriented programming language that supports modules, classes, exceptions, high-level dynamic data types...
ansible-role-chrony (>=1.0.3, <=1.3.0), hive-builder (>=2.2.0, <=2.3.1) +2 more potentially affected by CVE-2023-5115 via ansible (2.10.0rc1)
ansible PYPI version 2.10.0rc1 is affected by a known vulnerability. The following packages have a transitive dependency on ansible and may be impacted: - ansible-role-chrony =1.0.3, =2.2.0, =0.0.1, =2.7.1 - pytest-ansible 2.2.3 Source cves: CVE-2023-5115 Source advisory: OSV:GHSA-JPVW-P8PR-9G2X...
homeassistant-stubs (2021.4.0b4), pytest-homeassistant-custom-component (0.3.0) potentially affected by CVE-2023-50715 via homeassistant (2021.4.0b4)
homeassistant PYPI version 2021.4.0b4 is affected by a known vulnerability. The following packages have a transitive dependency on homeassistant and may be impacted: - homeassistant-stubs 2021.4.0b4 - pytest-homeassistant-custom-component 0.3.0 Source cves: CVE-2023-50715 Source advisory:...