155 matches found
CVE-2024-36039_PoC
CVE-2024-36039: PyMySQL Object Injection to SQL Injection PoC A complete, reproducible Proof of Concept PoC laboratory for CVE-2024-36039 , demonstrating how an Object Injection vulnerability in PyMySQL versions = 1.1.0 can be escalated to a full SQL Injection using MariaDB's ODBC Escape Sequence...
Oracle Linux 8 : python36:3.6 (ELSA-2026-82858)
The remote Oracle Linux 8 host has packages installed that are affected by a vulnerability as referenced in the ELSA-2026-82858 advisory. - Fix CVE-2021-27291: ReDos via crafted malicious input Resolves: rhbz1943459 rhbz1943460 python-pymongo - Backport CVE-2026-88029 python-PyMySQL - Security fi...
python313-PyMySQL-1.2.0-1.2 on GA media (moderate)
python313-PyMySQL-1.2.0-1.2 on GA media Announcement ID: openSUSE-SU-2026:11995-1 Rating: moderate Cross-References: CVE-2024-36039 CVSS scores: CVE-2024-36039 SUSE : 8.1 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H Affected Products: openSUSE Tumbleweed An update that solves one vulnerability ca...
OPENSUSE-SU-2026:11995-1 python313-PyMySQL-1.2.0-1.2 on GA media
These are all security issues fixed in the python313-PyMySQL-1.2.0-1.2 package on the GA media of openSUSE Tumbleweed...
PT-2026-105704
These are all security issues fixed in the python313-PyMySQL-1.2.0-1.2 package on the GA media of openSUSE Tumbleweed...
Rocky Linux 9 [CIQ] Security Update: python3.11-PyMySQL / python3.11-PyMySQL+rsa (crlsa-2024_9194)
The Rocky Linux 9 host has packages installed that are affected by a vulnerability as referenced in the CIQ crlsa-20249194 advisory. python-pymysql: SQL injection if used with untrusted JSON input CVE-2024-36039 Tenable has extracted the preceding description block directly from the CIQ security...
Rocky Linux 9 [CIQ] Security Update: python3.12-PyMySQL / python3.12-PyMySQL+rsa (crlsa-2024_9193)
The Rocky Linux 9 host has packages installed that are affected by a vulnerability as referenced in the CIQ crlsa-20249193 advisory. python-pymysql: SQL injection if used with untrusted JSON input CVE-2024-36039 Tenable has extracted the preceding description block directly from the CIQ security...
Rocky Linux 8.6 [CIQ] Security Update: python39-PyMySQL Multiple Vulnerabilities (ciqsa-2026_0758)
The Rocky Linux 8.6 host has a package installed that is affected by multiple vulnerabilities as referenced in the CIQ ciqsa-20260758 advisory. This advisory aggregates security fixes for the python-PyMySQL SRPM in CIQ LTS 8.6. It addresses 4 CVEs: CVE-2015-20107, CVE-2020-10735, CVE-2021-28861,...
Rocky Linux 8.8 [CIQ] Security Update: python39-PyMySQL (ciqsa-2026_1144)
The Rocky Linux 8.8 host has a package installed that is affected by a vulnerability as referenced in the CIQ ciqsa-20261144 advisory. This advisory aggregates security fixes for the python-PyMySQL SRPM in CIQ LTS 8.8. It addresses 1 CVE: CVE-2024-6345. Tenable has extracted the preceding...
Rocky Linux 8 [CIQ] Security Update: python3.12-PyMySQL (crlsa-2024_4245)
The Rocky Linux 8 host has a package installed that is affected by a vulnerability as referenced in the CIQ crlsa-20244245 advisory. python-pymysql: SQL injection if used with untrusted JSON input CVE-2024-36039 Tenable has extracted the preceding description block directly from the CIQ security...
Rocky Linux 8.6 [CIQ] Security Update: python38-PyMySQL Multiple Vulnerabilities (ciqsa-2026_0215)
The Rocky Linux 8.6 host has a package installed that is affected by multiple vulnerabilities as referenced in the CIQ ciqsa-20260215 advisory. This advisory aggregates security fixes for the python-PyMySQL SRPM in CIQ LTS 8.6. It addresses 4 CVEs: CVE-2015-20107, CVE-2020-10735, CVE-2021-28861,...
Rocky Linux 8 [CIQ] Security Update: python3.11-PyMySQL (crlsa-2024_4244)
The Rocky Linux 8 host has a package installed that is affected by a vulnerability as referenced in the CIQ crlsa-20244244 advisory. python-pymysql: SQL injection if used with untrusted JSON input CVE-2024-36039 Tenable has extracted the preceding description block directly from the CIQ security...
Rocky Linux 8.6 [CIQ] Security Update: python2-PyMySQL Multiple Vulnerabilities (ciqsa-2026_0181)
The Rocky Linux 8.6 host has a package installed that is affected by multiple vulnerabilities as referenced in the CIQ ciqsa-20260181 advisory. This advisory aggregates security fixes for the python-PyMySQL SRPM in CIQ LTS 8.6. It addresses 4 CVEs: CVE-2015-20107, CVE-2023-32681, CVE-2022-45061,...
CLSA-2026-1768435940 TuxCare security update for pymysql (1 CVE)
TuxCare rebuilt pymysql to address 1 CVE. Fixed in 0.10.1.post1+tuxcare...
PT-2026-73701
TuxCare rebuilt pymysql to address 1 CVE. Fixed in 0.10.1.post1+tuxcare...
data-integration-babel (>=0.3.0, <=0.5.0), dbfactory (>=1.0.4, <=1.0.10) +9 more potentially affected by CVE-2024-36039 via pymysql (0.10.0)
pymysql PYPI version 0.10.0 is affected by a known vulnerability. The following packages have a transitive dependency on pymysql and may be impacted: - data-integration-babel =0.3.0, =1.0.4, =0.2.0, =2.2.6, =1.0.0, =0.2.2, =0.6.10, =1.42.14, =9.4.219.dev3, =10.0.71 - telegraf-pyplug 0.1.1 Source...
PyMySQL SQL Injection vulnerability
PyMySQL through 1.1.0 allows SQL injection if used with untrusted JSON input because keys are not escaped by escapedict...
aiida-abinit (0.3.0), aiida-bader (0.0.6) +146 more potentially affected by CVE-2024-36039 via pymysql (0.9.3)
pymysql PYPI version 0.9.3 is affected by a known vulnerability. The following packages have a transitive dependency on pymysql and may be impacted: - aiida-abinit 0.3.0 - aiida-bader 0.0.6 - aiida-codtools =2.0.0, =0.1.0, =1.1.4, =0.5.0, =1.0.0a1, =0.2.0, =3.0.0a6, =0.1.0b0, =0.1.0, =1.0.2,...
aiomysql (>=0.0.17, <=0.0.20), autox (>=0.0.2, <=0.2.3) +21 more potentially affected by CVE-2024-36039 via pymysql (0.9.2)
pymysql PYPI version 0.9.2 is affected by a known vulnerability. The following packages have a transitive dependency on pymysql and may be impacted: - aiomysql =0.0.17, =0.0.2, =2024.4.1, =0.1.1, =0.0.5a0, =19.7.0, =2.0.0, =4.0.0, =1.0.13, =1.0.26 and more Source cves: CVE-2024-36039 Source...
abadpour (>=6.13.1, <=6.47.1), abcli (>=8.194.1, <=9.254.1) +60 more potentially affected by CVE-2024-36039 via pymysql (0.10.1)
pymysql PYPI version 0.10.1 is affected by a known vulnerability. The following packages have a transitive dependency on pymysql and may be impacted: - abadpour =6.13.1, =8.194.1, =0.2.3, =0.0.1, =0.1.0, =0.1.0, =2.0.0b3, =0.0.1, =2.1.1, =0.1.0, =0.1.0, =1.7.0, =1.5.0, =4.2.1, =4.357.1 and more...