Lucene search
+L

58 matches found

NVD
NVD
•added 2026/09/22 8:16 a.m.•12 views

CVE-2026-87081

Net::IDN::UTS46 versions before 2.590 for Perl allow CPU exhaustion via quadratic punycode encoding of an overlong label before the length check in toascii. toascii punycode encodes each label and only then applies the 63-byte DNS limit. encodepunycode in both backends follows the sample...

7.5CVSS0.0063EPSS
SaveExploits0References4
OSV
OSV
•added 2026/09/22 8:16 a.m.•7 views

UBUNTU-CVE-2026-87081

Net::IDN::UTS46 versions before 2.590 for Perl allow CPU exhaustion via quadratic punycode encoding of an overlong label before the length check in toascii. toascii punycode encodes each label and only then applies the 63-byte DNS limit. encodepunycode in both backends follows the sample...

7.5CVSS5.7AI score0.0063EPSS
SaveExploits0References6
Vulnrichment
Vulnrichment
•added 2026/09/22 7:25 a.m.•11 views

CVE-2026-87081 Net::IDN::UTS46 versions before 2.590 for Perl allow CPU exhaustion via quadratic punycode encoding of an overlong label before the length check in to_ascii

Net::IDN::UTS46 versions before 2.590 for Perl allow CPU exhaustion via quadratic punycode encoding of an overlong label before the length check in toascii. toascii punycode encodes each label and only then applies the 63-byte DNS limit. encodepunycode in both backends follows the sample...

5.7AI score0.0063EPSS
SaveExploits0References3
CVE
CVE
•added 2026/09/22 7:25 a.m.•27 views

CVE-2026-87081

The Net::IDN::UTS46 Perl module (versions before 2.590 ) is vulnerable to CPU exhaustion due to quadratic punycode encoding of overlong labels within the to_ascii function. The encode_punycode function, following RFC 3492, performs an outer loop for each distinct non-ASCII code point while scanni...

7.5CVSS5.7AI score0.0063EPSS
SaveExploits0References4
Positive Technologies
Positive Technologies
•added 2026/09/22 12:00 a.m.•3 views

PT-2026-96672

Name of the Vulnerable Software and Affected Versions Net::IDN::UTS46 versions prior to 2.590 Description An issue exists where CPU exhaustion can occur due to quadratic punycode encoding of an overlong label. This happens because the to ascii function performs punycode encoding on each label...

7.5CVSS5.8AI score0.0063EPSS
SaveExploits0References8
Tenable Nessus
Tenable Nessus
•added 2026/09/22 12:00 a.m.•14 views

Linux Distros Unpatched Vulnerability : CVE-2026-87081

The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - Net::IDN::UTS46 versions before 2.590 for Perl allow CPU exhaustion via quadratic punycode encoding of an overlong label before the length check in toascii...

7.5CVSS5.8AI score0.0063EPSS
SaveExploits0References3
Rapid7 Vulnerability Database (full)
Rapid7 Vulnerability Database (full)
•added 2026/09/22 12:00 a.m.•10 views

CVE-2026-87081: Inefficient Algorithmic Complexity

Net::IDN::UTS46 versions before 2.590 for Perl allow CPU exhaustion via quadratic punycode encoding of an overlong label before the length check in toascii. toascii punycode encodes each label and only then applies the 63-byte DNS limit. encodepunycode in both backends follows the sample...

7.5CVSS5.7AI score0.0063EPSS
SaveExploits0References2
UbuntuCve
UbuntuCve
•added 2026/09/22 12:00 a.m.•11 views

CVE-2026-87081

Net::IDN::UTS46 versions before 2.590 for Perl allow CPU exhaustion via quadratic punycode encoding of an overlong label before the length check in toascii. toascii punycode encodes each label and only then applies the 63-byte DNS limit. encodepunycode in both backends follows the sample...

7.5CVSS5.8AI score0.0063EPSS
SaveExploits0References5
Tenable Nessus
Tenable Nessus
•added 2026/09/21 12:00 a.m.•12 views

SUSE SLED15 / SLES15 Security Update : perl-URI (SUSE-SU-2026:4046-1)

The remote SUSE Linux SLED15 / SLEDSAP15 / SLES15 / SLESSAP15 host has a package installed that is affected by a vulnerability as referenced in the SUSE-SU-2026:4046-1 advisory. This update for perl-URI fixes the following issue: - CVE-2026-19953: non-NFC host names encoded to non-standard punyco...

6.5CVSS5.9AI score0.00229EPSS
SaveExploits0References4
Cvelist
Cvelist
•added 2026/09/16 9:47 p.m.•44 views

CVE-2026-92598 Nodemailer before 9.1.0 IDN/Punycode Domain Allow-list Bypass

Nodemailer before 9.1.0 fails to apply UTS-46 normalization when encoding international domain names, causing the domain resolver to compute a different Punycode A-label than standards-compliant parsers. Attackers can craft recipient addresses with invisible characters or compatibility mappings...

8.3CVSS0.00395EPSS
SaveExploits0References4
OSV
OSV
•added 2026/09/10 1:16 a.m.•12 views

CLEANSTART-2026-VO23255 ToASCII and ToUnicode functions incorrectly accept Punycode-encoded labels that decode to an ASCII-only label

Multiple security vulnerabilities affect the metallb package. The ToASCII and ToUnicode functions incorrectly accept Punycode-encoded labels that decode to an ASCII-only label. See references for individual vulnerability details...

9.8CVSS5.8AI score0.00692EPSS
SaveExploits2References43
Tenable Nessus
Tenable Nessus
•added 2026/09/09 12:00 a.m.•18 views

openSUSE 16 Security Update : perl-URI (openSUSE-SU-2026:21773-1)

The remote openSUSE 16 host has a package installed that is affected by a vulnerability as referenced in the openSUSE- SU-2026:21773-1 advisory. This update for perl-URI fixes the following issue: - CVE-2026-19953: non-NFC host names encoded to non-standard punycode labels due to missing...

6.5CVSS6AI score0.00229EPSS
SaveExploits0References3
SUSE Linux
SUSE Linux
•added 2026/09/08 7:06 a.m.•16 views

Security update for perl-URI

This update for perl-URI fixes the following issue: CVE-2026-19953: non-NFC host names encoded to non-standard punycode labels due to missing normalization in nameprep bsc1277886. Patch Instructions: To install this SUSE update use the SUSE recommended installation methods like YaST onlineupdate ...

6.9CVSS5.9AI score0.00229EPSS
SaveExploits0References4
OSV
OSV
•added 2026/09/08 7:06 a.m.•7 views

SUSE-SU-2026:4070-1 Security update for perl-URI

This update for perl-URI fixes the following issue: - CVE-2026-19953: non-NFC host names encoded to non-standard punycode labels due to missing normalization in nameprep bsc1277886...

6.5CVSS5.9AI score0.00229EPSS
SaveExploits0References3
OSV
OSV
•added 2026/09/08 1:30 a.m.•34 views

CLEANSTART-2026-PE88816 ToASCII and ToUnicode functions incorrectly accept Punycode-encoded labels that decode to an ASCII-only label

Multiple security vulnerabilities affect the helm-operator package. The ToASCII and ToUnicode functions incorrectly accept Punycode-encoded labels that decode to an ASCII-only label. See references for individual vulnerability details...

9.8CVSS6.8AI score0.00873EPSS
SaveExploits6References151
OSV
OSV
•added 2026/09/07 1:53 p.m.•6 views

SUSE-SU-2026:4046-1 Security update for perl-URI

This update for perl-URI fixes the following issue: - CVE-2026-19953: non-NFC host names encoded to non-standard punycode labels due to missing normalization in nameprep bsc1277886...

6.5CVSS5.9AI score0.00229EPSS
SaveExploits0References3
SUSE Linux
SUSE Linux
•added 2026/09/07 1:53 p.m.•12 views

Security update for perl-URI

This update for perl-URI fixes the following issue: CVE-2026-19953: non-NFC host names encoded to non-standard punycode labels due to missing normalization in nameprep bsc1277886. Patch Instructions: To install this SUSE update use the SUSE recommended installation methods like YaST onlineupdate ...

6.9CVSS5.9AI score0.00229EPSS
SaveExploits0References4
OSV
OSV
•added 2026/09/06 4:46 p.m.•3 views

OPENSUSE-SU-2026:21773-1 Security update for perl-URI

This update for perl-URI fixes the following issue: - CVE-2026-19953: non-NFC host names encoded to non-standard punycode labels due to missing normalization in nameprep bsc1277886...

6.5CVSS5.9AI score0.00229EPSS
SaveExploits0References2
OSV
OSV
•added 2026/09/05 3:02 p.m.•7 views

OESA-2026-3591 perl-URI security update

This module implements the URI class. Objects of this class represent "Uniform Resource Identifier references" as specified in RFC 2396 and updated by RFC 2732. Security Fixes: URI versions before 5.36 for Perl encode non-NFC host names to non-standard punycode labels via missing normalization in...

9.8CVSS5.8AI score0.00229EPSS
SaveExploits0References2
OSV
OSV
•added 2026/09/05 3:02 p.m.•8 views

OESA-2026-3590 perl-URI security update

This module implements the URI class. Objects of this class represent "Uniform Resource Identifier references" as specified in RFC 2396 and updated by RFC 2732. Security Fixes: URI versions before 5.36 for Perl encode non-NFC host names to non-standard punycode labels via missing normalization in...

9.8CVSS5.8AI score0.00229EPSS
SaveExploits0References2
Rows per page
Query Builder