Lucene search
+L

17697 matches found

NVD
NVD
•added 2026/03/19 9:17 p.m.•24 views

CVE-2026-32622

SQLBot is an intelligent data query system based on a large language model and RAG. Versions 1.5.0 and below contain a Stored Prompt Injection vulnerability that chains three flaws: a missing permission check on the Excel upload API allowing any authenticated user to upload malicious terminology,...

8.8CVSS0.00584EPSS
SaveExploits1References2
Cvelist
Cvelist
•added 2026/03/19 8:55 p.m.•42 views

CVE-2026-32622 SQLBot: Remote Code Execution via Terminology Poisoning

SQLBot is an intelligent data query system based on a large language model and RAG. Versions 1.5.0 and below contain a Stored Prompt Injection vulnerability that chains three flaws: a missing permission check on the Excel upload API allowing any authenticated user to upload malicious terminology,...

8.6CVSS0.00584EPSS
SaveExploits1References2
Mend
Mend
•added 2026/03/19 8:55 p.m.•8 views

CVE-2026-32622

SQLBot is an intelligent data query system based on a large language model and RAG. Versions 1.5.0 and below contain a Stored Prompt Injection vulnerability that chains three flaws: a missing permission check on the Excel upload API allowing any authenticated user to upload malicious terminology,...

8.8CVSS6AI score0.00584EPSS
SaveExploits1References4
Snyk
Snyk
•added 2026/03/19 6:31 p.m.•12 views

Improper Validation of Array Index

Overview Affected versions of this package are vulnerable to Improper Validation of Array Index in protocol parser components. An attacker can cause the application to crash or exhaust resources by sending specially crafted, malformed network packets to a monitored network interface. Note: This i...

5.9CVSS6.7AI score0.00251EPSS
SaveExploits0References2
EUVD
EUVD
•added 2026/03/19 3:31 p.m.•20 views

EUVD-2026-13115

A flaw was found in pgproto3. A malicious or compromised PostgreSQL server can exploit this by sending a DataRow message with a negative field length. This input validation vulnerability can lead to a denial of service DoS due to a slice bounds out of range panic...

7.5CVSS5.9AI score0.00086EPSS
SaveExploits0References7
NVD
NVD
•added 2026/03/19 3:16 p.m.•17 views

CVE-2026-4427

Rejected reason: Duplicate of CVE-2026-32286...

0.00086EPSS
SaveExploits0
osv_ubuntu
osv_ubuntu
•added 2026/03/19 3:16 p.m.•25 views

UBUNTU-CVE-2026-4427

A flaw was found in pgproto3. A malicious or compromised PostgreSQL server can exploit this by sending a DataRow message with a negative field length. This input validation vulnerability can lead to a denial of service DoS due to a slice bounds out of range panic...

7.5CVSS5.9AI score0.00086EPSS
SaveExploits0References8
UbuntuCve
UbuntuCve
•added 2026/03/19 3:16 p.m.•16 views

CVE-2026-4427

Rejected reason: Duplicate of CVE-2026-32286...

5.9AI score0.00086EPSS
SaveExploits0References7
attackerkb
attackerkb
•added 2026/03/19 2:24 p.m.•17 views

CVE-2026-4427

Duplicate of CVE-2026-32286...

7.1AI score0.00675EPSS
SaveExploits0References7
Debian CVE
Debian CVE
•added 2026/03/19 2:24 p.m.•21 views

CVE-2026-4427

Removed by vendor...

5.9AI score
SaveExploits0
CNNVD
CNNVD
•added 2026/03/19 12:00 a.m.•26 views

Number withdrawal

pgproto3 is a PostgreSQL protocol encoding library developed by Jack Christensen. This CVE number has been withdrawn...

5.8AI score0.00086EPSS
SaveExploits0References7
Rapid7 Vulnerability Database (full)
Rapid7 Vulnerability Database (full)
•added 2026/03/19 12:00 a.m.•10 views

CVE-2026-32622: Missing Authorization

SQLBot is an intelligent data query system based on a large language model and RAG. Versions 1.5.0 and below contain a Stored Prompt Injection vulnerability that chains three flaws: a missing permission check on the Excel upload API allowing any authenticated user to upload malicious terminology,...

8.8CVSS6AI score0.00584EPSS
SaveExploits1References1
Amazon
Amazon
•added 2026/03/19 12:00 a.m.•29 views

Important: postgresql

Issue Overview: Heap buffer overflow in PostgreSQL pgcrypto allows a ciphertext provider to execute arbitrary code as the operating system user running the database. Versions before PostgreSQL 18.2, 17.8, 16.12, 15.16, and 14.21 are affected. CVE-2026-2005 Affected Packages: postgresql Note: This...

8.8CVSS8.2AI score0.01372EPSS
SaveExploits5
Tenable Nessus
Tenable Nessus
•added 2026/03/19 12:00 a.m.•22 views

Amazon Linux 2 : postgresql, --advisory ALAS2-2026-3193 (ALAS-2026-3193)

The version of postgresql installed on the remote host is prior to 9.2.24-8. It is, therefore, affected by a vulnerability as referenced in the ALAS2-2026-3193 advisory. Heap buffer overflow in PostgreSQL pgcrypto allows a ciphertext provider to execute arbitrary code as the operating system user...

8.8CVSS8.2AI score0.01372EPSS
SaveExploits5References4
osv_suse
osv_suse
•added 2026/03/18 3:32 p.m.•20 views

SUSE-SU-2026:20906-1 Security update for postgresql17

This update for postgresql17 fixes the following issues: - Update to version 17.9. bsc1258754 - CVE-2026-2003: Guard against unexpected dimensions of oidvector/int2vector bsc1258008 - CVE-2026-2004: Harden selectivity estimators against being attached to operators that accept unexpected data type...

8.8CVSS6.8AI score0.01372EPSS
SaveExploits5References10
osv_opensuse
osv_opensuse
•added 2026/03/18 3:31 p.m.•13 views

OPENSUSE-SU-2026:20388-1 Security update for postgresql17

This update for postgresql17 fixes the following issues: - Update to version 17.9. bsc1258754 - CVE-2026-2003: Guard against unexpected dimensions of oidvector/int2vector bsc1258008 - CVE-2026-2004: Harden selectivity estimators against being attached to operators that accept unexpected data type...

8.8CVSS6.8AI score0.01372EPSS
SaveExploits5References9
Github Security Blog
Github Security Blog
•added 2026/03/18 1:00 p.m.•26 views

Denial of service in github.com/jackc/pgproto3/v2

The DataRow.Decode function fails to properly validate field lengths. A malicious or compromised PostgreSQL server can send a DataRow message with a negative field length, causing a slice bounds out of range panic...

7.5CVSS7.1AI score0.00675EPSS
SaveExploits0References7Affected Software1
osv_suse
osv_suse
•added 2026/03/18 8:31 a.m.•20 views

SUSE-SU-2026:20194-1 Security update for postgresql17 and postgresql18

This update for postgresql17 and postgresql18 fixes the following issues: Changes in postgresql17, postgresql18: Update to 17.7: https://www.postgresql.org/about/news/p-3171/ https://www.postgresql.org/docs/release/17.7/ bsc1253332, CVE-2025-12817: Missing check for CREATE privileges on the schem...

5.9CVSS6.3AI score0.00364EPSS
SaveExploits0References5
osv_opensuse
osv_opensuse
•added 2026/03/18 8:31 a.m.•17 views

OPENSUSE-SU-2026:20131-1 Security update for postgresql17 and postgresql18

This update for postgresql17 and postgresql18 fixes the following issues: Changes in postgresql17, postgresql18: Update to 17.7: https://www.postgresql.org/about/news/p-3171/ https://www.postgresql.org/docs/release/17.7/ bsc1253332, CVE-2025-12817: Missing check for CREATE privileges on the schem...

5.9CVSS6.3AI score0.00364EPSS
SaveExploits0References4
Tenable Nessus
Tenable Nessus
•added 2026/03/18 12:00 a.m.•17 views

MiracleLinux 8 : postgresql:15 (AXSA:2026-331:01)

The remote MiracleLinux 8 host has packages installed that are affected by multiple vulnerabilities as referenced in the AXSA:2026-331:01 advisory. postgresql: PostgreSQL missing validation of multibyte character length executes arbitrary code CVE-2026-2006 postgresql: PostgreSQL intarray missing...

8.8CVSS7.8AI score0.01372EPSS
SaveExploits5References5
Rows per page
Query Builder